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With RoboAuthor we designed an extremely easy-to-use tool
for creating professional Help systems and documentation for
web based and desktop software applications.


The need for online user assistance, for both desktop
programs and the new web-based applications, is more acute
than ever. In fact, with a good help system, not only will your end
users love you but you will have fewer support calls and emails:
two good reasons for developing extensive documentation.


You’d like a fast help creator tool, and possibly something that
is useable by a non-technician (you probably know that usually
anybody that is good at writing manuals is not always good at
programming, and vice-versa).


So we tried to create a tool both powerful and simple. I believe
we achieved our aim of bringing different worlds together in a
really practical way.


We are proud to provide you with this software which
expresses our philosophy: a love for design, simplicity in use,
interactivity and completeness.


We wish you success working with RoboAuthor and feel sure
you will gain almost as much satisfaction using it as we did
designing and writing it.


Ing. Aldo Ghigliano
President, Visual Vision


W
e


lc
o


m
e







Welcome 3


Table of Contents 4


Introducing RoboAuthor 5


1. Your first work
Inserting links; browsing links


7


2.  HTMLHelp and WinHelp publishing
WinHelp; HTML Help; Keywords and Table of Contents;
Importing WinHelp files; Exporting HTML; Browser
preview; Technical information


11


3. CD-ROM publishing 15


4. Main functions
Text format; Styles; Links; Images; Tables;


19


5. Frames and frame sets
Creating frames; Links; Floating frames;


28


6. Multimedia objects, applets
Sounds and video; Applets; Slides;


32


7. The “Special” links
Anchors; Showing windows; Links inside/to a frame set;
Showing windows without a click;


37


8. Advanced functions
HTML added to images, forms, objects; Hypertext on
CD; How to run programs or external files, also on CD;
Keywords;


43


9. Graphics and paging pages
Displaying information on screen; Everything’s relative;
Invisible tables; Backgrounds; Clickable maps, hot spots
and browsing bars; Frames; Don’t exaggerate!


47


10. Frequent questions 54


T
a


b
le


 o
f 


C
o


n
te


n
ts







R oboAuthor is a tool for creating
professional Help systems and documen-
tation for web-based and desktop software
applications.


It is an “ all-in-one”  environment, as it
doesn’ t require an external editor, and it
permits you to work on a single source
document. By creating and maintaining a
single document you can prepare your
manuals as .CHM (HTML Help format),
.HLP (WinHelp format), plain HTML for
your Web site, as well as multimedia/
hypermedia autoinstall CD-ROMs.


Despite the completeness of the availa-
ble functions, which may seem too much
at first sight, the program has been desi-
gned around immediacy and speed for
everyday work.


But RoboAuthor is not for everybody.
There are essentially two big differences
in comparison with “ ordinary”  editors.


Firstly, RoboAuthor is not for lovers of
“ HTML”  code and technical perfection:


you won’ t see any HTML code during
normal creation of Help files. The pro-
gram does support such tasks, but unless
you feel the need, you just don’ t have to
worry about these things. RoboAuthor in
fact is more similar to a WordProcessor
rather than to a technical tool... it just
allows you to “ print”  on CHM / HLP files
or on CD-ROM’s rather than on paper
(providing all the additional hypermedia
facilities, of course).


Secondly, RoboAuthor manages pages
as a complete set, rather than as stand-
alone pages. Every project is saved by
RoboAuthor as a single hypertext file in
its native .AEH format; up to 260000
hyperlinked pages and images into a sin-
gle file, and no “ broken links” .


This “ global”  vision does greatly
speed up your work, not just because you
manage your help system at once, but also
‘cause the RoboAuthor interface has been
specifically optimized for getting the most
from this design.


So, RoboAuthor is not only “ visual”
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ghts for the CDs you can create. You can
use them for distributing documentation
within your firm / company, but if you
need a global redistribution license you
need to upgrade to HyperPublish. Hyper-
Publish (hyperpublish.com) includes all
RoboAuthor functions, plus direct Internet
publishing, global redistribution license
for CDs, and several other features.


In conclusion, we want to repeat that
RoboAuthor is vastly different from an
ordinary HTML editor: it’ s not a code
editing tool (even though it is possible to
add code manually). As opposed to older
editors, that force people to concentrate on
the code, RoboAuthor leads the machine
to “ think hypertextual” . We are underli-
ning this point as this means a change of
mentality in people who are used to wri-
ting HTML, but, at the end of the day, it
makes everything easier for everybody,
not just for beginners.


RoboAuthor is a powerful tool for peo-
ple who want to work quickly and to be
free to think about what they’ re doing,
instead of getting confused with program-
ming, files or code. It has been designed to
match the requirements of modern
authors.


The application requires a PC with
MSWindows 95 or higher, even a old
Pentium I 100MHz, 32Mb of RAM and
32MB of free Hard Disk space.


We are sure you will appreciate both
our software, and the vast effort behind
producing it. Enjoy!


(WYSIWYG, What You See Is What
You Get), that means that you don’ t have
to write “ codes”  and that what you see in
editing mode is really what the end user
will see. RoboAuthor is also WYSIWYL
(What You See Is What You Link). This
means that all the links between pages
(i.e. words or pictures you can click on to
be carried to other pages/sections) can be
defined directly on screen and they’ ll be
immediately “ active” . Immediately
“ active”  does mean you can follow each
link from within the editor mode: just
double click on it! Furthermore, when you
select the destination page of a link, all the
dialogs do show a preview screen, in order
to make the selection even simpler. You
see a preview of the selected page, and
you can navigate within that preview (just
click the links), so you can reach the
required destination page by either name
or navigation. It’ s really much easier to
use than it is to explain!


The visual interface provides you with
the opportunity to use styles, tables, hot
spots, frame sets, slides, forms and to
show popup windows easily, and much
more...


As mentioned above, the output is not
limited only to CHM, HLP and HTML.
Ii’ s also very easy to create self-installing
CDs with an automatic internal search
engine. RoboAuthor has the ability to cre-
ate a “ draft”  of your CD which you can
then use with any common burning sof-
tware (Nero, EasyCD, etc...).


Please remember that the RoboAuthor
license doesn’ t include redistribution ri-







1 .  Y our f irs t w ork


Fig.1 will appear, ready for you to type
some text into the page. Enter a line or
two of text about vegetables and include
the word “ potatoes” .


The number “ 0”  shown in the central
text-box at the bottom of the current page,
indicates that we are on page “ 0” .


Now we can select a word, which is
done in the same way as in many other
applications; simply drag your mouse over
the word or double-click it: let’ s select
“ potatoes”  (See Fig.2), and now click the
Link button on your toolbar (the one with
the chain and a page on) as shown here:


The window in Fig.3 will be
shown; this is one of the most impor-
tant dialog windows, because it allows us
to define many link types, by simply choo-
sing one of the tabs on the top.


But let’ s get on: Choose the “ New
page”  tab (the last on the right) and press
the “ OK”  button. RoboAuthor will define
the link and, at the same time, will take us
to a new page, where we can provide more
information about potatoes.


O nce you have RoboAuthor in-
stalled on your PC, either from a CD or an
Internet distribution release, you will
doubtless be impatient to start.


The first thing to keep in mind is that
RoboAuthor operates on hypertext docu-
ments (on your whole manual), not on
single pages. This means that multiple
pages can be loaded in memory at the
same time. At any time, once they are
created, it is possible to browse pages,
create new links, navigate throughout a
file, or carry out a search. The easiest way
to pass from one page to another is using
CTRL+ and CTRL- keys.


Inser ting links
Linking pages is really very simple:


let’ s make a simple example now, by
creating a hypertext consisting of two pa-
ges (e.g. a general description and a single
help topic), each linked to the other.


Let’s run RoboAuthor: the window in







to insert a link to the previous page (page
0), the one about vegetables.


We write the text “ Back to previous
page” , we select it, and we click again on
the Link button (chain picture). The win-
dow, as shown in Fig.5, is displayed
showing us a list of all available pages
within the hypertext (page #0 and page #1
in this case). We can now directly choose
the link destination on the screen, so let’ s
choose “ Vegetables” .


Click on the “ OK”  button and Robo-


If you check the text-box at the bottom,
you’ ll see the
current page
number has
switched to
“ 1” .


Let’s add
a little text
now, as
shown in
Fig.4. At this
point we need


Fig.1 – The main
window: to write
something, just


type on your
keyboard…


A hypertextual link
looks like an underlined
word or sentence: with
a click on it you will
switch to a related page
(with a double click
when in edit mode).


Fig.2 – Let’s
choose a word
within the text,
"potatoes" for


example







Author takes us to the page in Fig.6 (page
#0). Notice here that the link to “ potatoes”
is underlined blue text. If we double-click
on the word “ potatoes” , the editor will
automatically switch to the “ Potatoes”
page (page #1).


From this page, we can double-click
on “ Back to previous page”  to return
again to page #0, and so on.


As you can see, creating links and
navigating through them with RoboAuthor
is really very easy, even from within the
editor.


There are several ways provided to
move from page to page: you can type the
page number directly in the page number
text-box; use the up and down arrows
beside it; use the right mouse button over
the same text-box (a list of recently visi-
ted pages will be shown); you can also use
the red arrow buttons at the top left to go
to previous or next visited pages.


Using the Hypertext menu at the top,
click “ Hypertext > Read-only”  to switch
to a non-editable preview of the hypertext:
This is handy as you won’ t need to click


Fig.3 – The Link
to... window where


you can define
simple links: just


select the last tab


Fig.4 – Let’s write
something in page


1.







twice on links, and table grids will be
hidden, but more on that later.


It’ s now time to save your work:
Choose “ File > Save all”  and the whole
hypertext / site / catalog will be saved into
a single file with the .AEH extension. The
process is the same whether 1, 2 or 1000
pages; 1, 2 or 1000 images, in this way
RoboAuthor keeps your work compact


and simplifies the tasks of making back-
ups and exchanging files.


Usually you use a single AEH file for
your Help document, and you create a new
page for each Help topic.


In later chapters however, we’ ll show
how passing to HTML or other format
files is immediate.


Fig.5 – The window
where you can


visually choose the
target for your link.


Fig.6 – We’re back
to page 0, and  can
see that the link to


the "potatoes" page
is already active.







mat used for the Windows Help guides) is
a simple one step operation.


Select “ Publish >Export WinHelp” .
Then with the “ path”  tab please choose
the folder that has to be used for storing
the temporary files and the .HLP file, and
choose the main file name. If the file that
contains your manual is called
mickey.aeh, the main file name will be
mickey.rtf (main source file for the
WinHelp) and the project file name will
be mickey.hpj (by opening mickey.hpj
with the HPC you might manually edit the
topic mapping and several other features).


Then press the Export button: Robo-
Author will generate several source files.
Then it will automatically call the MS
Help Project Compiler (HPC), that will
compile the .HLP file. The resulting file
(.HLP, mickey.hlp in our example) will
contain all your manual and will be the
only one that you will distribute.


If RoboAuthor doesn’ t automatically
find the HPC compiler, you may define its
position / path with the “ Options”  tab. If


W ith RoboAuthor you can
create with a single click HTMLHELP
(.CHM), WINHELP (.HLP) and plain
HTML for your website, from within a
single source documentu produce and
maintain a single file, thus saving time.


Depending on the help file format that
you need, RoboAuthor may require one or
two external free programs. You don't
need to learn how to use these programs
(it may be quite complicated), you just
need to install them and RoboAuthor will
"talk with them".


WinHelp
For producing .HLP WinHelp files


(the classic Windows help format) you
need the free MS Help compiler (you find
it on the CD; - hcw403.exe; 521K - once
downloaded, double click on its icon to
install; or see roboauthor.com).


Then converting an entire hypertext
into a Windows Help file (.HLP, the for-
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you don’ t have the Microsoft WinHelp
compiler, no pain: it is included with Ro-
boAuthor CD edition, and with several
other software products (including lan-
guages such as Delphi, VisualBasic and
so on). You can find it for free on several
sites too.


Please notice that due to the characte-
ristics of the WinHelp format itself, some
features may not be supported (e. g. fra-
mes).


HTML Help
For creating .CHM HtmlHelp (the


new Microsoft Help file format intended
to replace WinHelp since Windows 98)
you need the free Microsoft HTML Help
Workshop (you find it on the CD -
htmlhelp.exe; 3426K - once downloaded,
double click on its icon to install; or see
roboauthor.com or visualvision.com/help
or ask support@visualvision.com).


Please notice that an HTML Help file
(.CHM) can be viewed only on PCs with
Internet Explorer, so it may not be ok for
Windows 95 first edition.


Once the MHHWS is installed it is


very simple to create an HTML Help. Just
select “ Publish >Export HTML Help” ,
then choose the temporary files folder
with the “ Path”  tab, and the main file
name. If the file that contains your manual
is called mickey.aeh, the main project file
for the HTMLHelp will be mickey.hhp
(by opening this text fi le with the
MHHWS you might edit the topic map-
ping under the MAP section and several
other features; mickey.hhc and
mickey.hhk will contain the table of con-
tents and the keyword list).


Then press the Export button. Robo-
Author will call the MHHWS: you should
then press its “ Compile”  button in order
to obtain the .CHM file.


The resulting file (.CHM, e.g.
mickey.chm in our example) will contain
all your manual and it is the only file that
you will distribute.


Keywords, table of contents
The program permits you to create a


list of keywords for the whole manual,
and you can assign some of these to each
page.


Fig.9 – The export
window used for all


formats; in this figure
HTML is selected...







The keyword list, and the keywords
related to each page, should be set up
manually. You can setup a global
keyword list with “ Hypertext
>Keywords” . In the window shown, select
the “ Add global key”  button (the yellow
key with the green +). Then use the left
button to add a given global key to the
selected page. You can add up to 20
keywords to each page.


For both WinHelp and HTML Help, it
is possible to create a tree-structure of the
hypertext, defining chapters and sub-


chapters. You can do that by using
“ Hypertext >Pages order preset-TOC” .


Impor ting WinHelp files
If you have a WinHelp project in RTF


format, you can import it to RoboAuthor
and easily make changes, or simply take
advantage of the full scope of HTML. To
import the document, select “ File >Import
pages...”  and choose “ RTF WinHelp”  for-
mat.


Fig.13 – The RTF
WinHelp export


window. It is also
possible to export


to normal RTF (e.g.
to read the file with


MSWord).


Fig.14– RTF export
options







Expor ting HTML
The HTML export feature allows you


to save to plain HTML, for your Web site.
This is useful if you are writing documen-
tation for a web based application. Robo-
Author will create a different file for each
page and image used in your hypertext to
your hard disk.


Just choose “ File >Export pages...”  or
“ Publish >Export pages...” . The window
in Fig.9 will be displayed, and will allow
you to select which pages are to be expor-
ted (use the check-boxes for this).


Use the “ Path”  tab (see Fig.10) in
order to specify the folder where HTML
and image files should be stored as the
result of the export.


An interesting point to notice here, is
that RoboAuthor generates HTML code
only “ on demand” , while the native ‘aeh’
format is used during the edit process.
This results in HTML being treated like a
mere printing language like Postscript,
just as it should be. This saves you time,
allowing you to concentrate on the con-
tent, rather than on the technical side.


Browser  preview
Even though the integrated browser


within RoboAuthor is very true
(RoboAuthor is WYSIWYG and genera-
tes optimized code to provide the best
results on all browsers, even older Net-
scape 2 and Internet Explorer 3 browsers;
and also Opera and Mozilla), many users
still want to “ try”  their pages directly with
the actual browser, i.e. Internet Explorer
for the HTML Help format.


RoboAuthor allows you to do that, by


using the “ Publish >Browser preview”
feature. You can see the current page, or
even the whole hypertext, using your de-
fault browser, and you can also add menu
items for quick access to other browsers.
You can easily define these entries by
selecting “ Tools >Options >Browser” .
The window shown is very easy and intui-
tive.


Technical information
While executing the given examples,


expert users would notice that pages are
referred to in the editor using the page’s
title (high level name), rather than the file
name (low level name). They would also
notice that file names are generated auto-
matically by RoboAuthor, using an opti-
mizing criteria which improves perfor-
mance.


Conventions often dictate that the main
page (home page) of a HTML hypertext is
named index.htm or index.html. Should
you wish to choose a different name, you
simply select “ Hypertext >Current hyper-
text’s properties” , then select the “ Page
settings, background”  tab and use the
“ Cover file name (HTML)”  text box.


If you need to specify a different
HTML name for other pages (for exam-
ple, you could name the page about pota-
toes potatoes.html), simply use “ Format
>Page properties...” . RoboAuthor auto-
matically creates a redirection file and
maintains all links to the page. Please
remember that documents need to have
been saved in .AEH native format, for all
these features to be available.







long as the CD redistribution license.
Let’s make a practical example now.


We will use for this purpose the file crea-
ted in Chapter 1. If you didn’ t saved it,
please save it now by using “ File >Save
all” . We will suppose you saved it as
mickey.aeh (.AEH is the default exten-
sion for RoboAuthor files, and is shown if
“ hide known extensions”  is disabled in
your MSWindows Explorer’s setup).


First, let’ s select “ Publish >Cd Rom” :
the window in Fig.21 is displayed. Now
we can just press the button “ Include
present hypertext” . We will see that
mickey.aeh has been included in the right
list (Fig.22).


You may add other hypertext docu-
ments in the list. For example, in the
file-system in the left-hand panel, locate
the directory containing es_aeh (for the
default install it’ s in c:\vv\cdroms\client\f
- it contains some AEH file such as the
user’s manual). Then we can drag the
hypertext into the right-hand window, as
shown in Fig.23.


In any case it is mandatory to include


O ne of the most interesting fea-
tures of RoboAuthor is the Wizard that
allows you to easily publish your ma-
nuals, guides, policies, hypertext docu-
ments on a self-installing CD.


To ensure distribution of a fully inde-
pendent product, regardless of whether
Internet Explorer, Mozilla, Opera or Net-
scape are installed on a users PC, Robo-
Author puts a copy of “ HP Reader”  onto
the CD’s it creates. HP Reader is a pro-
prietary browser which includes a full-
text search engine with boolean search
capabilities (and/or operators); and sup-
ports keyword searches (see previous
Chapter and Chapter 9).


Please notice that you can’ t distribute
the CD(s) created with RoboAuthor. They
are available for internal use only, within
your firm / company. If you need the
redistribution license, please get Hyper-
Publish. HyperPublish is a VisualVision
product that includes all RoboAuthor fea-
tures (plus several other functions), as


3 .  C D - R O M


P ub l is h ing







text will be placed under the “ Start
>Programs”  menu, and the name of the
main hypertext that will be shown when
running, after the CD is installed. In the
given example, it is mickey.aeh.


The tab shown in Fig.26 allows us to
define a license file, an introduction and/
or a farewell message. Here again you can
get some examples from es_CD\wizStuff\.
If you make no modifications the program
will include some default files.


Once these files are included, you can
create the CD by simply clicking on
“ Create” . The program will build a draft
of the CD in the previously selected direc-
tory, and will ask if you wish to store the


at least one hypertext in the right side list.
Now let’s select the tab “ CD’s image


path”  (Fig.24) where we can choose a
directory to store the draft of the CD
we’ re creating, let’ s say c:\temp.


In Fig.25 we can see that the “ Custom”
tab contains two sub-tabs: the first one
allows us to define a “ splash screen”  for
the reader (that is the "About" window
and the window which appears when you
run the program). We can set an image by
pressing the image button (sun and cac-
tus). You will find a simple example in
..\es_CD\wizStuff\ssplash.gif.


In the same tab you can define a name
for the Windows group where the hyper-


Fig.21 - The CD
Wizard


Fig.22 - Let’s
include our work in


the CD, with the
button in the top


left...







Fig.23 - We
included some
other hypertext


documents. It is
mandatory to


include at least
one hypertext...


see also the
“Advanced
Functions”


Chapter.


Fig.24 – Secify the
path for the draft
build of your CD-


ROM here; you
can write them


later using your
usual burning


software.


Fig.25 - Define the
player’s properties


fom this window,
including Splash


screen, default
Windows group


etc.)







settings in a .wzz file for future use. If you
need to make the CD again, you simply load
the .wzz file and make any necessary chan-
ges.


As soon as the CD is created, a “ Test”
button appears. Use this to test your installa-
tion procedure, just like the end-user will. If
we look now at the directory c:\temp, it
should look like Fig.27: these are all we have
to copy in the root of our CD.


If the automatic insertion notification is
enabled in Windows settings, the resulting
CD will automatically run when inserted into
the CD-reader.


In Chapter 8 (Advanced functions), expe-
rienced users can see how to put programs
onto the CD and launch them directly, or
how to launch files managed by other pro-
grams (e.g. PDF files), and in conclusion,


how to create links to a hypertext resident on
a CD.


If you build a huge CD, containing multi-
ple files, you may choose not to install the
whole CD onto the users HD, simply reque-
sting that the CD be left in the drive while
viewing files.


To achieve the above result, there is a
little trick provided by RoboAuthor, consi-
sting of creating a cover hypertext (the only
one to put in the Wizard, so the only one to
copy to the HD) containing links to the other
hypertext documents resident on the CD.


You can get more information about this
trick in Chapter 8.


If you want to create a CD where nothing
is installed on the end user PC, please get
CDFrontEnd, www.cdfrontend.com.


Fig.26 - Player
setup options: you


can include a
license for the end-


user of your
hypertext, a


welcome message,
etc...


Fig.27 - The draft:
files and directories


to be written on
your self-installing


CD.







The easiest way to understand the ad-
vantages of using styles is to consider this
document you’ re reading now: every sin-
gle page has a title; the title style is the
same for all pages and is different from
the text style (Titles are larger and use a
different font, or typeface).


Saving different styles for titles and
normal text offers these advantages:


− You save time in applying a set of
attributes (if we hadn’ t used the
‘Title’  style for this page, we would
have needed to select each title, ap-
plied a font and a size, applied bold);


− You can immediately modify multi-
ple pages, or even the whole docu-
ment, by simply changing one little
thing. If you decide to use green for
the titles, you just need to modify
‘Title’  style, and it will be applied to
all pages instantly;


You can use styles in many different
ways. The easiest way to create a new
style is to apply text attributes to a text
block. As an example, you can select any


N ow we’ve had some practice
with the simplest ways to manage pages
and links, let’ s have a look at the main
text functions and how we can use them.


Text format
Nowadays, all word-processors have


standard buttons to let you apply ‘bold’
and ‘ italic’  characteristics to the text and
RoboAuthor is no different; you can also
change the color, size and character
(font). In addition, RoboAuthor offers you
the ability to define your own text styles,
in much the same way as MS Word or
Word Perfect do.


Styles
Text styles can be used to save diffe-


rent paragraph settings. Styles can be de-
fined and/or applied to the text using the
“ Paragraph”  toolbar or from the “ Format”
menu.


4 .  M a in f unctions







ted style. Another way is to type an exi-
sting style name in the Styles combo and
to press Enter.


If you want to change style settings
simply select a text block and apply modi-
fications; then click in the styles’  combo
and press Enter. A window will be di-
splayed asking if you wish to make chan-
ges to the style, select “ Modify style by
using selected text as example” . An alter-
native method is to use “ Format
>Styles...” , then select the style and apply
your changes.


If you simply apply a style to a para-
graph, pre-existing formatting is retained.
To clear all existing formatting, and keep
all paragraphs true to style, use “ Format
>Reformat” .


The “ style”  concept is a relatively re-
cent thing, originating from word proces-
sing and desktop publishing applications.
The majority of applications distinguish
between style and format:


− “ Style”  means all properties defined
in the Style applied to a paragraph.


− “ Format”  applies to the same attribu-


number of words, set a size of 15 and
apply bold to the text; then write a name
for the new style in the styles combo on
the toolbar and press Enter. A window
will appear asking you to confirm the new
style’s parameters.


Another way to create a new style is
by using
“ Format >New
style”  directly
from the menu:
the window in
Fig.30 is
d i sp l ay ed ,
allowing you to
define all the
parameters for
your new style.


To apply a
style to a paragraph or a text block, you
must click on the Styles combo box arrow.
The visual online help file (indexRA.aeh)
for example, contains many different sty-
les including List, Text and Title. Clicking
on any of these items, will reformat the
selected text or paragraph using the selec-


Fig.30 – Here you
can define a new


Style or modify an
existing one; you
can even copy a


Style from another
hypertext using


"Import".


Before starting a new
project it is always a
good idea to spend a
few minutes to set up
the styles you will use.
This will save a lot of
time if you later need to
make modifications.







hypertext and the page we want to
link to. Select the destination page
for the link visually, as the program
provides us with a preview of the
pages, and enables us to surf through
them;


− Link to an Internet address: Robo-
Author keeps track of all URLs re-
ferred to in the current hypertext. As
shown in Fig.32, we can choose the
address to link to from a list, or we
can add a new one by clicking on the
"+" key;


− Link to an embedded file: we can
include a text file or a ZIP file within
a hypertext (.AEH file). We can
browse for a file in the file system
using the window displayed in
Fig.33. Clicking on the link will di-
splay the file. If the selected file has
an unknown extension, RoboAuthor
will ask for instructions.  If you have
to deal with a huge file, we would
suggest that you don’ t include it in


tes, but those applied locally with
toolbar buttons or with “ Format
>Font...”


You can have two paragraphs that
appear identical on the screen, but are in
fact different. RoboAuthor maintains this
distinction, as does MS Word and certain
other editors, because this is what users of
styles expect.


Links
Let’s take a look now at some different


link types, in addition to the ones we’ve
seen in Chapter 1. As already stated, crea-
ting a link is as simple as selecting a text
block and clicking the chain tool-button,
but we can also choose “ Insert >Link”
from the menu. In the displayed window,
depending on the tab we select, the fol-
lowing links can be established:


− Link to other pages of the hypertext
(see Chapter 1);


− Link to other hypertexts: Fig.31
shows how we can select another


Fig.31 - Here you
can define a link to


a page in another
hypertext. The


simplest ones are
when both


hypertexts are in
the same directory.







− Link to a new page copied from an
existing one in another hypertext;


− Link to a new empty page: this is the
simplest link that you can add detail
to later;


− Link to images: It is not only possible
to link to images, but also sections of
a picture using hot-spots (right
mouse button on a picture); These
methods will be dealt with in later


the hypertext. It would be better to
save it separately on the CD (see
Chapter 8);


− Link to a page copied from a tem-
plate: You can link to a new page
copied on-the-fly from a template
(Fig.34);


− Link to a new page copied from an
existing one within the current hyper-
text;


Fig.32 – Here  you
can insert a link to


an Email, or
Internet address


(URL) ; this is
accessed using


"Insert >Link".


Fig.33 - This
window allows you
to include any file


within your
hypertext; access it


using "Insert
>Link".







− Define one or more clickable zones
or “ hot-spots” : using the right mouse
button you can select “ Add area” .
Hot-spots can be moved and resized;
it‘ s possible to define a link for each
hot-spot using the right mouse but-
ton, the “ image”  menu or the toolbar.
Use DEL to delete a hot spot.


Several properties are available for
images; you can access the editing win-
dow using the right mouse button or
through the “ Image >properties”  menu
item. Figs.37-40 show the related win-
dows with all concerned tabs.


You can also apply transparency to
your images, enlarge or reduce them, and
you can even include HTML code (see
Fig.40).


It is also possible to use images that
change when the mouse cursor passes
over them. This method uses two different
images that are shown depending on the
cursor position (see Fig.38). Of course,
these images can link to a new page.


Another useful feature allows you to


chapters;
Expert users will be able to use the


“ special links”  (Chapter 7).


Images
It is possible to insert an image by


clicking the ‘ Insert Image’  tool-button, or
by selecting “ Insert >Image/Map”  from
the menu.


The window shown in Fig.35 displays,
allowing us to select the source of the
image to include. This can be from disk,
from an existing image in the internal
album or from another hypertext.


To get an image from the internal cli-
part collection, you must select “ From
disk”  and then click on the “ Clipart”  but-
ton (the icon with the mountain and the
sun).


Once an image is inserted you can:
− Assign a link to the image: using the


right mouse button you can “ Define
a link”  the same way as for the text
links shown above. Details of special
links follows later.


Fig.34 - This
window allows you
to create a link to a
new page, created


by copying it from a
template.







the following reasons:
− viewing pages becomes strongly de-


pendent on the user PC’s video reso-
lution; users viewing your site with a
lower screen resolution would not
see the site as you intended, and
consequently may give up and go
elsewhere.


− if you export to HTML / Web, pages
cannot be viewed with older brow-
sers, palmtops or with a tv-box;


Using “ Insert >Table”  will display the
window shown in Fig.41, where you can
choose from several predefined table
layouts.


You can modify these tables if requi-


replace an image, either on a single page,
or using automatic substitution throughout
the entire hypertext (see Fig.39). In addi-
tion, using the “ Album”  window
(“ Hypertext >Images- files -link archive
and erase” ), you can globally interact
with all images included in the hypertext.


Tables
Tables are not merely a way to put


numbers and letters into columns. In video
publishing, tables with transparent bor-
ders are the best way to position objects
on the screen. We discourage the
“ absolute”  positioning on the screen for


Fig.35 - You can
insert an image


from the internal
album or from a


disk  using "Insert
>Image".


Fig.36 - Inserting a
clickable zone (hot-


spot) into an
image.







Fig.37 – Use the
image properties


window  to define
alternative text for


the image, together
with many other


settings.


Fig.38 - It is
possible to choose


an alternative
image to display
when the mouse
cursor is over it.


Fig.39 - This
window allows you


to replace every
occurrence of an


image used in the
whole hypertext in


one hit.







cell’ s background, on a row or on a column.
It’ s interesting to note that each cell can
have a colored background, an image or can
be transparent.


What’s more, tables can be “ nested” ,
that means you can build a table inside a
cell of another table, and so on.


You can select a whole table using the
right mouse button and “ Select table” .


To copy a whole table, simply select it
and press CTRL+INS; then move to your
required destination and press SHIFT+INS,
it really is that easy.


red, using the “ Tables”  menu or by using
the tool-buttons on the toolbar (e.g. you can
add or delete rows and columns, change the
background color of a cell, etc…).


Placing your cursor over a table cell and
using your right mouse button gives yet
another modification option. Choose
“ Properties”  and the window in Fig.43 will
be displayed, allowing you to define the
properties for your table, such as border’s
width or the background. From here you
can also assign a fixed size for your table or
a percentage relative to the main window.


Using the tab in Fig.44 you can act on a


Fig.40 – Uing this
window, experts


can add HTML
code within the


<IMG> tag.


Fig.41 - This
window allows you
to define and insert


tables.







Fig.42 – Once a
new table is


Inserted, it can be
resized by dragging
the grey rectangles.


Fig.43 - TheTable
properties window.


Fig.44 - Properties
of the selected cell


and the column it
belongs to.







A  common method to make a
manual more appealing and usable is to
split the screen into different sections, or
frames.


Creating frames
Creating frames with RoboAuthor is


really very easy: all you need to do is to
drag and release one of the notched bars
that are on the screen sides.


As you will notice, in most of its win-
dows, RoboAuthor treats pages that con-
tain frames as a single page. In particular,
the master page of the frame-set will
always be referred/displayed. The master
page is the page shown when the fra-
mes button is released.


You can use this button to switch
between “ Frames”  and “ No frames”
mode. This button has no effect on the
page’s structure, it’ s just a display option
for the editor. In addition to showing the
master frame of a frame-set, this button is


useful to quickly test how your hypertext
will be viewed with browsers that do not
support frames (such as palmtop, tv-box
etc.).


Let’s make a simple example. Start by
creating a new hypertext with “ File >New
hypertext” , and split the page (#0) into
two sections by dragging the notched bar
on the left (see Fig.50). If you do not see
the notched bar on the left, click the
‘Show frames’  button. You will notice
that pressing and releasing this button
shows the master page, the one on the
right.


Now we want to build a structure
where “ page A”  and “ page B”  can be
selected from a list displayed in the left
window e.g. a simple menu. The selected
page is displayed in the right window,
without the left frame being affected or
changed in any way.


To demonstrate this, we’ re going to
create a new page with “ File >Add new
page” , then drag out a frame using the bar,
as we did before (Fig.51). Now click in
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this way, the “ Index”  page will be shared
by the two frame set.


Please note that by changing the value
of the “ Size”  box, we can set the same
size for both “ Page A”  and “ Page B”  left
frame, for example 25%.


the left frame, then using your right mouse
button, click and select “ Choose page in
frame…” ; the window in Fig.52 will
open. In the box “ Page in frame”  we will
select “ Choose existing one” : the window
will change as in Fig.53, allowing us to
insert the “ Index”  page into the frame. In


Fig.50 - We’ve just
created two frames
by simply dragging
the left bar across


to the right, and are
currently entering


text in the right
frame.


Fig.51 - Recreating
the same frames


layout in a new
page of the
hypertext…


Fig.52 - Let’s fill the
left frame with the


same page as used
in the previous


frame-set…







to the user.
In fact, it would be possible to only


change the right frame, keeping the one on
the left unchanged. This requires us to use
special links, as described in Chapter 7.


Floating frames
You can insert a frame as shown in


Fig.62 using "Insert >Floating frame". A
dialog window will display as shown in
Fig.63 and you have the option to include
any hypertext page within the frame.


Links
All we have to do now is to insert


links. Selecting the text-block “ page B”
and choosing “ Insert >Link”  will display
the window in Fig.5, allowing us to select
"Page B" as the destination. Now do the
same for “ Page A” .


When finished, it should look like
Fig.55. Clicking on “ Page A”  or “ Page B”
in the left frame should display the corre-
sponding page on the right.


Several ways are given to build a set of
frames like the one just demonstrated. In
the example just created, the page chan-
ging is achieved by replacing both frames;
but since the frame on the left is the same,
only the one on the right appears to change
to the user.


Fig.53 - It’s
possible to insert


any page of the
hypertext into the


frame…


Fig.54 - Let’s
complete the page
by writing "page B"
in the frame on the
right. Now we just
need to set up the


links.







Fig.55 - Our first
frame-set: clicking


in the left menu will
display our


selected page in
the right frame.


Fig.62 - A page
containing a


floating frame...


Fig.63 - The dialog
window for


independent
frames. You can


also call it by
clicking on a frame


with the right
mouse button, and


selecting
"Properties".







T he following multimedia
objects are directly supported:


− pages with background music
− pages with buttons to start music
− pages with avi, mov, mpeg video


You can also insert objects that are not
directly supported. You will see them
when exporting to HTML / HTML Help
(CHM) or within the browser preview.
They are not supported for WinHelp
(HLP). For example:


− pages with Java Applet
− pages with object + embed (e.g. code


written to be compatible with either
NS / IE / etc.)


To speed up the editing of pages with
non-standard objects, you can use object
prototype libraries (a type of macro - with
Hyper Publish hyperpublish.com you can
create these libraries). This feature can
speed up insertion of third party graphic
objects, and Data-Base tag insertion.


If you are creating a CD, there is
another way to insert big files (chapter 8).


Sounds and video
Use “ Insert >Animation - sound”  to


insert an animation or a sound. Interesting
isn’ t it? You will see the dialog shown in
Fig.80. To choose the audio or video file,
click “ choose file” . Don’ t we make it easy
for you? The window shown in Fig.81
will be displayed. For audio, you can use
any wav or mid file, together with any
format supported by your MSWindows
install. If you have already used an audio
file on another page of your hypertext,
you can easily select it using the second
tab (Fig.82).


For video files, the process is very
similar.


With “ action kind”  you can choose if
you want a loop action (e.g. background
sound, or repeated animation) or to show
a “ console” , a set of buttons that the user
will use to start the sound or video.


The “ loops”  box indicates how many
loops are allowed, if “ loop”  is selected as
the action. For example if you choose “ 1”
you can insert an action that will be exe-
cuted when entering the page (this kind of
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Fig.80 – Insert
animation and


sounds using this
window: you can
insert any format
supported by the


browser


Fig.81 - Here you
can insert a file


(sound or
animation) that will


be embedded in the
hypertext


effect is used in the RoboAuthor presenta-
tion, “ ? - Help >Show presentation” ).


Applet
Use “ Insert >Embed Java Active X”  to


insert an applet. The window in Fig.83
will be shown. You should insert the pro-
per HTML code. The important thing to
notice is that when you refer to a file or an
image you shouldn’ t insert its actual file
name, but you should instead use the but-
tons on the right. With these buttons you
can visually select an image, a file, a site


page: RoboAuthor will insert a reference
code (shown as visual block; you can use
the right mouse button to change it) that
will be resolved to an actual file name
on-the-fly, when generating HTML. This
system is very useful as it allows you to
change files and images within the hyper-
text without worrying about the actual
code, and without having to change it
yourself.


You can also use the “ Insert page or
file ref...”  button to insert a reference to an
internal page (Fig.86): in fact you won’ t
know the HTML file name of the page, as







Fig.82 - HP
mantains an


internal album with
all sounds and


animations used in
the hypertext


it is generated on-the-fly.
Please note that you will only see the


Applet working when exporting in HTML
(or with the browser preview, “ Publish
>Browser preview”  - you see this menu
only with “ Hypertext >Read only”
disabled).


You can get a better understanding of
the mechanism by opening the file multi-
mediaPK.aeh in edit mode (this is one of
the Help files, available in the es_aeh
directory). One of these examples is parti-
cularly interesting as it doesn’ t just use an


applet (messagera.class), but an applet
parameter is contained within a file
(untitled_messagera.vac). Using your ri-
ght mouse button on the applet gray block,
you will see how the code is written. The
two files above are embedded within the
AEH hypertext and are automatically ex-
tracted when you publish on the Internet
or ask for a preview.


To insert an ActiveX or Embedded
object is as simple as inserting an applet:
you write the code and when the time
comes to insert the object file name, you


Fig.83 - With this
dialog window you


can insert the code
related to an


applet. The .class
file will be archived
in the same album
as any music files







use the “ Main object”  button which in-
serts the dynamic reference to the actual
file (Fig.85) into your code.


Using the right button you can also
place a reference to the size of the applet
/ embedded object / activeX. This option
will allow you to visually resize the gray
block that marks the object within a Hy-
perPublish page. As stated previously,
you will only see the actual working
object inside a correctly configured brow-
ser.


Headers and footers
This function is available if you up-


grade to VisualVision HyperPublish,
www.hyperpublish.com.


Slides
Using “ Insert >Page functions


>Slides”  you can instruct the program to
replace the current page with a different
one, after N seconds. The window shown
is the one in Fig.96. This is the function
used in “ ? - Help >Show demo” .


With “ Hypertext >Slides”  you can use


Fig.84 - You can
insert ActiveX or


Embed objects with
ease. HP can


visually manage
their size (please


notice X and Y
markers)


Fig.85 - You can
insert into the code


a dynamic
reference to a file
(for example the


.class file for a
Java applet)







the more comprehensive window shown
in Fig.97, where you can set up a whole
slide sequence: pages (slides) may be se-
lected from the whole hypertext, and you


can simply change the sequence using
“ drag & drop” .


Fig.86 - You can
insert into the code


a dynamic visual
reference to a page


Fig.96 - The
simplest way to


switch a page to
another one


(shown) after N
seconds...


Fig.97 - Using this
dialog we can


easily set up a
page or slide
sequence...







T he simplest links available in
RoboAuthor are the “ normal links” . As
seen in Chapter 1 you can insert them by
selecting a text block and using “ Insert
>Link” . If you need something more ela-
borate and powerful, you have to use
"Insert >Special link". Note that special
links work only with the editor in read
only mode (“ Hypertext >Read only” ), in
the browser or with the HP Reader.


We suggest that you don’ t attempt
using special links until you are familiar
with the normal ones.


There are many available options. Fir-
stly, you can link to another page:


− with a click, a window will show
− a new browser window will show
− the destination page replaces the cal-


ling frame
− the destination page will show in


another frame or window
− the destination page will show as a


popup window
− the destination page is opened at a


fixed row, marked by an anchor (see
below)


Additionally, you can set up the fol-
lowing behaviors:


− a click on the link will close a win-
dow


− link to a different position on  the
same page, using anchors


− link to WinHelp sequence
− a click on the link will show the


search by keyword window (click to
show the search window: this works
only in the editor/reader)


All these actions are “ visual” , i.e. you
do not have to do anything difficult or
write any code. Experts will enjoy the
freedom to add HTML code to any of
these links, simply choose the HTML tab
within the link insertion window.


We will also see how to open windows
automatically, as the user enters a page.
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Anchors
The simplest of the special links are


the links to an “ Anchor”  within the same
page. Anchors act like a bookmark and
allow jumping to sections within a given
page. This kind of link is useful when you
have a very long page.


To insert an anchor, move the cursor
to the link destination and use “ Insert
>Anchor”  from the main menu (or
SHIFT+F5). An anchor icon appears. Se-
lecting it with your right mouse button
allows you to edit its properties.


Now select the text block or the image
you want to link to your anchor, and use
“ Insert >Special link”  (on an image, use
your right mouse button and click “ Define
special link” ). Click on OK in the window
that will be displayed. You will then see a
dialog where you can select the destina-
tion Anchor. Click on the anchor (a num-
ber is assigned to each anchor and will be
displayed in the box at the bottom right),
and then click OK. You can test the result
in “ read only”  mode (Hypertext >Read
only).


If you later need to modify the link
destination, place the cursor on the link,


use the right mouse button and select
“ Link properties” . In the dialog window
displayed, select “ Visual edit...”  (Fig.
103) or “ Link target page...” .


You can also link to an anchor inserted
on another page. Select a text block, use
“ Insert >Special link”  and select the se-
cond tab (Fig.104). In the “ Target page
shows:”  area, choose “ in current window”
and click OK. You will then select both a
destination page and an anchor (see
Fig.105).


Showing windows
From the special link dialog, choosing


the third tab allows you to show the desti-
nation page within a separate window.
You must define a name for the new win-
dow (see Fig.106), this name can be used
later to change the window content for
example.


If two links use the same name for a
window (e.g. “ Goofy” ), and you click first
on the link #1, then on the link #2, you
will not show two different windows, so it
is imperative that each window has a uni-
que name. That is, unless you really want
to show the same window from two diffe-


Fig.100 – Showing
an anchor within a


page, these are not
visible out of edit


mode.







Fig.101 - The
special link window


Fig.102 - Here you
can select the


destination anchor


Fig.103 - Properties
of the link just


inserted...







rent links.
The separate window can be shown as


an ordinary window, or (for CD publi-
shing and WinHelp only) as a popup win-
dow. The difference is that a popup closes
whenever a user clicks on it, or clicks on
another window. If the destination page is
a frame-set, you can choose to show the
whole frame-set or just the “ master”  page
(see Chapter 5 to learn about the master
page).


Choosing the second tab (see Fig.104)
and selecting “ opening a new browser
window” , will show the destination page
in another instance of the browser (this is


different from a normal “ window” , as it
will include the navigation bar).


With the 5th tab you can close any
window, by name.


Links inside/to frame sets
Now we will see some useful links that


work within frame-sets.
Suppose that we have the layout as


shown in Fig.107: We want a link from a
word or text block in the right window,
that replaces the content of the same win-
dow while leaving the left window un-
changed. To obtain this, we simply choose


Fig.104 - More link
types


Fig.105 - Let’s
choose a


destination page for
the link, and an


anchor. The link
dialog allows many
different link types.







“ in current window, replaces caller page”
in the tab shown in Fig.104: when we
click OK, the program asks for the desti-
nation page which can, as usual, be cho-
sen visually.


Another possible choice is more diffi-
cult to explain than to use: The tab shown
in Fig.108 which allows you to visually
choose the frame where the destination
page will be shown. Please note that you
can also manually insert the destination
frame name (frames can be named using
“ Format >Advanced frameset manage-
ment” ). This is useful for linking to
“ floating frames”  (see Chapter 5) or to
link to a separate window, or a frame
within a separate window. Any window
with the specified name will have its con-
tent replaced by the destination page
when the user clicks this type of link.


Using the last tab, it is possible to
activate a defined special “ jump” . Op-
tions include moving to the previous or
next page in a sequence and you can also
display the "Search" window which is
useful for CD-ROMs (see Chapter 8).
Groups and sequences may be defined


using “ Format >Page properties”  (see
Fig.12), these sequences will also be used
for the WinHelp export feature.


All these links work with text blocks,
single words, images and hot spots
(Fig.36).


Showing windows without a
click


Using “ Insert >Page functions >Open/
Close windows”  you can open or close a
window as soon as the user enters the
specified page. A “ functional block”  will
be inserted in the page, and will be activa-
ted when the page is shown.


The “ functional block”  properties may
be modified using the right mouse button,
(see Fig.109). Here you can define the
window attributes, or supply the name of
the window to be closed.


In the online guide (“ ? -Help >Help” )
using the file specialLinksPK.aeh , you
will find live examples that can be opened
in the editor. There are lots of tricks to
enable full use of these resources.


Fig.106 - More
available link types


and properties...







Fig.107 -  A simple
frame set, used as


an example


Fig.108 - You can
visually select the


link destination
frame, and the


linked page


Fig.109 - Show /
close windows







Y ou can insert both HTML and
Javascript inside RoboAuthor pages. This
subject is not for beginners.


There are two main options for inser-
ting HTML or JS. With the first one,
“ Insert >Script Java/Vb >At page start”
(Fig.120), you can insert code at page
start. This is useful for example for intro-
ducing META tags (Keywords and de-
scriptions).


With the second one, “ Insert >Script
Java/VB >Within text” , you can insert


code anywhere within the text. Useful for
inserting the code for counters or a guest-
book for example, (see the following page
www.visualvision.com/utils).


Using the second type, you will not see
the HTML code within the RoboAuthor
pages, the place for code insertion is
marked with an icon. To see/modify the
HTML/Javascript, click on the icon using
the right mouse button, and select
“ Properties” .


The dialog window dedicated to code
insertion has some special functions. With
“ Load”  and “ Save”  you can use templa-
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Fig. 120 -
Javascript inserted


inside the HTML
tag <HEAD>.


Use “Insert >Script
Java / VB > At


page start”...







tes. With the buttons bottom right, you
can insert visual references to all the
objects contained in the internal album
managed by RoboAuthor. For example, if
some HTML code (say an Applet) needs
to make a reference to an internal image,
there is no need to input the image file
name. You can simply click the “ image”
button, choose the image visually, and the
program places a marker that will dyna-
mically resolve to the image file name
when the HTML code is generated. This
assures there will be no broken links, even
if you make changes to the image.


HTML added to images,
forms, objects


You can’ t edit the RoboAuthor HTML
code, but you can add HTML to any
object. Use the right mouse button on the
object, click on “ Properties” , and click the
“ HTML”  tab of the dialog shown. Many
examples are included in the online help
file (open indexRA.aeh in the editor).
Fig.122 shows the HTML added to a text
box, it is the example on page 298.


Hyper text on CD
With the CD Wizard you can create a


ready-to-use CD-ROM. During the install
process, any hypertext included in the list
on the first dialog of the Wizard, is tran-
sferred to the final user’s Hard Disk (HD).
In the example shown in Fig.23, the Wi-
zard copies the listed hypertext documents
to the CD (multimediaPK.aeh, in-
dexRA.aeh, ...) , and instructs the installer
to run indexRA.aeh on the user’s HD
(Fig.25, on the bottom right).


Sometimes you may prefer to leave
some hypertext documents on the CD,
perhaps they are large and you want the
user to browse them directly from CD.


This is very easy. Place at least one
hypertext in the list used by the Wizard,
(see Fig.23). This hypertext will be the
only one to be installed on the end-user’s
Hard Disk, and must contain links to the
other hypertext you intend to leave on the
CD, (details for placing these links follow).
This step is necessary or the reader will not
be able to browse your other hypertext
documents.


The next step is to press “Build”  and
create the draft CD in a temporary direc-
tory (the directory you will use as the


Fig. 122- HTML
added to a text
box (a part of a


form)







master for the CD). Then, from inside that
directory, create a sub-directory and call it
data. Put all hypertext documents that you
want to leave on the CD in the “Data”
directory just created, (e.g. test1.aeh,
test2.aeh). Note that these .aeh files must
not be included in the Wizard’s list (the one
in Fig.23).


Then you need to place link from the
first hypertext (the one that will be copied
on the end-user’s HD) to the hypertext in
the data directory. Use “Insert >Link”  then
select the third tab “Internet - Program” ,
press “Add +”  and type something like:
iper://cddrive:\path\myhypertext.aeh|123


For instance if the hypertext we want to
link to is test1.aeh, in the directory data,
and the page we want to link to is page 0,
we would write: iper://cd-
drive:\data\test1.aeh|0


The word cddrive: is used to tell Robo-
Author that it must automatically insert the


CD path. The CD drive letter is stored du-
ring installation. If the user has multiple
drives, and swaps them around, RoboAuthor
prompts the user to enter the new CD drive
path when needed.


It is worth repeating that you have to
store at least one hypertext on the end-users
HD, the main one that you list in the Wizard
(Fig.23). There’s no way to avoid this, and it
will be the hypertext listed as an entry in the
Windows “Start”  menu, so the user will need
it to see your CD. It need only be a cover
page, with links to other hypertext docu-
ments on the CD. Remember to name that
main hypertext, using the box at the bottom
right of the window shown in Fig.25 (default
hypertext name).


It is a very simple process, and with a
little practice you should be able to create
professional CD-ROMs in minutes..


Fig. 124- Using
this window


you can link to
a hypertext on


your CD,
program files
(.exe) or any


file on your CD.


Fig. 125 - Here
we add the


directory “data”
to the CD draft
created by the


CD wizard.







How to run programs or
external files, also on CD


It is sometimes useful to allow your user
to run a program or a file, simply by clicking
on a link.  Any link can be used to run a
program: select a text block, use "Insert
>Link" or “ Insert >Special link” , then from
the link window, choose the "Internet - Pro-
gram" tab (see Fig.124).


In addition to http://, ftp:// and mailto:
commands, the “ Internet - Program”  tab
allows you to run programs by using the
special strings, prog: and run: - You can:


− run a program by using a dummy file
name. The syntax is prog:dummy.txt,
where ".txt" is a Windows registered
file extension (i .e. Windows knows
how to manage a text file; this is true
when a proper application is installed)


− run a program or a file using a relative
path (relative to the current hypertext).
The syntax is: run:path\exename.exe
or run:..\mypath\exename.exe. You can
also run a file by using filename.ext,
where .ext is a Windows registered file
extension (e.g. .pdf).


− run a program or a file on the CD.
run:cddrive:\mypath\exename.exe runs
the software exename.exe available in
the mypath\ directory of the CD; you
can also run a file as above. The CD
drive letter is stored during installa-
tion. If the user has multiple drives and
swaps them around, RoboAuthor will
prompt the user to enter the new path
when needed.


− run a program by storing the command
line within the Windows Registry. This
means that an external application
must write a string to the Registry that
will be used by the iPerReader. The
syntax is
prog:\software\acme\exename, where
that string means that the program


that string means that the program
path is stored in the key
HKEY_CURRENT_USER\software\ac
me\, string exename


See also “ Insert >Link >File”  to learn
how to embed small files in the hypertext.


Keywords
The program permits you to create a list


of keywords for the whole site, and you can
assign some of these to each page.


The keyword list, and the keywords rela-
ted to each page, should be set up manually.
You can setup a global keyword list with
“Hypertext >Keywords” . In the window
shown, select the “Add global key”  button
(the yellow key with the green +). Then use
the left button to add a given global key to
the selected page. You can add up to 20
keywords to each page.


Any CD created with the CD Wizard
comes with a built-in keyword search and
full-text search engine. If more than one
hypertext is included on the CD, these se-
arch capabili ties are limited within each
hypertext. You can prompt users to press
“Search”  to start a search, or you can even
place a link or an image/button that shows
the search window when clicked: to do this,
use “Insert >Special link”  and select the last
tab.







B esides the powerful features offe-
red by RoboAuthor to create "well built"
pages, we would like to provide some
useful suggestions about creating and pa-
ging electronic manuals, although this is
really not the aim of this manual.


Creating a good work is not merely
dependent on the richness of graphics or
special effects, nor an on-paper paging
experience. Even if the usual communica-
tion rules are adopted, as for paper publi-
cations, the electronic manual is a media
apart from all traditional ones.


In this chapter we give some tips for
making a professional and useful docu-
ment, even without super-graphics and
expensive software


Displaying information on
the screen


Displaying information on the screen
is very different from presenting it on
paper. In traditional publishing, the page-


maker just needs to choose the page's size
and can then begin adding text and pictu-
res.


Using the same methods for on-screen
paging may well result in ineffective di-
splays, since the dimensions are depen-
dent on the video resolution set by the
user, not by the author of the page. Typi-
cal screen resolutions can vary between
640x480 and 1600x1280 pixels on diffe-
rent monitors, going from 10 inch  to 21
inch screens. So, how can we cater for
everyone’s requirements?


There are different solutions. By con-
sidering the fact that a minimal resolution
of 640x480 or 800x600 is available to
everyone, we could set such values as
typical during the design of pages. Ac-
tually, this is the choice adopted for many
professional works on CD. Nevertheless,
this solution may be considered very limi-
ted by the user, who would like to take
advantage of a more powerful video card,
leaving our work appearing to be of a low
quality.
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Fig. 134 - A correct
page when shown in


different windows







Another simple solution may consist of
preparing the work as if it were a book or
paper magazine. For example, we can
define the A4 or US Letter format for all
pages, and then provide the user with a
reader that has zoom capabilities for use
on a small monitor. If we do this, pages
will have a fixed size and the content will
be the same for all video resolutions.


This is the method adopted for a lot of
works provided with Acrobat Reader. In
our personal opinion, this method is not
ideal for users who have small monitors
or with monitors working at a low video
resolution.


Everything's relative
RoboAuthor adopts a third method ba-


sed on automatic justification. Using this
method the displayed content has no abso-
lute position value, but is dependent on
the width of the current window. Firstly,
text fits according to the window’s width:
this means that if you narrow the window,
the length of each text line will change
accordingly, as shown in the example in
Fig.134.


To be effective, when using this stra-
tegy, it is essential to position all objects
on the page using percentage or relative
values, rather than absolute values.
Looking at Fig. 134 and Fig.135 we can
make a comparison using the two
methods: unfortunately, with absolute po-
sitioning, the user’s screen must have the
same video resolution and the same win-
dow size you used, in order to get the
correct display. To quote a statistic, this
scenario may apply for only 10-15% of
users; this suggests that the highest per-
centage of users would see a more or less,
reasonably laid out page. All things consi-


dered, it would be better to accept the
in-percentage tables philosophy, since it is
evident that it has a reason of being.


Invisible tables
How can we insert in-percentage ta-


bles making them fit for all resolutions?
Well, it’ s very easy indeed, since they are
the default used by RoboAuthor.


Let’s make an example now, by recre-
ating what is shown in Fig.135, but this
time changing the absolute references
which make the page video resolution
dependent.


Firstly, let’ s get the three images so-
meway (the “ Golem”  writing, the number
and the split line; we saved them from an
Internet page, with right mouse button).
Then let’ s run RoboAuthor and define the
page’ s background as white using
“ Format> Page properties” . If you wish,
you can also insert an image as the back-
ground. Now we have to put the three
images saved previously (“ Insert >
Image” ) and an invisible table (“ Insert
>Table” ) with two columns to put text in.
We can define the percentage for the two
columns simply by right-clicking within
the two cells shown on screen (second tab,
as shown in Fig.44). The result should
look the example in Fig.139. At this point
we can insert the text, and the page should
then look like Fig.140: enlarging or nar-
rowing the window should not affect the
page quality.


Please notice that you can insert a
table within another table, so you can
create more sophisticated structures, if
needed. Again, we suggest you to try and
try again, as this is the best way to learn
how to use the advanced features offered
by RoboAuthor.







Fig. 135 - A page
with fixed tabes seen


at different screen
resolutions







Fig. 139 - Let’s insert
the images and let’s


create a table with
two coloumns,


without borders...


Fig. 140 - ...then let’s
write (you will see the


dotted lines just in
the editor; they aren’t


shown in the
published CD).


Fig. 141 - Page with
a repeated square


background


Backgrounds
One of the greatest differences


between video and paper publications is
the use of backgrounds.


Printing backgrounds on a paper-made
publication is very expensive and someti-
mes may affect the readability and spoil
the overall appearance. This same treat-
ment, when applied to CD or HTML Help
pages, may well result in a visual enhan-
cement.


In Fig. 141, 143 and 148, we can see
some examples that demonstrate the use
of backgrounds. We can assign a back-
ground to a table’s cell through the usual


window shown in Fig.44. It is however
important not to over use this feature. In
general, we discourage the use of back-
grounds that have too much contrast, satu-
rated colors or too much detail, because
these can affect text readability and take
focus away from the subject matter. If you
really wish to use them, we suggest that
you put a colored table where you want to
insert a text block (see Fig. 143, where we
have used nested tables).


Clickable maps, hot spots
and browsing bars


An interesting way to link different







Fig. 143 - If you
apply a coloured


background to the
table the text is more


readable


Fig. 148 - Lens
effect. You can do


this with two different
backgrounds, similar


but with different
color tone.


pages is to create special images that
contain some intelligent areas, which,
when clicked, will generate the loading of
the linked page. In Fig.154 we show a
sophisticated example, but we could sim-
plify this by making a bare horizontal bar.


We can insert a clickable zone (hot
spot) by positioning the cursor over the
chosen area and right-clicking with the
mouse (“ Add area” ). A small rectangle
appears with four white corners. We can
then move the rectangle and resize it by
dragging the white corners in order to
define the intelligent (clickable) zone. By
right-clicking on the newly created hot
spot, we could go on to define a link.


It is important to take into considera-
tion that some users may not be able to
take advantage of the graphic links. To
provide them with the opportunity of
browsing our pages, it would be advisable
to replicate the links elsewhere on the


page in a simple text format, even if only
in small sized characters at the foot of the
page.


Accompanying the program, you are
provided with many different examples of
button-bars and clickable maps. Using the
same bars throughout the same manual /
guide / presentation will improve unifor-
mity and will contribute to the overall
style of your work.


Taking all of these points into conside-
ration, we should say that designing but-
ton bars or maps is not as easy as it could
at first seem. If you are not experienced
with graphics software, it may take some
time before you obtain a satisfying result.
For an easy software for creating buttons,
see our Web site. Nevertheless don’ t give
up, but try to get some help from an
experienced friend or from a specialized
video-graphics publication







Fig. 154 - A nice
image with hot


spots (www.
fantascienza.


com).


Frames
Frames are a very useful feature, espe-


cially while designing complex manuals.
Frames allow us to split pages into more
sections. A very common implementation
consists of using an index or box contai-
ning a selection-list on the left side of
each page. Using frames so that we don’ t
have to physically repeat the same menu
for every page; and at the same time,
make browsing much easier.


Some authors discourage the use of
frames. Actually, the practice of discoura-
gement should not be applied to the cor-
rect use of frames, but rather for those
making bad use of them.


It is interesting to note that by choo-
sing ‘0’  as the value for the borders of a
frame, the borders will be invisible to
your readers, and you can also hide any
scroll-bars. Using these features, you can
easily create some interesting effects for
your RoboAuthor  help documents.


Please refer to chapters 5 and 7 for
more details concerning the use of frames
and related special links.


Don't exaggerate!
With a little practice and your powers


of observation, you will soon get excellent
results with the several opportunities offe-
red by invisible tables, frames, back-
grounds and clickable maps.


To further enhance your work, some
graphics software is almost a necessity.
Use it to develop effects such as texture,
lens, aliasing and fading and also to create
your own buttons, image maps, split-line
and backgrounds.


Having said all that, only one more
rule requires attention. In order to create
really efficient and optimized pages:
"don't exaggerate!". With so much power
in your hands it's very difficult to set a
limit, but to keep your readers interest,
it’ s necessary to create light, quick and
efficient pages, so don’ t overdo the ef-
fects.


With this same aim in mind, we sug-
gest that you use the same background for
all pages, that you don't use more than two
different fonts (one for the text blocks and
one for titles) and no more than 3 font
sizes. Following these recommendations,
we are sure you will cope with creating
attractive and well-made pages. Nothing
else is needed.


Have fun with RoboAuthor!







F or any question, email the support
staff: support_ra@visualvision.com


For Immediate response to frequent que-
stions, read below!


− tutorials, basic questions
− link and pages, hypertext functions
− tables
− images, hot spots, areas, backgrounds,


icons, thumbnails
− styles and fonts (CSS)
− frames
− templates
− WINHelp HLP and HTML Help CHM
− CDROM publishing
− HTML - Applets - AEH - ASP
− .DOC / .ZIP / .PDF / Flash / Import files
− generic questions
− purchase


TUTORIALS, BASIC
Are there any tutorials for main features?
Yes, in the internal manual (hit the F1 key, then
click Tutorials).


I've downloaded the sample program. I don't
understand the directions on how to make it
work. Can you refer me to someone who can
show me how to use this program or whom I can
hire to do the work I need?
There are several companies specializing in deve-
loping HTML Help, manuals, CDs or ebooks.
You might ask in the program user's forum (see
on www.RoboAuthor.com).
The program is really no more complicated than
the popular MSWord, so a better alternative
would be to convince a friend who is computer-
wise to help you learn it. Once the program is
installed, find it from the Start >Programs
>Visual Vision menu. Then, from inside the main
program window, click on the "?-Help" menu,
then "Help", then "Tutorials". These will show
you many of the features and how to achieve the
required results.


Can RoboAuthor manage frames? And what
about the mouseover? Can it create HTML
Help? Does it make the coffee...?
The answer is always yes (well... not for the
coffee, but we’re working on it...!). To learn more,
read all the manual or take a deeper look at the
online tutorials.


1 0 .  F re q ue nt
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I have previously used another editor and I
can’ t understand how to manage HTML files
with RoboAuthor...
With RoboAuthor you edit a whole manual,
not codes and files. It manages all things
automatically, creating HTML files on-the-
fly. You can add code but you can’ t modify
the HTML directly. If required, you can im-
port old HTML pages using "File >Import",
the code is automatically optimized. If you
really need to touch the HTML code yourself,
we would advise that you search for another
program!


I imported HTML pages into the site, but
nothing is showing up!!
Use CTRL+ & CTRL- to move between pa-
ges.


LINK AND PAGES, HYPERTEXT
FUNCTIONS
I don’ t understand the way RoboAuthor sa-
ves pages.
All hypertext pages are saved in a whole
“AEH”  file. With “File >Save all”  or with the
toolbar button, you save all hypertext pages
with a single click.


...in the tutorial it says:...then, let’s press the
link button in the toolbar (sheet and chain, or
> "Insert >Link" from the main menu)... but
there is no button labeled "link" in the tool-
bar...and which toolbar?
Select a text block, then choose from the main
menu “ Insert”  then “Link”  if you aren't able to
find the button with the image of the sheet
and the chain. If you are on an image, use the
right mouse button, and choose “Define link” .


How can I set the size of a page?
You can’ t set the size of the page, as you can’ t
know what monitor and what window will be
used by the people that will see your site. The
safe way is to always use % tables (it is the


default in RoboAuthor) and to not assume
that the pages have a fixed size.


I want to change the page numbering as I
want to insert a page between page 1 and 2,
but I can’ t.
Yes, you can’ t. If you really need to do that,
you can insert say a page #3, copy the #2 to #3
with “Edit >Paste page from...” , then delete
all the text within page #2. Agreed this is not
quite what you are looking for, but the auto-
matic numbering is very useful to optimize
the publishing speed. Please remember that
the end user will not see the RoboAuthor page
numbers, only the page titles, so it really
makes no difference. If you were to label page
24 as "Page 1" and page 45 as "Page 2" this
would have no effect on your readers, as the
HP page number is just a facility to allow you
to switch pages without having to remember
the proper page names.


Can I change the number of page #0?
This is not possible. If you want to set another
page as home page, simply choose “Hypertext
>Current hypertext properties” , and click on
the left, on “cover” . Any page can be used as
cover, not just the #0. The #0 is just the
default.


How can I fix a page width to 535 pixels, in
order to obtain the ideal setting when printed
to paper?
You can fix this width for a table. Use the
right mouse button on a table cell, and click
“Properties” . However, it is better to use %
tables, so your work will display well on all
monitors, from 10 to 19” .


How can I place a link inside the same page?
The links within the same page are called
“Anchors” . You need first to place the
“Anchors” . In order to do this, move the
cursor to the link destination and use “ Insert
>Anchor”  from the main menu (or
SHIFT+F5). You will see an anchor icon. If







you select it with the right mouse button you
can edit its properties. A number is assigned
to each anchor.
Now select the text block or the image you
want to link, and use “ Insert >Special link”
(on an image, right mouse button, “Define
special link” ). Click on OK in the window
that will be shown. Then you will see a dialog
where you can select the destination Anchor.
Click on the anchor, then click OK. You can
test the result in “ read only”  mode (Hypertext
>Read only).


How can I link to an anchor placed in a
different page?
Select the text block you want to link, then
“ Insert >Special link” . In the dialog that will
be shown, do not choose the first tab but one
of the others (e.g. second tab “Normal” ), then
OK, and select the destination page. Within
the preview of that page you can click on the
destination Anchor (the number will be co-
pied in the box that’s on the right at the
bottom of the window).


Can I insert an alternate text on a link, like I
can do for images?
Select the text and apply the link with "Insert
>Special link" (or F5). Then click on the
"HTML" tab. In the box insert the following
tag: TITLE="insert here the tooltip text". Then
click on the first tab and choose any of the
link types (for example the second sub-tab,
"Normal", then OK).


What should I do to save a single page?
You can use "File >Save as...", or "File
>Export pages". In this way you can obtain
single Rtf or Html pages.


I've not been able to find out if I can have
different colors for links in the same frame...
You should define different text styles. Each
text style can have its own color/style for the
links. Use "Format >Styles", then the last tab
("link"). You can also set up the style of the


link (underlined, bold, or so).


Where can I find information about pages
contained in an hypertext / manual / guide?
How can I manage pages?
Creation: "Insert >New page", "Insert >Link",
"Insert >Special link".
Deletions, management: "Hypertext >Images
/files /link archive and erase".
Access: "Hypertext >Go to page", the bottom
center page number box, right mouse button
on this box.


When I'm editing a * .aeh file, how can I
delete a page (in my case page 0 as it is
empty)?
Page 0 can't be deleted. For other pages, use
"Hypertext >Images /files /link archive and
erase". You can also cut & paste another page
to fill the page 0.


I don't understand how to insert a link.
Select a text block, then press the button with
a page and chain. In the window displayed,
you can link to an existing page in the hyper-
text, or to a newer one - more options are also
available.
If for example you choose "new page", then
press OK, RoboAuthor will create the new
page for you, and will show the page in the
editor. If you link to an existing page, you can
choose it from an active preview - active
means that you can navigate through it like in
a browser. When you press OK, the link is
made and RoboAuthor shows the destination
page in the editor. See also the first chapters
of the manual.


How can I link an external Html page, for
example an Html page that already exists on
my Web site?
Select a block, chain button, choose
"Internet", click the “Add”  button and write in
the left box the address (e.g. "http://my-
site.com/ mypage.htm"), then press "OK".
How can I manage the pages different from







the main one? Just with links?
In the bottom center there is a box with the
current page number. Click on it with the
right mouse button, you will have a list of the
most recent visited pages. You can also use
“Hypertext >Images - files - link archive and
erase” , “Hypertext >Go to page...” , “File >All
pages...” .


How can I copy a page within another in
same hypertext (with Html I can do it with
"save as", then "open". Is there another way
in RoboAuthor)?
"Insert >New page", then "New page by
copying existing one"; or "New page by
copying from another hypertext", ...
You can also use "Edit >Paste page from...".


How can I manage headers and footers?
You might want to get HyperPublish,
www.hyperpublish.com. It includes all Robo-
Author functions, plus several other features,
including headers and footers.


Do you have some step by step guidelines on
how to create, open, and close popup win-
dows?
To open a popup, select a text block, "insert
>special link", 3rd tab (independent window
or popup). To close a popup, in the page
where the popup should be closed, use "insert
>page functions >open/close windows", then
specify the name of the popup. The popup is
closed on entering the page. You can open the
.aeh files used as examples (speciallinks.aeh).


I can only get to non-linked pages when I am
in the "edit/preview" mode, by using the page
scroller (the box at the bottom of the screen,
with the page number) or CTRL+-. Is this
normal? Will normal keyboard/mouse pa-
ging work when this Web site is "published"?
No, you have to place links. The other ways to
manage pages are only active in the editor
(this simplifies the creation / management of


pages).


Is there a limit to the length of the URL you
can insert with "Insert >Link", 3rd tab?
Yes, there is an internal limit. You can insert
longer links very simply, by using HTML
blocks ("Insert >HTML >Within the page").
Insert two HTML blocks, the first before the
text/image to be linked: <a href="http://the-
longurlhere.com/">, the second at the end:
</a>


Will your program allow me to create an
index at the top of a page, create a para-
graph or graphics several lines down the
page, use the indexed item as a heading for
the paragraph or graphics and link to it, also
add a 'return to top of page' at the end of
each paragraph?
You can insert any kind of links but you
usually have to insert links manually.
You can use "anchors" for links within the
page.


TABLES
Does percent % size mean the table will
automatically be sized to the content?
It means the table will fit the screen pixel
width, using a %. When you insert a new
table, the software use 100% as the default.
Unless you have a particular requirement, do
not change this setting. It will fit automati-
cally any browser window.


I inserted an image in a table. Why does it
appear in all cells?
Perhaps you inserted the image as the table
“background” . If you want to insert an image
as a single “cell”  background, use the right
mouse button on the cell, “Properties” , second
tab, then click the Sun and Cactus icon.


When I have to write words in 3 columns do I
have to insert a table or can I just use the
space bar?







It is better to use a table. Never use the space
bar as, if you view the page from another PC,
the size of the space might be different and
you will lose the alignment.


How can I create a table with more than a
column within a row?
You can insert a new table with any rows or
columns within a cell of another table.


How can I delete a table?
There are many ways. For example put the
cursor on a cell, press the right mouse button,
then choose "Select table", then press DEL.


How can I copy a table?
Select the table as above, then press
CTRL+INS. Move the cursor to the destina-
tion, then press SHIFT+INS.


I'm having a problem formatting text in a
table. The table text automatically formats
itself to Times New Roman (my default font is
Arial) and I also can't select the entire table,
column or row to apply the required format-
ting.
The table default style is "[no style in tab]".
Simply change that style with "Format
>Styles".


IMAGES, AREAS, HOT SPOTS,
BACKGROUNDS, THUMBNAILS,
ICONS
Animated GIFs don't play in the editor!
Move to preview mode (Hypertext >Read
only).


How can I move images and position them
somewhere in the page? I can’ t position an
image as I would like.
The “ fixed”  position for an image is good
when you create a text that will be printed on
paper, but has no sense for an electronic
manual or a CD, where the reader can see


your work inside an unknown width window.
Your user might use a 600 pixel or a 1200
pixel width window, and you don’ t know that.
The best thing to do then is to create a work
that will be seen well on any PC, in other
words a work that all readers will like. To do
this, simply use “ invisible”  tables (i.e. tables
without any border) to position images on the
page.


If I want to add a caption near to an image is
it better to use tables or frames?
Better to use a table.


How can I delete an image inside a table?
Select the image and press DEL two times. If
the image is a background, choose “Table
>Properties” . To delete the table, right mouse
button, “select table” , DEL.


Can I write some text over an image, similar
to using layers in a graphics program?
No, you should use PaintShop PRO or a simi-
lar graphics program to achieve this. Or get
3D Buttons for buttons (see the order page on
www.RoboAuthor.com).


Is there a fast way to change the image back-
ground for all pages of a site?
There are two ways. If the background is
already an image, use “Hypertext >Images -
files - l ink archive and erase” , select the
image, then press “ Replace...” . Otherwise
there is a button in the bottom right of the
second tab of “Hypertext >Current hypertext
properties”  dialog.


How can I place text beside an image?
Create a simple table with one row and two
columns. Inside the first column, insert the
image. Inside the second one, insert the text.


I am having trouble inserting an image with
transparent background. Sometimes it works
and sometimes not.







It should work for the large majority of GIF
images. However, not all images are suitable
to be automatically converted using the inclu-
ded transparent-color processor, so you may
have to proceed manually with paint programs
such as Paint Shop PRO or Corel Photo Paint.


Is it possible to add more than one clickable
area (hot spot) on an image? For me, the
clicking areas seems to disappear...
You can insert up to 20 areas per image. If you
need more, you can split the image in different
sections with a paint program.


I see the "paste from clipboard" can perform
the automatic conversion of a WMF to a GIF
/ JPG format with a lower byte size. As I
already inserted WMF images, can I convert
them to GIF in some way or must I reinsert
them?
Unfortunately, you must reinsert.


I can't insert animated GIFs with "Insert
>Animation"!
Please use "Insert >Image".


Where can I find the included clip art?
In the “ Insert >Images”  dialog, “From disk” ;
click on the icon with the mountain and the
sun.


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


How can I insert pictures that will be enlar-
ged in a separate window when you click on
them? Should I use the click area / hot spots?
What can I do with a click area?
A click area is useful when you want to assign
different destination links to different sections
of a single image. For example let’s say you
have a picture of yourself. You can assign an
area to the eyes, an area to the mouth, and so


on. A click on the eyes may display a page
where you talk about your wonderful blue
eyes and so on... :o)
If you want to create a gallery with some
thumbnails linked to larger images in a sepa-
rate window, you don’ t need to use hot spots.
Simply create a page containing a series of
small images, then insert a new page for each
enlargement and assign links to each small
image (right mouse button, “Define special
links” ). Inside the “special link”  dialog you
can specify to use a popup to display the
destination link (the page containing the lar-
ger image), and you can specify a name for
the popup.


Is there a way to place icons of thumbnails
on my page, then click to view a larger
image?
Yes, just insert a little image (you can do it
with a paint program) then insert a link (right
mouse button, "Define link") to a page that
contains the larger image. If you use "Define
special link" you can also show the larger
image in a popup.


How can I set a background image or a
background color for a page?
“Format >Page properties” , then click the
icon with the cactus and the sun. You can
also insert tables using an image as the back-
ground (click on a table or on a table cell with
the right mouse button, then properties).


I designed a navigation bar in Paint Shop
PRO, how do I insert that into page and add
links to each button?
Insert >Image then add hot spots (clickable
areas) with the right mouse button, then de-
fine links with right mouse button.


I have an image and some text on one page.
I want the text to line up on the right of the
image, and I suppose using a frame will do
it, but I can't get my image into a frame.
Better to use a simple table, rather than a







frame. Just use "Insert >Table" then use a table
with 2 columns, 1 row (If you want to create
frames, simply drag the top or left border of the
edit window).


I imported a picture into my document. Is
there any way to add a border or is that
something only available in the full version?
You can do this with a paint program. The
normal HTML border facilities are too limited
so they are not included at all.


STYLES, FONTS, CHARSET
If I change the font height, sometimes this is
lost when I write additional text. Why?
Do not move the cursor after changing the font
style.


Can I save a style?
Yes. Simply write its name in the styles cell,
then press ENTER, and the settings of the
current paragraph will be saved as style. You
can also import styles from another hypertext.
For creating new styles you can also choose
“Format >Styles” . See also the manual for
more info! Within the "Styles" dialog you can
import existing styles from other hypertext
documents.


How can I recall a style I saved?
Simply click on the styles cell and select the
required style!


How can I change the style of the links within
a table?
Like any style, i.e. by using "Format >Styles".
The default style for tables is [no style in table]


I have created an HTMLHelp and used some
of the fonts installed on my computer for the
page. The problem I have is when other peo-
ple view it, the fonts are not the same as the
ones I used to create the manual. Should I use
just fonts that are universal on all computers?


Yes, Times New Roman, Arial and Courier
New. If the user has MSWindows+Office
usually also Verdana and some others. Use
GIF images when you want different fonts.


Can I change the charset such as for Rus-
sian?
Within Hypertext >Current Hypertext proper-
ties you can change the charset of the site (say
for example windows-1251 for russian).
Do this before the actual typing.


FRAMES
How can I delete some frames I inserted?
You should delete them frame by frame. To
delete a frame you should move its border to
the top or to the left (depending of the kind of
the frame).


How can I remove the frames border?
Choose "Format >Page properties >Frame
properties" (or use the right mouse button). In
the dialog, uncheck the box “show rectangle
border”  and write 0 inside the “ border
between frames" box.


I am working with frames and I noticed that
the frames will not allow me to align text/
images to the top right-hand corner. It looks
like the frames have a top margin of about
.5". Can I get rid of this?
Yes, use “Hypertext >Current Hypertext pro-
perties” , second tab and set the margin as 0
(default is -1).


I want to add a page with frames. I want to
use as an existing page as a frame.
Create a new frame set. Within a frame, use
the right-click mouse menu to select which
page will fit the frame.


I have a page with too many frames. I went to
"Hypertext", then "images - files - hyperlink
archives and erase" and tried to delete the







pages with the frames. When I go back to the
page, the frames are still there. What am I
doing wrong?
You probably deleted another page. When
working in the page with the frames, press the
"no frame" button at the bottom of the page.
That switches the view to "no frame" mode,
(note: it doesn't actually delete the frames, it is
just a display option). This way you will see
which is the master page for the frame set.
Delete it and the frame set will be deleted.
Another way to delete a frameset is to replace
it with another, (Format >Advanced frame set
manager).


TEMPLATES
The templates seem to be in Italian! Where
could I get English ones?
The templates are not in Italian. It is a dummy
latin-like language that has no meaning. The
text is there purely to fit the page for demon-
stration purposes. You can replace it with
anything you like.


WINHELP AND HTML HELP
I'm having trouble getting * .HLP export.
What is the difference between * .HJP and
*.HLP, as I only seem to get * .HJP to export,
and this certainly doesn't work as a * .HLP
file
HJP (and other fi les generated by Robo-
Author) must be compiled with the MS help
compiler (HPC) in order to obtain the HLP file.
RoboAuthor can do this automatically but
HPC should be installed. See the
www.RoboAuthor.com Web site for more
info.


I have problems creating a .CHM file
(HTMLHelp)...
First verify that the Microsoft HTMLHelp
Workshop is installed (see the FAQ on
www.RoboAuthor.com for more information).


If ok, choose "Publish >Export pages", then,
at the top, "HTMLHelp" as the format. In the
"path" tab please choose a temporary directory
for the temporary files needed during the pro-
cess, e.g. c:\temp. Then press "Ok". If the
Help compiler doesn't automatically start, se-
lect the c:\temp folder within Windows Ex-
plorer and double- click on yourfilename.hhp
(if file extensions are disabled on your PC,
you should see 3 yourfilename files, in this
case please click on the one with strange
shape). Once the HTMLHelp Workshop is
started, choose "File >Compile", and you'll
get the .chm file.


After I compile as HTMLHelp, a page doesn't
show in a Window. When in simple HTML or
while in RoboAuthor it works...
You should include that page somewhere in
the TOC (Hypertext >Predefined page order -
TOC), so the Microsoft Compiler is able to
find it.


Can I use a .CHM for context sensitive Help?
Yes you can. The Context-ID (or Topic ID)
for each page is the page number. See your
programming environment manual to see how
to call an HTML Help topic by Topic ID.


What if I want to call context-sensitive Help
(i.e. I want to call a chosen page when the
user hits F1), in Delphi 3/5? VB?
Delphi: download the unit supplied on the
www.RoboAuthor.com Web site, and add it
to the “ uses”  section. Then use “Project
>Options”  to assign the name of your .CHM
file as Help File name. Then insert the page
number you want to call in the “HelpContext”
section of each control (as you did for
WinHelp). VB: see Web site.


CDROM PUBLISHING
Can I create a CD with RoboAuthor for a
third party? Are there some royalties to be







paid? Should I include any license informa-
tion?
No, you should get HyperPublish for doing
this (www.hyperpublish.com). With HyperPu-
blish you have no royalties to pay. CDs created
with RoboAuthor are for internal use only
(within your firm / company).


I can't understand how to create a CD.
Please read the CDROM tutorial ("?-Help"
then "Help" then "Tutorials"). It is really sim-
ple.


Does RoboAuthor support DB files when on
CD?
Ho, RoboAuthor does not support DB files.


I have several PDF files that I would like to
place on a reference CD. Can RoboAuthor
import PDF files? If not, how can I link to
PDF files?
You can't import PDF but you can simply link
them with the "run:" command, i.e. you can
place links like "Click here to read document
#1", where a click will launch the PDF (search
for “Advanced CD functions”  in the online
help). You may also include the Acrobat Rea-
der on the CD and run it with the same "run:"
command, i.e. you can place a link such as:
"please click here to install the Acrobat Reader
if you don’ t already have it".


Can I use a Java Applets, Active X controls,
Javascript, VBScript or ASP when creating a
CD? I added an applet and I can view it in
the browser but when I build the CD the
applet doesn't show.
The RoboAuthor internal browser can't run
Applets, Active X or Javascript. You can
however export as HTML files (File >Export)
then create an HTML CD. Applets and so on
will work on .CHM format (HTML Help).


I have created a CD with the internal CD
Wizard, but when I install it on a PC, it


transfers all AEH files to the users HD. Is
there a way to avoid this?
Yes you can instruct the program to leave the
main part of the files on the CD, (this way
your user will need to keep the CD inserted to
see your work), see Chapter 8.


I can't understand how to create a CD.
Please read the proper chapter or the  CD-
ROM tutorial ("?-Help" then "Help" then
"Tutorials"). It is really simple.


Can I protect the CD with passwords?
No. You should use CDFrontEnd for doing
this (www.cdfrontend.com).


I'd like to be able to have one link on a page
that says "Available documents" and when
the user clicks it, a window will open
showing file folders and available files to
use. There will be around a hundred files on
this resource disk, and to create links to all
of them would be too much work.
Select a text block, choose "Insert >Link"
from the main menu, choose the 3rd tab, then
the "Add +" button, then instead of "http://.."
enter "run:c:\path" or "run:cddrive:\path" (in
the latter case, the program autodetects the
CD-drive when the Reader is installed from
the CD-ROM, and automatically replaces the
cddrive keyword).


Does your software support PDF files or can
I convert them into something else?
With RoboAuthor you can create an hyperme-
dia CD with links to PDF files. You can also
include on the CD a page where the user can
install the Acrobat Reader (see run: function
in Advanced Functions Chapter).
RoboAuthor can't import PDF files, but many
clients are using the handy RoboAuthor inter-
face to manage collections of PDF files on
CD.


I have spent some time trying to publish my







finished .aeh files to a workable CD. This is
my biggest problem: everytime I want to re-
configure a new version of the CD, the CD
wants to continue using the my settings. I've
tried uninstalling the program and reinstal-
ling it, but they're still there. Where are these
preferences being stored?
If you are creating different CDs, the only
important thing is you must configure the pa-
rameters in the wizard properly. See the tab
"customize" then the subtab "reader settings".
The parameters in this subtab MUST be diffe-
rent for different CDs, to avoid problems /
superimpose of different CDs. If you use iden-
tical parameters for 2 CDs, you tell to the
program that 2 CDs are identical, so the install
will treat them as identical.
The settings are saved in a .wzz file (see
"Save" and "Load" buttons in the first Wizard
tab; use "New" button to start a new CD
project).


How can I run a RoboAuthor document from
a CD without installing it first? How can I run
the RoboAuthor Reader without installing it?
How can I change the autorun file so that it
runs the reader off the CD?
This is not possible with RoboAuthor. We
have another product with this feature, it is
called CDFrontEnd.


I recently purchased RoboAuthor and found it
fairly easy to use, but I am looking for auto-
run... With “ CD Front End”  can I create a
disc that is “ auto-run” , but is NOT, repeat
NOT “ auto-install” ?
Yes you can. See www.cdfrontend.com


When making a CD, how can you add a link to
exit the program?
Just select a text block, "Insert >Special link",
then select the "Close window" tab, check the
"main window" checkbox.


HTML - APPLETS - AEH - ASP
How can I modify the HTML of a page?
You can just add code, you can’ t modify the
automatically generated HTML. RoboAuthor
is designed with an internal optimizer that
works well both with IE and Netscape. As it
is a bit possessive, it doesn’ t allow external
interference. If you want to add code ma-
nually, use "Insert > HTML", or, with any
object selected, use the right mouse button,
"Properties", and the HTML tab.


I want to name the home page as
"index.htm", how do I do that?
Use "Hypertext >Present hypertext proper-
ties", tab "Page settings, background".


I want to supply the HTML file name for a
page. For example "mickey.html" instead of
"nameaeh_000002.htm", how is that done?
Use "Format >Page properties", and the cen-
ter left gray box. This will not cancel the
automatic naming, but will add a redirection
page.


What should I do if I want many Html pages,
or I want to see a preview?
Use the "Publish" menu.


What can I do with an "AEH"? Can I only see
it with RoboAuthor?
You can see an "AEH" with almost all Visual
Vision products, and with iPerReader (works
on the same principle as Acrobat Reader: it is
automatically included by the CD Wizard).
An AEH file contains a whole hypertext, so
your work becomes easy to share. With the
"Publish" menu you can convert into Html or
Rtf files anytime you want.


How do I attach Java Applets to a page?
With "Insert >HTML" insert the HTML code
related to the applet. Instead of the class
name, i.e. where you find the clas-
sname="appletname.class" part in the code,







just write classname="", then place the caret
inside the brackets and press the button "Insert
page or file ref", then choose the 3rd tab and
search for the .class file in the HD.


Can I manage ASP pages with RoboAuthor?
Certainly. You can use "Insert >Html >Within
text" to insert ASP code. You can also take
advantage of custom components ("Tools
>Custom components prototypes") creating
custom components libraries (every compo-
nent can have parameters, so you can reuse it
with ease in the text). As RoboAuthor uses
".htm" or ".html" as the file extension, you may
have to ask to your server administrator to
enable these extensions also for ASP pages
(usually ASP pages are named ".asp", but it is
easy to override this setting).


DOC / ZIP / PDF / FLASH / IM-
PORT FILES
Why does the size of the AEH remain the
same even if I delete some multimedia files ?
It is not sufficient to delete a link, a button or a
video with the CANC that deletes the button.
RoboAuthor archives each thing you use in an
internal archive or “album” . If you delete the
link, the file remains inside the album, to
enable fast reuse. If you want to delete the file,
please choose “Hypertext >Images - files - link
archive and erase” , search the file then delete it
with DEL.


Can I save in PDF format?
Indirectly you can. If you have the Adobe
product installed, choose "File >Print" then
print to the "Acrobat Distiller". Otherwise you
can install a fake PostScript printer (an Apple
LaserJet for example), print to FILE: (instead
of LPT1), save the file as filename.ps then use
the free Ghostscript (you can find it on sim-
tel.net) to convert from PS to PDF. A correct
Ghostscript command on the DOS prompt is
gswin32c -q -d -dPDFSETTINGS=/printer -
dCompatibil ityLevel=1.3 -dNOPAUSE -


dBATCH -sDEVICE=pdfwrite -
sOutputFile=c:\nomeoutputfi le.pdf nome-
file.ps).


Any examples for interacting with Flash?
Just use “ Insert >Flash” .


How can I import files?
To import, use "File >Import" and choose a
file format (RTF; HTML; ASCII), then search
for the files you want to import in the file
system (shown on the left) and drag them to
the right. The program can import multiple
files at a time and automatically divide a
single file into pages. Use CTRL+ CTRL-
after the import to see the pages.
The program is designed to be used for crea-
ting BOTH Web site and CDs; the import
functions sometimes discard the text format,
so it would be better to use the native program
functions once you have learnt them.


When I import RTF, how does the system
split a single file into multiple pages, how
does it decide when to end a page and start a
new one?
It uses an internal criteria.
You can choose (in the import format menu)
one file/one page or one page/one page. The
latter option ensures that page breaks in the
existing document are maintained in your
created pages.


I have imported RTF pages, but most of them
do not include the "continue" link on the new
pages.
You are supposed to write the pages INSIDE
the program. If you import the pages from
another program, YOU will need to add the
links. The program can place very powerful
links, not only the sequential links expected
for a sequential piece or book.


After importing, the very first page is blank
and I can not get rid of it.







Simply copy another page inside it. Alternati-
vely, change the settings of the program so that
the cover page and the summary page are not
using the first page (Hypertext >Current Hy-
pertext properties), then second tab, then click
on the left on "cover" or "summary" and
choose the required page.


I imported an .rtf document and set up some
links to certain portions of it (hypertext?).
The links work fine, but in the non-edit, pre-
view mode, I can only get to the linked pages,
not the ones without links.
This is normal, as the preview mode is desi-
gned to work as if published, and no pages
would be available in a live situation, unless
linked.


We have user manuals which were created
using another program. If we choose to use
your software, will we be able to maintain/
edit/revise the old manuals in it, or will they
have to be recreated?
If your other program is able to save in RTF,
HTML or ASCII formats, or at least allows
copying to the clipboard, you will be able to
import the data to our software (possibly some
reformatting will be required).


Can your program import Word Perfect for-
mat (WPF files)?
Not directly, but within Word Perfect you can
choose "Save as..." then save your file in RTF
format, that can be imported by our program.


GENERIC QUESTIONS
I can’ t find the answer to my question!
No problem, just write to us! We respond to
all! support_ra@visualvision.com


I can't delete some objects with DEL.
Use DEL twice.


The XYZ window displays too small for me!


Please resize the window. RoboAuthor stores
and remembers window settings.


How can I see the hypertext on a browser?
Use "Publish >Browser preview"


I'm writing a manual for an application and
I need to include multiple copies of the appli-
cation logo and application name. Is there a
quick way?
Create a new page, insert the name and the
logo of the application.
Then you can use "Edit >Paste page from..."
to insert the logo anywhere you want.


I can't use tabs!
You can use the "reduce indent" and "increase
indent" buttons.


The copy and paste procedure sometimes
discards the text format.
This can happen for short text, as RoboAuthor
tries to use intelligent behavior when you cut
& paste. Sometimes the behavior is not exac-
tly as you might expect.


Can I insert the same text and/or image
group in multiple pages, like a "C include"?
Yes, simply create a new page and enter the
required text and images. Then, for each page
that will contain the text, use "Insert >Html
>Within text", then use the "insert page in
text" button. A window will display allowing
you to select the page to insert. Note: This is
not a fully visual operation, and works only
when Html publishing. For a fully visual
system, see another FAQ in this page.


How can I make floating windows?
When a user browses your site / hypertext,
there are two ways a window can show:
- when user clicks on a special link ("Insert
>Special link")
- when user enters a page that contains an
"open window" component ("Insert >Page







functions >Open / close windows"
See samples in "? >Examples".


In multi-frame pages Netscape sometimes
hangs.
This is due to a style-sheet bug in some relea-
ses of Netscape 4. To avoid the problem, use
"Format >Reformat" on all paragraphs within
the hanging frame. You may have to define
some additional styles to accomplish this.


Netscape reports "Javascript error,
IperF_open not found in page xxxx.htm".
Edit the page in RoboAuthor and insert a
special link to a pop-up, even a hidden link,
e.g. a white comma on a white background.


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


I can’ t “ minimize”  the application.
Select “Tools >Program options”  then “Reset
dialogs settings” , then exit from the applica-
tion.


I have a problem with the program locking
up. It seems to be related to the file I am
working in because I had a few other files I
was working with and I am not having the
problem there. If the file is corrupted in some
way is there anything I can do about saving
some of the pages? Help! I don’ t want to start
over!
When a file is corrupted the most practical
way is to open a new file, and copy the pages
(the non-corrupted ones) from the old file,
using "Edit >Paste page from...".


What is the difference between RoboAuthor,
EasyWebEditor, HyperPublish?
EasyWebEditor (EWE) is purely for Web de-
sign; RoboAuthor (HP) can create HTML
Help, WinHelp and auto-install CD-ROMs.


HyperPublish includes all RoboAuthor and
EasyWebEditor functions, plus several other
features (see www.visualvision.com Web site
for a comparison table)


I have EBooksWriter. What is the difference
with RoboAuthor (RA)?
The EbooksWriter can create self-extracting
ebooks, i.e. it can transform an AEH file to an
EXE file that a user can click and see (without
anything else installed). With EbooksWriter
you can also password protect pages or set of
pages (they will be encoded with a strong 128
bit encryption). You can also disable print or
clipboard copy. The interface is very similar
to RA, and you can read RA files.


Do you have a Mac edition?
No.


I have an icon for email - I've checked the
tutorial and can't find out how to make this
work!
Very simple: select the image, right mouse
button on it, "define link", 3rd tab, "+ Add"
button, then enter
mailto:youraddress@aol.com


I can't get the spell check working!
The application uses the MS spell check en-
gine. Some installations of Office 2000/XP
mess things up. A practical solution to get
things working quickly is to install an old
MSWord release (for example Word 7), or see
the User’s forum.


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


The program says “ Access Violation XXXX” ,
then hangs...
You have too much applications opened (” too
much”  may mean 4-5 in Win98/ME...!).







Close some apps or restart the computer.
The error numbers like 00231245E are no use
to us at all.
If this happens and you are able to provide us
with step by step instructions on how to repro-
duce the error, (e.g. open the program, write
"mickey", press "save" and the error
ALWAYS happens) we can correct the pro-
blem. Often it is not a problem with the pro-
gram, but a problem of limited handles within
MSWindows.


Can I show an external URL in a frame or a
pop-up?
Yes, create an empty page / frame / popup then
use "Insert >HTML >Within text" and insert
this code:
<script language=javascript>
<!--
location.href="http://www.abc.com"
//-->
</script>
The empty page will be replaced with the
external URL (http://www.abc.com). Use pa-
rent.location.href="" in case you want to re-
place a whole frame set.


My popup window works fine in preview, but
does not work at all in browser preview or on
the net. Do you have any ideas as to what is
wrong?
This can happen if you use a window name
that includes spaces or strange characters. Ple-
ase use something like "Mickey" as a window
name (without the quotes). "Mickey Mouse",
"123bcd" or "Mi$%/&" for example, are not
valid identifiers.


If I switch to “ read only”  (Edit/Preview but-
ton), the slides don’ t appear to work.
You have to use "Hypertext >reload page" to
start the slide sequence. To obtain this at load
time, configure the hypertext as "Read only"
using "Hypertext >Options".


I have noticed that in some of my work, when
I resize the windows (larger or smaller),
some tables or images move and don't retain
their position. Is there a solution to this
problem?
You would benefit from practising with the
"invisible" tables, and learn how to use them
to correctly position images and text. You
must remember that the final users screen and
window sizes are unknown.


Is there a way to setup a printing order for
the pages, so when the user wants to print,
there is a predefined order?
Just use Hypertext >Predefined order - TOC
to setup an order. You can define chapters and
subchapters, or just sequential pages.
Then with File >Print you can choose to print
the pages by using the predefined order.


I get "Share error... "
This means the same file is opened in another
instance of the program (go to the task bar
and close the other instance); or out of disk
space; or the AEH file is marked as "read
only" in the MSWindows file manager.


Our primary interest in RoboAuthor is ini-
tially to use it to print manuals & catalogue
price list and to the migrate that to CD's.
Is this ok? There is not much mentioned on
the Web site that I could find on Printing...
As said on the Website, RoboAuthor is for
CD or HTMLHelp output, not printing.
However the software can quickly export all
pages in RTF format. You will then open
them in MSWord or Corel Ventura or XPress
or Publisher, page them, and print.
Video manuals/catalogs and printed manual/
catalogs are COMPLETELY DIFFERENT
worlds (the paging is different, relative vs.
fixed, the paper doesn't support image hot
spots and hyper links etc...) so a program that
claims to be suitable for both world can not be
real.







But an approach like explained above is reali-
stic and actually used by some clients.


PURCHASE - REGISTRATION
I created some pages with the trial version,
can I use the project with the registered edi-
tion, without having to redo it all?
Yes, sure.


I have some registration problems.
Write to the address provided in the registra-
tion email. Be sure to include your order # and
possibly attach the receipt of the payment so
we can proceed faster.


How can I get RoboAuthor?
Go on the www.RoboAuthor.com Web site.


You can purchase online (through a secure
store) the electronic edition or the CD.


For any question, any suggestion:
support_ra@visualvision.com














