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It may surprise you, but the first Web site was not built until
1994. Until more recently, to create a site it was necessary to
learn the complex HTML code language, and to deal with
dozens or hundreds of files, one per page.


Even today, for historical reasons and due to the high speed
of Web development, some well known Web site building tools
still require a technical approach and some HTML code
experience. In other words, these tools are not what could be
described as handy.


EasyWebEditor may be the first Web tool expressly
designed to let users concentrate on the content rather than
code and physical files.


As with wordprocessors, you're not concerned with how
pages and images are stored, you simply work with a complete
file: so it is with EasyWebEditor. You act on a complete site
and never worry about the low-level detail.


Obviously EasyWebEditor is more sophisticated than a
wordprocessor, as it has many additional hypertext functions.


This behavior makes the Web world accessible for absolute
beginners, while at the same time making Web experts more
productive. The auto-optimized code is handled for you, so
why waste time in repetitive chores when you can use your
time to develop superior content.


We wish you success working with EasyWebEditor and feel
sure you will gain almost as much satisfaction from using it, as
we did while designing and writing it.


Ing. Aldo Ghigliano
President, Visual Vision
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Using Web-sites is the most effi-
cient and cheapest way to distribute data
and information. EasyWebEditor opens
this method to you, allowing for easy crea-
tion of personal and business sites with the
least possible effort.


Everything you need to build a great
site is within this  productive tool. And,
although Easy Web Editor is packed with
functions, everything is designed with
speed and simplicity in mind.


EasyWebEditor is not for lovers of
“ code”  and technical details, you won’ t for
example see any HTML code during nor-
mal creation of Internet pages. The pro-
gram does support such tasks, in addition
to being automatic compatible with most
widely used browsers, but unless you feel
the need, you just don’ t have to worry
about these things.


In fact, EasyWebEditor  was conceived
for every day utilization, much like most of
the common word-processors that you use
for printing works on paper.


There are essentially two big differen-
ces from ordinary editors: firstly, EasyWe-
bEditor in effect allows you to “ print”  on
the Internet rather than on paper; secondly,
EasyWebEditor manages your website as a
complete set of pages, rather than as stand-
alone pages. It uses an interface specifi-
cally optimized to manage hypertextual
links between pages (i.e. words or pictures
you can click on to be carried to internal
sections or to call external documents).


The simple yet powerful editor inter-
face provides you with the opportunity to
use styles, tables, hot spots, frame sets,
slides, forms and popup windows easily.
And what’s more, it’ s all visual, WY-
SIWYG (What You See Is What You
Get), that means what you see in editing
mode is really what you get when you
publish on the Internet.


EasyWebEditor is also WYSIWYL
(What You See Is What You Link): this
means that all links between pages can be
defined directly on screen and they’ ll be
immediately “ active” , enabling you to fol-
low them from within the editor, simply by


Introducing
E a s y W e b E ditor
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WebEditor is optimized in order to speed
up the website creation and management:
no programming and codes means that you
can dedicate your time to the layout and the
content; hypertext optimized means you
can perform several global actions (on se-
veral pages) with just one click (saving a
hypertext; publishing on the Internet; glo-
bal searching and substitutions...) thus sa-
ving time.


At the end of the day, the original Ea-
syWebEditor design makes everything ea-
sier for everybody, not just for beginners.


In conclusion, EasyWebEditor is a
powerful tool for people who want to be
free to think about what they’ re doing: a
good Web site (or maybe several Web
sites!).


The application requires a PC with
MSWindows 95 osr2, 98, Me, NT, 2000,
2003, XP, Vista and at least a old Pentium
I 100MHz, 32Mb of RAM and 32MB of
free Hard Disk space.


We are sure you will appreciate both
our software, and the vast effort behind
producing it. Enjoy!


double-clicking. Furthermore, when you
select the destination page of a link, all the
dialogs have a preview screen, to make the
selections even simpler. You see a preview
of the selected page, and you can navigate
within that preview, simply by clicking a
link, so you can reach the required destina-
tion page by either name or navigation. It’ s
really much easier to use than it is to
explain!


The archive functions are also optimi-
zed to manage your website as a set of
pages: every project is saved by EasyWe-
bEditor as a single hypertext file in its
native .AEH format. HTML and RTF are
kept behind the scenes and treated for what
they are: nothing more than printing lan-
guages, which could be updated in the
future without any user intervention.


The Internet publishing is handled by
an internal FTP engine (FTP is the most
common standard for Internet publishing),
capable of publishing a whole site with just
one click, taking care of transferring only
the new / modified pages.


EasyWebEditor means a change of
mentality in people who are accustomed to
writing HTML and managing scattered fi-
les: as said, it’ s not a code editing tool and
the interface has not been designed around
files and codes, like older editors. Easy-
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1 .  Y our f irs t w ork


some text into the page. Enter a line or two
of text about vegetables and include the
word “ potatoes” .


The number “ 0”  shown in the central
text-box at the bottom of the current page,
indicates that we are on page “ 0” .


Now we can select a word, which is
done in the same way as in many other
applications; simply drag your mouse over
the word or double-click it: let’ s select
“ potatoes”  (See Fig.2), and now click the
Link button on your toolbar (the one with
the chain and a page on) as shown
here:


The window in Fig.3 will be shown;
this is one of the most important dialog
windows, because it allows us to define
many link types, by simply choosing one of
the tabs on the top.


But let’ s get on: Choose the “ New
page”  tab (the last on the right) and press
the “ OK”  button. EasyWebEditor will de-
fine the link and, at the same time, will
take us to a new page, where we can
provide more information about potatoes.


If you check the text-box at the bottom,


O nce you have EasyWebEditor
installed on your PC, either from a CD or
an Internet distribution release, you will
doubtless be impatient to make your first
page.


The first thing to keep in mind is that
EasyWebEditor operates on hypertext do-
cuments, not on single pages. This means
that multiple pages can be loaded in me-
mory at the same time. At any time, once
they are created, it is possible to browse
pages, create new links, navigate
throughout a file, or carry out a search. The
easiest way to pass from one page to
another is using CTRL+ and CTRL- keys.


Inser ting links
Linking pages is really very simple:


let’ s make a simple example now, by crea-
ting a hypertext consisting of two pages,
each linked to the other.


Let’s run EasyWebEditor: the window
in Fig.1 will appear, ready for you to type
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in this case). We can now directly choose
the link destination on the screen, so let’ s
choose “ Vegetables” .


Click on the “ OK”  button and Easy
WebEditor takes us to the page in Fig.6
(page #0). Notice here that the link to
“ potatoes”  is underlined blue text. If we
double-click on the word “ potatoes” , the
editor will automatically switch to the
“ Potatoes”  page (page #1).


From this page, we can double-click on
“ Back to previous page”  to return again to
page #0, and so on.


As you can see, creating links and navi-
gating through them with EasyWebEditor
is really very easy, even from within the
editor.


There are several ways provided to
move from page to page: you can type the


you’ ll see the current page number has
switched to “ 1” .


Let’s add a little text now, as shown in
Fig.4. At this point we need to insert a link
to the previous page (page 0), the one


about vegeta-
bles.


Now type
then select the
text “ Back to
p r e v i o u s
page” , and
click again on
the Link but-
ton (chain pic-
ture). The


window, as shown in Fig.5, is displayed
showing us a list of all available pages
within the hypertext (page #0 and page #1


Fig.1 –
EasyWebEditor
main window: to
write something,
just type on your


keyboard…


A hypertextual link
usually looks like an un-
derlined word or sen-
tence: with a click on it
you will jump to a rela-
ted page (a double click
when in edit mode).


Fig.2 – Let’s
choose a word
within the text,
"potatoes" for


example
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page number directly in the page number
text-box; use the up and down arrows be-
side it; use the right mouse button over the
same text-box (a list of recently visited
pages will be shown); you can also use the


red arrow buttons at the top left to go to
previous or next visited pages.


Using the Hypertext menu at the top,
click “ Hypertext > Read-only”  to switch to
a non-editable preview of the hypertext:


Fig.3 – The Link
to... window where


you can define
simple links: just


select the last tab


Fig.4 – Let’s write
something in page


1. Then let’s
highlight the text


“Back to previous
page”


Fig.5 – The window
where you can


visually choose the
target for your link.
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This is handy as you won’ t need to click
twice on links, and table grids will be
hidden, but more on that later.


It’ s now time to save your work:
Choose “ File > Save all”  and the whole
hypertext / website will be saved into a
single file with the .AEH extension. The
process is the same whether 1, 2 or 100


pages; 1, 2 or 100 images, in this way
EasyWebEditor keeps your work compact
and simplifies the tasks of making back-
ups and exchanging files.


In later chapters however, we’ ll show
how passing to HTML or other format files
is immediate.


Fig.6 – We’re back
to page 0, and  can
see that the link to


the "potatoes" page
is already active.
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>Internet FTP >Publish on the Internet...” .
As you may guess, the first time we


publish the program needs to know
“ where”  and so it ask us to setup the “ FTP
parameters” , with the Internet Publishing
Setup Wizard (Fig.7; these parameters can
be changed at any time using “ Publish >
Internet FTP > Setup...” ). Obviously we
cannot tell you your personal settings,
since these are different for everybody. As
stated earlier, these are given out by your
service provider / host (see also in the
on-line guide “ ? > Help”  the relative step-
by-step tutorial).


Once the configuration is done, (please
note that this only has to be done once,
since the application stores your personal
parameters for  future use), the window in
Fig.8 will appear. A white bar and a
“ Stop”  button will be visible while EWE
checks the server for any previous version
of the current hypertext / website.


If a previous version of the current
hypertext is located, an automatic proce-
dure runs to check for modifications made
since the last publishing operation. Only


I f you want the whole World to be able
to see your Web pages (your personal
ones, or your company site) the pages have
to be hosted on a computer permanently
connected to the Internet (the “ Web ser-
ver” ).


Maybe your firm already has it. Or
there are many firms with dedicated Inter-
net connections that offer this service for
free or for an annual / monthly fee (write
us for more info!). In any case the publi-
shing phase (to move your pages from your
PC to the Web sever, thus making them
available to the World) uses the so called
“ FTP”  standard (File Transfer Protocol),
and the “ FTP parameters”  supplied by your
host or your system administrator are the
“ key”  for accessing your web space.


Let’s publish via FTP
Now let’s look at a simple example


where we’ ll publish the pages we created
earlier. This is easy: choose “ Publish


2 .  Inte rne t p ub l is h ing
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lected pages will be transferred. When the
transfer is complete, EWE will display a
confirmation message, together with the
version number of the hypertext currently
on the Internet.


During the publishing process, it is
always possible to deselect pages or abort
the transfer operation.


Common FTP errors such as 530, etc.
are explained at www.easywebeditor.com/
ftp/. The program works on any server that
supports the FTP service, problems are
usually caused by the host, the internet
provider, or by your antivirus / firewall / or
any other blocking software or hardware
(example: some wireless routers have an
internal firewall); or simply by incorrectly
typed parameters.


the changed pages are selected for publi-
shing. The pages selected for publishing
are the ones shown on the left-hand list
with a check-mark beside them.


Despite the automatic process mentio-
ned above, it is possible to manually over-
ride page selection. Perhaps you want to
force publication of a certain page, or de-
lay publishing of other pages, simply click
the appropriate check-box with your mouse
to select or deselect pages. If you get a
slow modem connection, the manual
method could be useful for splitting a hy-
pertext into several segments, allowing you
to publish it over subsequent connections.


Once your selection is made, whether
manually or automatic, you just have to
click on the “ Publish”  button, and all se-


Fig.7 – The  FTP
configuration


wizard; the FTP
configuration tab


requires the same
parameter


Fig.8 – The FTP
window:  the left
panel shows the


files to be
tranferred; the right
panel lists the files


that are currently
on the server.
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Expor ting HTML
Normal people won’ t probably use the


HTML export feature.
Anyway, the HTML export feature al-


lows you to save a different file for each
page and image used in your hypertext to
your hard disk.


You can activate this by choosing “ File
>Save other formats / export pages...”  or
“ Publish >Export pages...” . The window in
Fig.9 will be displayed, allowing you to
select which pages are to be exported using
the familiar check-boxes.


Using the “ Path”  tab (see Fig.10), you
can specify the folder where HTML and
image files should be stored as the result of
the export.


An interesting point to notice here, is
that EWE generates HTML code only “ on
demand” , when FTP publishing or while


exporting pages. At all other times, the
native ‘aeh’  format is used. This is quite
unusual for Internet software programs,
and results in HTML being treated like a
mere printing language like Postscript, just
as it should be.


At the end of the day EWE saves you
time, allowing you to concentrate on the
content, rather than the technical side, thus
saving you a lot of unnecessary worry.


Browser  preview
Even though the integrated browser


within EWE is very true (EWE is WY-
SIWYG and generates optimized code to
provide the best results on all browsers,
even older NS2 and IE3 browsers), many
users still want to “ try”  their pages directly
with the actual browser.


Fig.9 – The export
window used for all


formats; in this figure
HTML is selected...


Fig.10 – The tab
which allows you to


define a path for
exporting your


HTML…
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EWE allows you to do that, by using
the “ Publish >Browser preview”  feature.
You can see the current page, or even the
whole hypertext, using your default brow-
ser, and you can also add menu items for
quick access to other browsers. You can
easily define these entries by selecting
“ Tools >Options >Browser” . The window
shown is very easy and intuitive.


FTP profiles
In case you have experience of publi-


shing Web pages on different Web sites
using FTP,
you’ ll proba-
bly need to
save different
conf i gur a-
tions, or profi-
les. EWE al-
lows you to do
this by using
“ P u b l i s h
>Internet FTP
>Setup...” . In


the window displayed (see Fig.7), just click
on “ Add new...” , beside  “ Server settings” ,
to define a new user profile. This will
allow you to maintain several sites without
having to enter all the different information


each time.


Technical information
While executing the given examples,


expert users would notice that pages are
referred to in the editor using the page’s
title (high level name), rather than the file
name (low level name). They would also
notice that file names are generated auto-
matically by EWE, using an optimizing
criteria which improves performance du-
ring FTP publishing.


Internet conventions often dictate that
the main page (home page) of a site is
named index.htm or index.html. To comply
with this requirement, or should you wish
to choose a different name, you simply
select “ Hypertext >Current hypertext pro-
perties” , then select the “ Page settings,
background”  tab and use the “ Cover file
name (HTML)”  text box on the top right.


If you need to specify a different name
for other pages (for example, you could
name the page about potatoes pota-
toes.html), simply use “ Format >Page pro-
perties...”  and insert this name (e.g. pota-
toes.html) within the gray box on the mid-
dle left. This new name will be an alias for
the normal name.


Fig.11 – Defining
shortcuts to run


alternative
browsers…


EWE does generate
Web sites that will be
displayed well on all
browsers. The most
common Internet brow-
sers are Netscape, Mi-
crosoft Internet Explo-
rer, Opera and Mozilla.
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vantages of using styles is to consider this
document you’ re reading now: every single
page has a title; the title style is the same
for all pages and is different from the text
style (Titles are larger and use a different
font, or typeface).


Saving different styles for titles and
normal text offers these advantages:


− You save time in applying a set of
attributes (if we hadn’ t used the
‘Title’  style for this page, we would
have needed to select each title, ap-
plied a font and a size, applied bold
and set the color);


− You can immediately modify multiple
pages, or even the whole document,
by simply changing one little thing. If
you decide to use green for the titles,
you just need to modify ‘Title’  style,
and it will be applied to all pages
instantly;


You can use styles in many different
ways. The easiest way to create a new
style is to apply text attributes to a text
block. As an example, you can select any
number of words, set a size of 15 and


N ow we’ve had some practice
with the simplest ways to manage pages
and links, let’ s have a look at the main text
functions and how we can use them.


Text format
Nowadays, all word-processors have


standard buttons to let you apply ‘bold’
and ‘ italic’  characteristics to the text and
EWE is no different; you can also change
the color, size and character (font). In
addition, EWE offers you the ability to
define your own text styles, in much the
same way as MS Word or Word Perfect
do.


Styles
Text styles can be used to save diffe-


rent paragraph settings. Styles can be defi-
ned and/or applied to the text using the
“ Paragraph”  toolbar or from the “ Format”
menu.


The easiest way to understand the ad-


4 .  M a in f unctions
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box arrow. The help file (indexEWE.aeh -
you may find it with the MSWindows Start
>Find feature) for example, contains many
different styles including List, Text and
Title. Clicking on any of these items, will
reformat the selected text or paragraph
using the selected style. Another way is to
type an existing style name in the Styles
combo and to press Enter.


If you want to change style settings
simply select a text block and apply modi-
fications; then click in the styles’  combo
and press Enter. A window will be di-
splayed asking if you wish to make chan-
ges to the style, select “ Modify style by
using selected text as example” . An alter-
native method is to use “ Format
>Styles...” , then select the style and apply
your changes.


apply bold to the text; then write a name
for the new style in the styles combo on the


toolbar and
press Enter. A
window will
appear asking
you to confirm
the new sty-
le’ s parame-
ters.


A not her
way to create
a new style is


by using “ Format >New style”  directly
from the menu: the window in Fig.30 is
displayed, allowing you to define all the
parameters for your new style.


To apply a style to a paragraph or a text
block, you must click on the Styles combo


Fig.30 – Here you
can define a new


Style or modify an
existing one; you
can even copy a


Style from another
hypertext using


"Import".


Before starting a new
project it is always a
good idea to spend a
few minutes to set up
the styles you will use.
This will save a lot of
time if you later need to
make modifications.


Fig.29 – The
“styles” toolbar:


you can select the
style to be applied


to the current
paragraph (or to the


highlighted
paragraphs). To


add new Styles use
the Format menu...
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windows-1251 for russian). You must do
this before the actual typing. The standard
charset is ISO 8859-1 (windows-1252).


Links
Let’s take a look now at some different


link types, in addition to the ones we’ve
seen in Chapter 1. As already stated, crea-
ting a link is as simple as selecting a text
block and clicking the chain tool-button,
but we can also choose “ Insert >Link”
from the menu. In the displayed window,
depending on the tab we select, the fol-
lowing links can be established:


− Link to other pages of the hypertext
(see Chapter 1);


− Link to other hypertexts: Fig.31
shows how we can select another hy-
pertext and the page we want to link
to. Select the destination page for the
link visually, as the program provides
us with a preview of the pages, and
enables us to surf through them;


− Link to an Internet address: EWE
keeps track of all URLs referred to in
the current hypertext. As shown in
Fig.32, we can choose the address to
link to from a list, or we can add a


If you simply apply a style to a para-
graph, pre-existing formatting is retained.
To clear all existing formatting, and keep
all paragraphs true to style, use “ Format
>Reformat” .


The “ style”  concept is a relatively re-
cent thing, originating from word proces-
sing and desktop publishing applications.
The majority of applications distinguish
between style and format:


− “ Style”  means all properties defined
in the Style applied to a paragraph.


− “ Format”  applies to the same attribu-
tes, but those applied locally with
toolbar buttons or with “ Format
>Font...”


You can have two paragraphs that ap-
pear identical on the screen, but are in fact
different. EasyWebEditor maintains this
distinction, as does MS Word and certain
other editors, because this is what users of
styles expect.


Charset
If needed, you can change the charset


for the site with “ Hypertext >Current Hy-
pertext properties”  (within the Charset box
enter the charset string, for example


Fig.31 - Here you
can define a link to


a page in another
hypertext. The


simplest ones are
when both


hypertexts are in
the same directory.







18


browse for a file in the file system
using the window displayed in Fig.33.
Clicking on the link will display the
file. If the selected file has an unk-


new one by clicking on the "+" key;
− Link to an embedded file: we can


include a text file or a ZIP file within
a hypertext (.AEH file). We can


Fig.32 – Here  you
can insert a link to


an Email, or
Internet address


(URL) ; this is
accessed using


"Insert >Link".


Fig.33 - This
window allows you
to include any file


within your
hypertext; access it


using "Insert
>Link".


Fig.34 - This
window allows you
to create a link to a
new page, created


by copying it from a
template.
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− Link to images: It is not only possible
to link to images, but also sections of
a picture using hot-spots; These
methods will be dealt with in later
chapters;


Expert users will be able to use additio-
nal special links (Chapter 8).


Images
It is possible to insert an image by


clicking the ‘ Insert Image’  tool-button, or
by selecting “ Insert >Image/Map”  from the
menu.


The window shown in Fig.35 displays,
allowing us to select the source of the
image to include. This can be from disk,
from an existing image in the internal al-
bum or from another hypertext.


To take an image from the internal
clipart collection, you must select “ From


nown extension, EWE will ask for
instructions.  If you have to deal with
a huge file, we would suggest that you
don’ t include it in the hypertext. It
would be better to transfer such a file
to the site using an FTP program and
then make a link to it (e.g. http://
yoursite.com/file.zip).


− Link to a page copied from a tem-
plate: You can link to a new page
copied on-the-fly from a template
(Fig.34);


− Link to a new page copied from an
existing one within the current hyper-
text;


− Link to a new page copied from an
existing one in another hypertext;


− Link to a new empty page: this is the
simplest link that you can add detail to
later;


Fig.35 - You can
insert an image


from the internal
album or from a


disk  using "Insert
>Image".


Fig.36 - Inserting a
clickable zone (hot-


spot) into an
image.







20


Fig.39 – the image
properties window:
alternative text for


the image and
much more. With


the Resample
button you can


actually resample
images (useful if
you changed the


image size )


Fig.40 - It is
possible to choose


an alternative
image to display
when the mouse
cursor is over it.


Fig.41 - This
window allows you


to replace every
occurrence of an


image used in the
whole hypertext in


one hit.


Fig.42 – Uing this
window, experts


can add HTML
code within the


<IMG> tag.
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You can also apply transparency to
your images, enlarge or reduce them, and
you can even include HTML code (see
Fig.40).


It is also possible to use images that
change when the mouse cursor passes over
them. This method uses two different ima-
ges that are shown depending on the cursor
position (see Fig.38). Of course, these ima-
ges can link to a new page.


Another useful feature allows you to
replace an image, either on a single page,
or using automatic substitution throughout
the entire hypertext (see Fig.39). In addi-
tion, using the “ Album”  window
(“ Hypertext >Images- files -link archive
and erase” ), you can globally interact with
all images included in the hypertext.


Tables
Tables are not merely a way to put


numbers and letters into columns. In


disk”  and then click on the “ Clipart”  button
(the icon with the mountain and the sun).


Once an image is inserted you can:
− Assign a link to the image: using the


right mouse button you can “ Define a
link”  the same way as for the text
links shown above. Details of special
links follows later.


− Define one or more clickable zones or
“ hot-spots” : using the right mouse
button you can select “ Add area / hot
spot” . Hot-spots can be moved and
resized; it‘ s possible to define a link
for each hot-spot using the right
mouse button, the “ image”  menu or
the toolbar. Use DEL to delete a hot
spot.


Several properties are available for
images; you can access the editing window
using the right mouse button or through the
“ Image >Properties”  menu item. Figs.37-
40 show the related windows with all con-
cerned tabs.


Fig.43 - This
window allows you
to define and insert


tables.


Fig.44 – Once a
new table is


Inserted, it can be
resized by dragging
the grey rectangles.
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Placing your cursor over a table cell
and using your right mouse button gives
yet another modification option. Choose
“ Properties”  and the window in Fig.43 will
be displayed, allowing you to define the
properties for your table, such as border’s
width or the background. From here you
can also assign a fixed size for your table
or a percentage relative to the main win-
dow.


Using the tab in Fig.44 you can act on a
cell’ s background, on a row or on a co-
lumn. It’ s interesting to note that each cell
can have a colored background, an image
or can be transparent.


What’s more, tables can be “ nested” ,
that means you can build a table inside a
cell of another table, and so on.


You can select a whole table using the
right mouse button and “ Select table” .


To copy a whole table, simply select it
and press CTRL+INS; then move to your
required destination and press
SHIFT+INS, it really is that easy.


WWW publishing, tables with transparent
borders are the best way to position objects
on the screen. The most recent Internet
browsers allow “ absolute”  positioning on
the screen, however, we discourage the use
of this feature for the following reasons:


− pages cannot be viewed with older
browsers, palmtops or with a tv-box;


− viewing pages becomes strongly de-
pendent on the user PC’s video reso-
lution; users viewing your site with a
lower screen resolution would not see
the site as you intended, and conse-
quently may give up and go el-
sewhere.


Using “ Insert >Table”  will display the
window shown in Fig.41, where you can
choose from several predefined table
layouts.


You can modify these tables if requi-
red, using the “ Tables”  menu or by using
the tool-buttons on the toolbar (e.g. you
can add or delete rows and columns,
change the background color of a cell,
etc…).


Fig.45 - TheTable
properties window.
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A  common method to make si-
tes more appealing and usable is to split the
screen into different sections, or frames.


EWE offers you many tools to simplify
the creation and modification of frames. It
also enables you to copy your frame
layouts to different pages.


Creating frames
Creating frames with EWE is really


very easy: all you need to do is to drag and
release one of the notched bars that are on
the screen sides.


As you will notice, in most of its win-
dows, EWE treats pages that contain fra-
mes as a single page. In particular, the
master page of the frame-set will always
be referred/displayed. The master page is
the page shown when the frames but-
ton is released.


You can use this button to switch
between “ Frames”  and “ No frames”  mode.
This button has no effect on the page’s


structure, it’ s just a display option for the
editor. In addition to showing the master
frame of a frame-set, this button is useful
to quickly test how your hypertext will be
visited with browsers that do not support
frames (such as palmtop, tv-box etc.).


Let’s make a simple example. Start by
creating a new hypertext with “ File >New
hypertext” , and split the page (#0) into two
sections by dragging the notched bar on the
left (see Fig.50). If you do not see the
notched bar on the left, click the ‘Show
frames’  button. You will notice that pres-
sing and releasing this button shows the
master page, the one on the right.


Now we want to build a structure where
“ page A”  and “ page B”  can be selected
from a list displayed in the left window e.g.
a simple menu. The selected page is di-
splayed in the right window, without the
left frame being affected or changed in any
way. To demonstrate this, we’ re going to
create a new page with “ File >Add new
page” , then drag out a frame using the bar,
as we did before (Fig.51). Now click in the
left frame, then using your right mouse


4 .  F ra m e s  a nd
f ra m e  s e ts
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for both “ Page A”  and “ Page B”  left
frame, for example 25%.


Links
All we have to do now is to insert links.


Selecting the text-block “ page A”  and
choosing “ Insert >Link”  will display a
window like the one in Fig.5 (Fig.55),
allowing us to select “ Page A”  (the host of
the frames “ Table of Contents”  and “ Page


button, click and select “ Choose page in
frame…”; the window in Fig.52 will open.
In the box “ Page in frame”  we will select
“ Choose existing one” : the window will
change as in Fig.53, allowing us to insert
the “ Index”  page into the frame. In this
way, the “ Index”  page will be shared by
the two frame set.


Please note that by changing the value
of the “ Size”  box, we can set the same size


Fig.50 - We’ve just
created two frames
by simply dragging
the left bar across


to the right, and are
currently entering


text in the right
frame.


Fig.51 - Recreating
the same frames


layout in a new
page of the
hypertext…


Fig.52 - Let’s fill the
left frame with the


same page as used
in the previous


frame-set…
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In fact, it would be possible to only
change the right frame, keeping the one on
the left unchanged. This requires us to use
special links, as described in Chapter 7.


Copying layout of existing
frames


Now we’ re going to see a simple way to
copy and edit frame layouts. The following
method is available using “ Format
>Advanced frameset manager” . This will
open the window in Fig.56 and is called
from Page B.


The page layout is shown on the right.
Clicking on a frame, the preview of the
page contained in the frame itself will be
displayed at the bottom of the dialog, hel-
ping us when choosing the page to display
in the frame. On the left side the program
shows all the parameters of the selected


A” ) as the destination for the link. While
doing this you may notice that the program
automatically assigns as “ page title”  what
you write on the beginning of the page -
you can change the page title with “ Format
>Page properties”  - the page title is used in
all the previews (such as Fig.55) and will
be shown on the browser’s title bar.


You can repeat the same kind of link for
“ Page B”  (do the same). When finished,
clicking on “ Page A”  or “ Page B”  in the
left frame will display the corresponding
page on the right (a double click when in
editor mode).


Several ways are given to build a set of
frames like the one just demonstrated. In
the example just created, the page changing
is achieved by replacing both frames; but
since the frame on the left is the same, only
the one on the right appears to change to
the user.


Fig.53 - It’s
possible to insert


any page of the
hypertext into the


frame…


Fig.54 - Let’s
complete the page
by writing "page B"
in the frame on the
right. Now we just
need to set up the


links.
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click on “ Copy also non master frames”  to
copy the full layout of page “ A”  (in this
case, the only non-master frame is the
“ Index”  one). Pressing “ OK”  will lead us
to Fig.60, where the right frame is the
master page of “ Page C” .


As you will notice, this is a very quick
and easy way to create side menus and,
also to reproduce frames.


It is possible to position the master
frame on the left or at the bottom, rather
than on the right, using the “ Advanced
frameset manager”  window.


You can save the current frame layout
as a template (button “ Save”  in Fig.56), or
alternatively, you can use a previously sa-


frame (name and properties).
The tab “ Copy from other page”  is


useful for replacing the current page layout
(we could have a frame-set or simply a
single page) with the layout of another
page of the hypertext.


As an example, let’ s try to create page
“ C” , identical to page “ A”  and “ B” . First
let’ s create a new empty page with “ File
>Add new page”  (or by using the shortcut
button on the lower toolbar). Then let’ s
choose “ Format >Advanced frames mana-
ger”  from within the new page; this will
open the window in Fig.57. Here we select
the tab “ Copy from other page”  and choose
“ Page A”  (Fig.58). At this point we need to


Fig.55 - We
highlighted “Page
A” in the table of


contents page,
then Insert >Link,


then we select
“page A” as


destination for the
link...


Page B is still
shown as Untitled


as you just created
it...


Fig.56 – A view
from the Advanced
frame management


window, showing
properties of the


current page: here
you can also


specify frame
borders, disable


scrolling, etc...
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Floating frames
You can insert a frame as shown in


Fig.62 using “ Insert >Floating frame” . A
dialog window will display as shown in
Fig.63 and you have the option to include
any hypertext page within the frame.


Please note that some browsers will not
display this kind of frame (old browsers,
some cell phones, set top boxes): for this


ved template as the current page, using the
“ Load from template”  tab (Fig.61). From
this tab simply choose the template you
want to use and click on “ Copy layout” . A
preview will be displayed, as shown in
Fig.56. All that’s needed now is to confirm
your choice with the “ OK”  button, to re-
turn to the editor and your copy.


Fig.57 - The
Advanced frame


management
window when


called from an
empty page.


Fig.58 – This
demonstrates the
"Copy from other


page" tab being
used within the


Frame-set
properties window,


to select an
existing page in the


hypertext


Fig.60 - We’ve
copied the same


layout of pages A
and B into an


empty page; now
we can write in the


page (the master
section on the


right)…
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Fig.61 - You can
save time by


copying layouts
from the


templates, or
save new


templates to
save time in the


future.


Fig.62 - A page
containing a


floating frame...


understanding and don’ t contain informa-
tion or links that are not available from
other pages.


reason, if you decide to use floating fra-
mes, we suggest you make sure that the
page content is not crucial to your readers


Fig.63 - The dialog
window for


independent
frames. You can


also call it by
clicking on a frame


with the right
mouse button, and


selecting
"Properties".
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F orms allow your Internet visitors
to send you data. The data is usually sent to
a program called a script, or CGI program,
that runs on the WWW-server computer.


Your host may include in your hosting
account a pre-installed set of these pro-
grams. There are many Web sites where
you can find programs such as these for
free, or for a nominal fee. You can also set
up the form so that the data is sent to an
e-mail address (this is the most common
way if you don’ t have direct access to the
server). Note that forms only work when
you publish your documents in HTML
(they don’ t work perfectly in the editor!).


A form typically consists in one or
more edit boxes and buttons. Each edit box
has its own identifier e.g. “ Name”  or
“ Address” . When you click the form but-
ton, the edit box identifiers and their con-
tents are passed to the CGI program or sent
to an e-mail address. The form start
marker’ s properties determine what hap-
pens when the form is submitted.


Inser ting forms
Using “ Insert >Form >Form element”


we can insert any kind of form element.
Firstly, you will be asked  for a “ form start
marker” . The form start marker is manda-
tory and specifies the action taken by the
browser when the user presses a form
“ Submit”  button. If you are unsure of
where to position the marker, simply press
OK. You have the option to change the
form start marker properties at any time,
using the right mouse button and
“ Properties” .


In the next dialog (Fig.72), you could
select the first tab for example, and insert
your email address if you decide to have
the input data sent by email.


Then with the next window (Fig.73),
you can insert edit boxes, memo, lists and
other elements useful when creating a
form. It is very important to assign a diffe-
rent identifier for each element, apart from
the “ radio buttons” . “ Radio-buttons”  are
used in groups offering your user a choice,
and only one item may be selected. The
identifier must be the same for all buttons


5 .  T h e  f orm s
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Fig.70 – An
example page


containing a simple
form


Fig.72 – A Form
start marker


contains
information such as


where to send the
form content, once
a submit button is


clicked


within a  group, while the “ button name”
(for HTML experts, that is in fact the “ on
value” ) identifies the actual button.


Fig.70 shows a simple form, with a text
cell and a button. To insert a button, use
“ Insert >Forms >Button” . There are two
kinds of button, submit and reset. The reset
button simply resets all form fields to their
original state. The submit button starts the
action specified in the form start marker.
The button can be a “ classic”  button or an


image. To use an image as a button, simply
click on “ select image”  (you can select any
image from the internal album).


You can insert more than one form
within the same page. No “ form end”
marker is required. If you include two
forms on the same page, the form start
marker of the second form will also act as
the “ form end”  marker for the first form.
Each “ Send”  button will be active only for
the form that contains it.


Fig.73 – This
window displays all


of the available
form elements
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Fig.74 - A slightly
more complex


form...


Fig.75 – An
alternative form


start marker
demonstrating how


page jumps are
used with forms...


Fig.76 - Here we
select a page to
show when the
user clicks the
submit button


Fig.74 shows an interesting example:
we define a form that will toggle a page
change (may not work with all browsers).
Firstly we must ensure that the form start
marker is defined as in Fig.75. Then, for


each included button, we have to define the
destination page, as in Fig.76, using the
“ Advanced”  tab of the button properties
window.


Experts can add HTML to any form







32


Fig.77 –
Demonstrating


Image buttons in
use.


element. This includes form start markers
(tag FORM), edit boxes, lists (INPUT,
SELECT; ...), buttons (tag INPUT). This
can be very useful when you want to insert
Javascript functions for example. Use the


right mouse button, “ Properties” , and
choose the “ HTML”  tab. For examples,
open indexEWE.aeh file in the editor.


Fig.78 – The form
submit buttons


dialog (Fig.76 is a
particular tab of


this dialog)
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T he following multimedia objects
are directly supported:


− pages with background music
− pages with buttons to start music
− pages with video


You can also insert objects that are not
directly supported. You will see them when
exporting to the Internet or within the
browser preview. For example:


− pages with Java Applet
− pages with object + embed (e.g. code


written to be compatible with any
browser)


− pages with Flash
To speed up the editing of pages with


non-standard objects, you can use object
prototype libraries (a type of macro). With
EasyWebEditor you can use these libra-
ries. With HyperPublish, www. hyper-
publish.com you can create them.


Sounds and video
Use “ Insert >Animation - sound”  to


insert an animation or a sound. Interesting


isn’ t it? You will see the dialog shown in
Fig.80. To choose the audio or video file,
click “ choose file” . Don’ t we make it easy
for you? The window shown in Fig.81 will
be displayed. For audio, you can use any
wav or mid file, together with any format
supported by your MSWindows install.
You should check that the format you use
is supported by all the common Internet
browsers (this is certainly true for .mid and
.wav). If you have already used an audio
file on another page of your hypertext, you
can easily select it using the second tab
(Fig.82).


For video files, the process is very simi-
lar. With “ action kind”  you can choose if
you want a loop action (e.g. background
sound, or repeated animation) or to show a
“ console” , a set of buttons that the user
will use to start the sound or video.


The “ loops”  box indicates how many
loops are allowed, if “ loop”  is selected as
the action. For example if you choose “ 1”
you can insert an action that will be execu-
ted when entering the page (this kind of
effect is used in the EWE demo, “ ? - Help
>Show demo” ).


6 .  M ul tim e dia  ob j e cts ,
a p p l e ts
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Fig.80 – Insert
animation and


sounds using this
window: you can
insert any format
supported by the


browser


Fig.81 - Here you
can insert a file


(sound or
animation) that


will be embedded
in the hypertext


Applet
Use “ Insert >Embed Java Active X”  to


insert an applet. The window in Fig.83 will
be shown. You should insert the proper
HTML code. The important thing to notice
is that when you refer to a file or an image
you shouldn’ t insert its actual file name,
but you should instead use the buttons on
the right. With these buttons you can vi-
sually select an image, a file, a site page:
EWE will insert a reference code (shown
as visual block; you can use the right
mouse button to change it) that will be
resolved to an actual file name on-the-fly,
when generating HTML. This system is
very useful as it allows you to change files
and images within the hypertext without


worrying about the actual code, and
without having to change it yourself.


You can also use the “ insert page or file
ref...”  button to insert a reference to an
internal page (Fig.86): in fact you won’ t
know the HTML file name of the page, as
it is generated on-the-fly.


Please note that you will only see the
Applet working when exporting in HTML
or publishing on a Web site (or with the
browser preview, “ Publish >Browser pre-
view”  - you see this menu only with
“ Hypertext >Read only”  disabled).


You can get a better understanding of
the mechanism by opening the file multi-
mediaEWE.aeh in edit mode (this is one of
the Help files, available in the es_aeh
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Fig.82 - The
program mantains
an internal album


with all sounds and
animations used in


the hypertext


directory). One of these examples is parti-
cularly interesting as it doesn’ t just use an
applet (messagera.class), but an applet
parameter is contained within a file
(untitled_messagera.vac). Using your ri-
ght mouse button on the applet gray block,
you will see how the code is written. The
two files above are embedded within the
AEH hypertext and are automatically ex-
tracted when you publish on the Internet or
ask for a preview.


To insert an ActiveX or Embedded
object is as simple as inserting an applet:
you write the code and when the time
comes to insert the object file name, you
use the “ Main object”  button which inserts
the dynamic reference to the actual file


(Fig.85) into your code.
Using the right button you can also


place a reference to the size of the applet /
embedded object / activeX. This option
will allow you to visually resize the gray
block that marks the object within a EWE
page. As stated previously, you will only
see the actual working object inside a cor-
rectly configured browser.


Flash
Use “ Insert >Flash”  to insert a Macro-


media Flash™ (or Swish) animation. You
will be asked for the .SWF file name, then
the Flash file will be inserted with a default
size of 50%. With the right mouse button


Fig.84 - You can
insert Applets,


ActiveX or Embed
objects with ease.
The program can
visually manage


their size (please
notice X and Y


markers)
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(Properties) you can edit the size and (if
needed) the HTML code related to the
Flash. You can use invisible tables to posi-
tion the Flash rectangle.


The program uses as template for the
Flash code the text file flash.txt.


Headers and footers
Each page can have a header and / or a


footer. There is no special edit area for
headers and footers, these are managed
separately. In short, you can use any page
as a header or a footer for any other page.
If you want a global header for the entire
site:


− Create a page and insert all the things
you want in your header (a logo, a
sentence, etc.).


− Select “ Hypertext >Current hypertext
properties” , click the second tab


(Fig.94), and the “ browse...”  button
near “ header” . In the window that
will be displayed, choose the page
that you have just created


With “ Format >Page properties”  you
can define a private header for any page
(Fig.95) or choose None. Footers are hand-
led in the same way.


Slides
Using “ Insert >Page functions >Slides”


you can instruct the program to replace the
current page with a different one, after N
seconds. The window shown is the one in
Fig.96. This is the function used in “ ? -
Help >Show presentation” .


You can also use “ Format >Page pro-
perties” .


Fig.85 - You can
insert into the code


a dynamic
reference to a file
(for example the


.class file for a
Java applet)


Fig.86 - You can
insert into the code


a dynamic visual
reference to a


page, a file, or also
to an image...







37


Fig.94 - Global
header and footer
for the hypertext /


site / catalog...


Fig.95 - Header
and footer for a


page (Page
properties dialog)


Fig.96 - The
simplest way to


switch a page to
another one


(shown) after N
seconds...
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T he simplest links available in
EasyWebEditor are the “ normal links” . As
seen in Chapter 1 you can insert them by
selecting a text block and using “ Insert
>Link” . If you need something more elabo-
rate and powerful, you have to use "Insert
>Special link". Note that special links
work only with the editor in read only
mode (“ Hypertext >Read only” ) or in the
browser.


We suggest that you don’ t attempt
using special links until you are familiar
with the normal ones.


There are many available options. Fir-
stly, you can link to another page:


− with a click, a window will show
− a new browser window will show
− the destination page replaces the cal-


ling frame
− the destination page will show in


another frame or window
− the destination page will show as a


popup window


− the destination page is opened at a
fixed row, marked by an anchor (see
below)


Additionally, you can set up the fol-
lowing behaviors:


− a click on the link will close a window
− link to a different position on  the


same page, using anchors
All these actions are “ visual” , i.e. you


do not have to do anything difficult or write
any code. Experts will enjoy the freedom to
add HTML code to any of these links,
simply choose the HTML tab within the
link insertion window.


We will also see how to open windows
automatically, as the user enters a page.


Anchors
The simplest of the special links are the


links to an “ Anchor”  within the same page.
Anchors act like a bookmark and allow
jumping to sections within a given page.
This kind of link is useful when you have a
very long page.


7 .  T h e  “ s p e cia l ”  l ink s
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To insert an anchor, move the cursor to
the link destination and use “ Insert
>Anchor”  from the main menu (or
SHIFT+F5). An anchor icon appears. Se-
lecting it with your right mouse button
allows you to edit its properties.


Now select the text block or the image
you want to link to your anchor, and use
“ Insert >Special link”  (on an image, use
your right mouse button and click “ Define
special link” ). Click on OK in the window
that will be displayed. You will then see a
dialog where you can select the destination
Anchor. Click on the anchor (a number is
assigned to each anchor and will be di-
splayed in the box at the bottom right), and
then click OK. You can test the result in
“ read only”  mode (Hypertext >Read only).


If you later need to modify the link
destination, place the cursor on the link,
use the right mouse button and select “ Link
properties” . In the dialog window di-
splayed, select “ Visual edit...”  (Fig. 103)
or “ Link target page...” .


You can also link to an anchor inserted
on another page. Select a text block, use
“ Insert >Special link”  and select the se-
cond tab (Fig.104). In the “ Target page
shows:”  area, choose “ in current window”
and click OK. You will then select both a
destination page and an anchor (see
Fig.105).


If you are using both frames and an-
chors in the Web, there can be a possible
malfunction if the link activates the
“ reframer”  script (this is a very useful
automatic feature - if the end user reaches
your website from a search engine and
enters a single frame of a framed page, this
scripts automatically redirects him to the
complete page, with all its frames). There
are two solutions for this problem: the first
one is to deactivate the reframer script
(“ Format >Page properties”  then uncheck
“ avoid single frame” ), the second one is to
change the link kind (toggle the option
“ Target window / frame show as”  between
“ single”  and “ frameset” ).


Showing windows
From the special link dialog, choosing


the third tab allows you to show the desti-
nation page within a separate window. You
must define a name for the new window
(see Fig.106), this name can be used later
to change the window content for example.


If two links use the same name for a
window (e.g. “ Goofy” ), and you click first
on the link #1, then on the link #2, you will
not show two different windows, so it is
imperative that each window has a unique
name. That is, unless you really want to
show the same window from two different
links.


Fig.100 – Showing
an anchor within a


page, these are not
visible out of edit


mode.
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Fig.101 - The
special link window


Fig.102 - Here you
can select the


destination anchor


Fig.103 - Properties
of the link just


inserted...


The separate window can be shown as
an ordinary window without toolbars. If
the destination page is a frame-set, you can
choose to show the whole frame-set or just
the “ master”  page (see Chapter 5 to learn
about the master page).


Choosing the second tab (see Fig.104)
and selecting “ opening a new browser win-


dow” , will show the destination page in
another instance of the browser (this is
different from a normal “ window” , as it
will include the navigation bar).


With the 5th tab you can close any
window, by name. Last but not least, the
6th tab is related to the shopping cart (see
the proper Chapter).
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If you are using frames and it seems
that a popup link is not working in the
Web, this means that you are not correctly
using the master frame (see the Chapter
about Frames, Chapter 5) or no popup links
are present on the master frame. If this
happens, the internal optimizer does re-
move the popup script from the master


frame (for size optimization, the product
tries to generate short and fast pages). This
is technically correct, but, unfortunately,
some browsers don’ t like it. The worka-
round is to place a fake link to a popup
(e.g. a white point linked to a dummy
popup) within the master frame, then just
republish.


Fig.104 - More link
types


Fig.105 - Let’s
choose a


destination page for
the link, and an


anchor. The link
dialog allows many
different link types.


Fig.106 - More
available link types


and properties...







42


Links inside/to frame sets
Now we will see some useful links that


work within frame-sets.
Suppose that we have the layout as


shown in Fig.107: We want a link from a
word or text block in the right window, that
replaces the content of the same window
while leaving the left window unchanged.
To obtain this, we simply choose “ in cur-
rent window, replaces caller page”  in the
tab shown in Fig.104: when we click OK,
the program asks for the destination page
which can, as usual, be chosen visually.


Another possible choice is more diffi-
cult to explain than to use: The tab shown
in Fig.108 which allows you to visually
choose the frame where the destination
page will be shown. Please note that you
can also manually insert the destination
frame name (frames can be named using


“ Format >Advanced frameset manage-
ment” ). This is useful for linking to
“ floating frames”  (see Chapter 5) or to link
to a separate window, or a frame within a
separate window. Any window with the
specified name will have its content repla-
ced by the destination page when the user
clicks this type of link. All these links work
with text blocks, single words, images and
hot spots (Fig.36).


Showing windows without a
click


Using “ Insert >Page functions >Open/
Close windows”  you can open or close a
window as soon as the user enters the
specified page. A “ functional block”  will
be inserted in the page, and will be activa-
ted when the page is shown.


Fig.107 -  A simple
frame set, used as


an example


Fig.108 - You can
visually select the


link destination
frame, and the


linked page
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Fig.109 - Show /
close windows


The “ functional block”  properties may
be modified using the right mouse button,
(see Fig.109). Here you can define the
window attributes, or supply the name of
the window to be closed.


In the online guide (“ ? -Help >Help” ),
file specialLinksEWE.aeh (you may find
this file with the MSWindows Start >Find
feature), you will find live examples that


can be opened in the editor. There are lots
of tricks to enable full use of these resour-
ces.


Trick: to show two windows with a
click, use Insert >Special link to place a
link to popup. Inside the popup, use “ Insert
>Page functions >Open/Close windows”  to
show the second window (use a different
name for the window!).
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Y ou can insert both HTML and
Javascript inside EasyWebEditor pages.
This subject is not for beginners, but for
additional information see also the online
guide (? >Help, Help).


There are two main options for inser-
ting HTML or JS. With the first one,
“ Insert >Script Java/Vb >At page start”
(Fig.120), you can insert code at page start.
This is useful for example for introducing
META tags (Keywords and descriptions).


With the second one, “ Insert >Script
Java/VB >Within text” , you can insert
code anywhere within the text. Useful for


inserting the code for counters or a guest-
book for example, (see the following page
www.visualvision.com/utils).


Using the second type, you will not see
the HTML code within the EasyWebEditor
pages, the place for code insertion is
marked with an icon. To see/modify the
HTML/Javascript, click on the icon using
the right mouse button, and select
“ Properties” .


The dialog window dedicated to code
insertion has some special functions. With
“ Load”  and “ Save”  you can use templates.
With the buttons bottom right, you can
insert visual references to all the objects
contained in the internal album managed


8 .  A dv a nce d f unctions


Fig. 120 -
Javascript inserted


inside the HTML
tag <HEAD>.


Use “Insert >Script
Java / VB > At


page start”...
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by EasyWebEditor. For example, if some
HTML code (say an Applet) needs to make
a reference to an internal image, there is no
need to input the image file name. You can
simply click the “ image”  button, choose
the image visually, and the program places
a marker that will dynamically resolve to
the image file name when the HTML code
is generated. This assures there will be no
broken links, even if you make changes to
the image.


HTML added to images,
forms, objects


You can’ t edit the EasyWebEditor
HTML code, but you can add HTML to
any object. Use the right mouse button on
the object, click on “ Properties” , and click
the “ HTML”  tab of the dialog shown.
Many examples are included in the online
help file (open indexEWE.aeh in the edi-


tor). Fig.122 shows the HTML added to a
text box, it is the example on page 298.


Keywords
The program permits you to create a list


of keywords for the whole site, and you can
assign some of these to each page.


The keyword list, and the keywords
related to each page, should be set up
manually. You can setup a global keyword
list with “ Hypertext >Keywords” . In the
window shown, select the “ Add global
key”  button (the yellow key with the green
+). Then use the left button to add a given
global key to the selected page. You can
add up to 20 keywords to each page. In the
HTML options you can tell the program to
include the page keywords inside the pro-
per META tag (see “ Options...”  button
inside the FTP window).


Fig. 122- HTML
added to a text
box (a part of a


form)
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select an image and use “ Image >Define
special link...”  (then last tab). Each link
contains the product price, currency, de-
scription and the product code.


The shopping cart properties window is
shown in Fig.201: you can define an email
address (the cart content will be sent to that
email) or the path of a CGI script, a fax
number, a remark for users, and you can
choose the colors for the shopping cart
rows.


For the Web, you can modify the shop-
ping cart script, if you are a Javascript
expert (if not, don't touch, the standard
setting will work properly). With XP /


E asyWebEditor includes a visual
shopping cart facility for your Web site. A
click on a text block or on a image can be
used to add a product in the shopping cart.
The shopping cart is shown in a popup
window: the window can be printed and
sent by fax or postal mail, or its content
can be sent to your email address.


To define the shopping cart properties
use “ Hypertext >Current hypertext proper-
ties” , then the “ Cart”  tab (Fig. 201). To
add a shopping cart link, select a text block
and use “ Insert >Link to shopping cart” , or


Fig.200 - Use
“Insert >Link to


shopping cart” to
allow the user to
add a product in


the shopping cart...


9 .  S h op p ing ca rt
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Vista and the IE browser you may need to
disable the “ protections”  for the preview.


The shopping cart requires the item
identifiers (“ Code” ) to be lowercase
(mandatory) and they must not contain spe-
cial chars (only abc123 is allowed, no
spaces). For item descriptions, spaces are
allowed but no special chars are allowed.


EasyWebEditor also supports an exter-
nal shopping cart plugin for accepting Pay-
Pal and Credit Cards, very handy, please


see www.easywebeditor.com/cart/.
You can also use any other shopping


cart service. You find a lot of shopping cart
/ ecommerce / credit card services on the
Internet. It is likely there are several carts
under your host's Control Panel, too. All
these services come with a manual and
some “ codes”  to be inserted. Just insert the
provided HTML code with “ Insert
>HTML >Within the text” .


Fig.201 - the
shopping cart


properties dialog...


Fig.202 - We
inserted two


products in the
cart... (to view the


cart, Insert >Link to
shopping cart, then
click on the link, or


double click if in
the editor)
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B esides the powerful features offe-
red by EWE to create “ well built”  pages,
we would like to provide some useful sug-
gestions about creating and paging Web
sites, although this is really not the aim of
this manual.


Creating a good Web site is not merely
dependent on the richness of graphics or
special effects, nor an on-paper paging
experience. Even if the usual communica-
tion and marketing rules are adopted, as for
commercial publications, the Web is a me-
dia apart from all traditional ones.


In this chapter we give some tips for
making an effective Web site, even without
super-graphics and expensive software


Displaying information on the
screen


Displaying information on the screen is
very different from presenting it on paper.
In traditional publishing, the page-maker
just needs to choose the page's size and can


then begin adding text and pictures.
Using the same methods for on-screen


paging may well result in ineffective di-
splays, since the dimensions are dependent
on the video resolution set by the user, not
by the author of the page. Typical screen
resolutions can vary between 640x480 and
1600x1280 pixels on different monitors,
going from 10 inch  to 21 inch screens. So,
how can we cater for everyone’s require-
ments?


There are different solutions. By consi-
dering the fact that a minimal resolution of
640x480 is available to everyone, we
could set such values as typical during the
design of pages. Actually, this is the choice
adopted for many professional works on
CD. Nevertheless, this solution may be
considered very limited by the user, who
would like to take advantage of a more
powerful video card, leaving our work ap-
pearing to be of a low quality.


Another simple solution may consist of
preparing the work as if it were a book or
paper magazine. For example, we can de-


1 0 .  G ra p h ics  a nd
p a ging p a ge s
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fine the A4 or US Letter format for all
pages, and then provide the user with a
reader that has zoom capabilities for use on
a small monitor. If we do this, pages will
have a fixed size and the content will be
the same for all video resolutions.


This is the method adopted for a lot of
works provided with Acrobat Reader. In
our personal opinion, this method is not
ideal for users who have small monitors or
with monitors working at a low video reso-
lution.


Everything's relative
EWE adopts a third method based on


automatic justification. Using this method
the displayed content has no absolute posi-
tion value, but is dependent on the width of
the current window. Firstly, text fits accor-
ding to the window’s width: this means that
if you narrow the window, the length of
each text line will change accordingly, as
shown in the example in Fig.134.


To be effective, when using this stra-
tegy, it is essential to position all objects on
the page using percentage or relative va-
lues, rather than absolute values. Looking
at Fig. 134 and Fig.135 we can make a
comparison using the two methods: unfor-
tunately, with absolute positioning, the
user’s screen must have the same video


Fig. 134 - A correct
page when shown in


different windows
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resolution and the same window size you
used, in order to get the correct display. To
quote a statistic, this scenario may apply
for only 10-15% of users; this suggests that
the highest percentage of users would see a
more or less, reasonably laid out page. All
things considered, it would be better to
accept the in-percentage tables philosophy,
since it is evident that it has a reason of
being.


Invisible tables
How can we insert in-percentage tables


making them fit for all resolutions? Well,
it’ s very easy indeed, since they are the
default used by EWE.


Let’s make an example now, by recrea-
ting what is shown in Fig.135, but this time
changing the absolute references which
make the page video resolution dependent.


Firstly, let’ s save the three images by
using your browser, Netscape or Internet
Explorer (the “ Golem”  writing, the number
and the split line). Then let’ s run EWE and
define the page’s background as white
using “ Format> Page properties” . If you
wish, you can also insert an image as the
background. Now we have to put the three
images saved previously (“ Insert >
Image” ) and an invisible table (“ Insert
>Table” ) with two columns to put text in.
We can define the percentage for the two
columns simply by right-clicking within
the two cells shown on screen (second tab,
as shown in Fig.44). The result should look
the example in Fig.139. At this point we
can insert the text, and the page should
then look like Fig.140: enlarging or nar-
rowing the window should not affect the
page quality.


Please notice that you can insert a table
within another table, so you can create


more sophisticated structures, if needed.
Again, we suggest you to try and try again,
as this is the best way to learn how to use
the advanced features offered by EWE.


Backgrounds
One of the greatest differences between


video and paper publications is the use of
backgrounds.


Printing backgrounds on a paper-made
publication is very expensive and someti-
mes may affect the readability and spoil the
overall appearance. This same treatment,
when applied to an Web site, may well
result in a visual enhancement.


In Fig. 141, 143 and 148, we can see
some examples that demonstrate the use of
backgrounds.


We can assign a background to a ta-
ble’s cell through the usual window shown
in Fig.44. It is however important not to
over use this feature. In general, we di-
scourage the use of backgrounds that have
too much contrast, saturated colors or too
much detail, because these can affect text
readability and take focus away from the
subject matter. If you really wish to use
them, we suggest that you put a colored
table where you want to insert a text block
(see Fig. 143, where we have used nested
tables)


Clickable maps, hot spots and
browsing bars


An interesting way to link different pa-
ges is to create special images that contain
some intelligent areas, which, when
clicked, will generate the loading of the
linked page. In Fig.154 we show a sophi-
sticated example, but we could simplify
this by making a bare horizontal bar.
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We can insert a clickable zone (hot
spot) by positioning the cursor over the
chosen area and right-clicking with the
mouse (“ Add new spot” ). A small rectan-
gle appears with four white corners. We
can then move the rectangle and resize it
by dragging the white corners in order to
define the intelligent (clickable) zone. By
right-clicking on the newly created hot
spot, we could go on to define a link.


It is important to take into consideration
that some users may not be able to take
advantage of the graphic links. To provide
them with the opportunity of browsing our
pages, it would be advisable to replicate


the links elsewhere on the page in a simple
text format, even if only in small sized
characters at the foot of the page.


Accompanying the program, you are
provided with many different examples of
button-bars and clickable maps. Using the
same bars throughout the same site will
improve uniformity and will contribute to
the overall style of your work.


Taking all of these points into conside-
ration, we should say that designing button
bars or maps is not as easy as it could at
first seem. If you are not experienced with
graphics software, it may take some time
before you obtain a satisfying result. Ne-


Fig. 135 - A page
with fixed tabes seen


at different screen
resolutions
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Fig. 139 - Let’s insert
the images and let’s


create a table with
two coloumns,


without borders...


Fig. 140 - ...then let’s
write (you will see the


dotted lines just in
the editor; they aren’t


shown in the
published ebook).


Fig. 141 - Page with
a repeated square


background


vertheless don’ t give up, but try to get
some help from an experienced friend or
from a specialized graphics publication


Frames
Frames are a very useful feature, espe-


cially while designing complex sites. Fra-
mes allow us to split pages into more
sections. A very common implementation
consists of using an index or box contai-
ning a selection-list on the left side of each
page. Using frames so that we don’ t have
to physically repeat the same menu for
every page; and at the same time, make


browsing much easier.
Some authors discourage the use of


frames, often in relation to search-engine
functionality. Actually, the practice of di-
scouragement should not be applied to the
correct use of frames, but rather for those
making bad use of them.


EWE automatically generates pages
that are compatible with non-frame-
capable browsers and with Internet search-
engines. Furthermore, EWE helps us with
link management, avoiding the risks of
possible problem areas. Taking all of these
points into consideration, and with a little
common sense, we can quietly make use of
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Fig. 143 - If you
apply a coloured


background to the
table the text is more


readable


Fig. 148 - Lens
effect. You can do


this with two different
backgrounds, similar


but with different
color tone.


frames and benefit from them.
It is interesting to note that by choosing


‘0’  as the value for the borders of a frame,
the borders will be invisible to your rea-
ders, and you can also hide any scroll-bars.
Using these features, you can easily create
some interesting effects for your EWE
works.


Please refer to chapters 5 and 6 for
more details concerning the use of frames
and related special links.


Don't exaggerate!
With a little practice and your powers


of observation, you will soon get excellent
results with the several opportunities offe-
red by invisible tables, frames, back-
grounds and clickable maps.


To further enhance your work, some
graphics software is almost a necessity.
Use it to develop effects such as texture,


lens, aliasing and fading and also to create
your own buttons, image maps, split-line
and backgrounds.


Having said all that, only one more rule
requires attention. In order to create really
efficient and optimized pages: "don't exag-
gerate!". With so much power in your
hands it's very difficult to set a limit, but to
keep your readers interest, it’ s necessary to
create light, quick and efficient pages, so
don’ t overdo the effects.


With this same aim in mind, we suggest
that you use the same background for all
pages, that you don't use more than two
different fonts (one for the text blocks and
one for titles) and no more than 3 font
sizes. Following these recommendations,
we are sure you will cope with creating
attractive and well-made pages. Nothing
else is needed.


Have fun with EWE!
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Fig. 154 - A nice
map (www.


fantascienza.
com).
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F or any question, email the support
staff or take a look at the user’s forum:
www.easywebeditor.com/forum/ (there is
a very powerful search feature).


For Immediate response to frequent
questions, read below!


− tutorials, basic questions
− link and pages, hypertext functions
− tables
− images, hot spots, areas, back-


grounds, icons, thumbnails
− styles, fonts, charset, CSS
− frames
− templates
− Internet Publishing - FTP
− HTML - Applets - AEH - ASP
− download / .DOC / .ZIP / .PDF /


Flash / Internet services / Counters /
Forum / Import files


− shopping carts, e-commerce
− generic questions
− purchase


TUTORIALS, BASIC
Are there any tutorials for main features?
Yes, hit F1 (or ?-Guide >Help), then  click on
“Tutorials” .


Can EasyWebEditor manage frames? And
what about the mouseover? The forms? Can it
publish directly to the Internet? Does it make
the coffee...?
The answer is always yes (well... not for the
coffee, but we’re working on it...!). To learn
more, scroll below, see the fast tour or take a
deeper look at the online manual.


I have previously used another editor and I
can’ t understand how to manage HTML files
with EasyWebEditor...
With EasyWebEditor you edit a whole Web
site, not codes and files. It manages all things
automatically and even publishes your work
using an internal FTP client, creating HTML
files on-the-fly. You can add code but you
can’ t modify the HTML directly. If required,
you can import old HTML pages using "File
>Import", the code is automatically optimized.
If you need to touch the HTML code, use Insert
>HTML.


1 1 .  F re q ue nt q ue s tions
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Can I import my old site created on geoci-
ties.com?
Use "File >Import >HTML". You might have
to reformat some text and tables. This is be-
cause EWE amends pages so they may be
viewed by any browser. You may have to do a
little reformatting, but this way your pages will
be viewed as you intended, on all browsers and
all PCs! You may need to use CTRL+
& CTRL- to move between pages.
You may also copy and paste from the brow-
ser.


LINK AND PAGES, HYPERTEXT
FUNCTIONS
I don’ t understand the way EasyWebEditor
saves pages.
All hypertext pages are saved in a whole
“AEH”  file. With “File >Save all”  or with the
toolbar button, you save all hypertext pages
with a single click.


...in the tutorial it says:...then, let’s press the
link button in the toolbar (sheet and chain, or
> "Insert >Link" from the main menu)... but
there is no button labeled "link" in the tool-
bar...and which toolbar?
Highlight a text block, then choose from the
main menu “ Insert”  then “Link”  if you aren't
able to find the button with the image of the
sheet and the chain. If you are on an image, use
the right mouse button, and choose “Define
link” .


How can I set the size of a page?
You can’ t set the size of the page, as you can’ t
know what monitor and what window will be
used by the people that will see your site. The
safe way is to always use % tables (it is the
default in EWE) and to not assume that the
pages have a fixed size. See also Chapter 10.


The text automatically resize and flows but I
don’ t want this.
So insert the text within a fixed width table
(“Table, Properties” ). However we would ad-


vise to read Chapter 10.


I want to change the page numbering as I
want to insert a page between page 1 and 2,
but I can’ t.
Yes, you can’ t. If you really need to do that,
you can insert say a page #3, copy the #2 to #3
with “Edit >Paste page from...” , then delete all
the text within page #2. Agreed this is not
quite what you are looking for, but the automa-
tic numbering is very useful to optimize the
publishing speed. Please remember that the
end user will not see the EasyWebEditor page
numbers, only the page titles, so it really
makes no difference. If you were to label page
24 as "Page 1" and page 45 as "Page 2" this
would have no effect on your readers, as the
EWE page number is just a facility to allow
you to switch pages without having to remem-
ber the proper page names.


Can I change the number of page #0?
This is not possible. If you want to set another
page as home page, simply choose “Hypertext
>Current hypertext properties” , and click on
the left, on “cover” . Any page can be used as
cover, not just the #0. The #0 is just the default.


How can I fix a page width to 535 pixels, in
order to obtain the ideal setting when printed
to paper?
Why 535? Anyway, you can fix this width for
a table. Use the right mouse button on a table
cell, and click “Properties” . However, it is
better to use % tables, so your work will di-
splay well on all monitors, from 6”  to 48” .


How can I place a link inside the same page?
The links within the same page are called
“Anchors”  (Chapter 7, Special links). You
need first to place the “Anchors” . In order to do
this, move the cursor to the link destination
and use “ Insert >Anchor”  from the main menu
(or SHIFT+F5). You will see an anchor icon. If
you select it with the right mouse button you
can edit its properties. A number is assigned to
each anchor.
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Now select the text block or the image you
want to link, and use “ Insert >Special link”  (on
an image, right mouse button, “Define special
link” ). Click on OK in the window that will be
shown. Then you will see a dialog where you
can select the destination Anchor. Click on the
anchor, then click OK. You can test the result
in “ read only”  mode (Hypertext >Read only).


How can I link to an anchor placed in a
different page?
Select the text block you want to link, then
“ Insert >Special link” . In the dialog that will
be shown, do not choose the first tab but one of
the others (e.g. second tab “Normal” ), then
OK, and select the destination page. Within
the preview of that page you can click on the
destination Anchor (the number will be copied
in the box that’s on the right at the bottom of
the window).


Can I insert an alternate text on a link, like I
can do for images?
Select the text and apply the link with "Insert
>Special link" (or F5). Then click on the
"HTML" tab. In the box insert the following
tag: TITLE="insert here the tooltip text". Then
click on the first tab and choose any of the link
types (for example the second sub-tab,
"Normal", then OK).


What should I do to save a single page?
Normally you don’ t need this. When you save
your work, all pages are saved.
To save a single page you can use "File >Save
as...", or "File >Export pages". In this way you
can obtain single Rtf or Html pages.


I've not been able to find out if I can have
different colors for links in the same frame...
You should define different text styles. Each
text style can have its own color/style for the
links. Use "Format >Styles", then the last tab
("link"). You can also set up the style of the
link (underlined, bold, or so).


Where can I find information about pages


contained in an hypertext / site? How can I
manage pages?
Creation: "Insert >New page", "Insert >Link",
"Insert >Special link".
Deletions, management: "Hypertext >Images
/files /link archive and erase".
Access: "Hypertext >Go to page", the bottom
center page number box, right mouse button on
this box.


When I'm editing a * .aeh file, how can I delete
a page (in my case page 0 as it is empty)?
Page 0 can't be deleted. For other pages, use
"Hypertext >Images /files /link archive and
erase". You can also cut & paste another page
to fill the page 0.


I don't understand how to insert a link.
Please read the Chapter 1.


How can I link an external Html page, for
example an Html page that already exists on
my Web site?
Select a block, chain button, choose the 3rd tab
(Internet), click the “Add+”  button and write
in the left box the address (e.g. "http://my-
site.com/ mypage.htm"), then press "OK".


How can I manage the pages different from
the main one? Just with links?
In the bottom center there is a box with the
current page number. Click on it with the right
mouse button, you will have a list of the most
recent visited pages. You can also use
“Hypertext >Images - files - link archive and
erase” , “Hypertext >Go to page...” , “File >All
pages...” .


How can I copy a page within another in same
hypertext (with Html I can do it with "save
as", then "open". Is there another way in
EasyWebEditor)?
"Insert >New page", then "New page by
copying existing one"; or "New page by
copying from another hypertext", ...
You can also use "Edit >Paste page from...".
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How can I manage headers and footers?
If you use "? >Help" and search for the
keyword "header" or "footer" (Search
>Keyword search) you'll get the answer.
In short, you can use any page as header or
footer for any other page, i.e. if you want a
global header for the whole site:
- create a page and insert within it all things
you want in your header (a logo, a sentence,
etc.).
- choose "Hypertext >Current hypertext proper-
ties", second tab, and press the "browse..."
button near “header” . In the window that will
be shown, choose the page you just created.
With “Format >Current page properties”  you
can define a private header (or no header) for
any page.


Do you have some step by step guidelines on
how to create, open, and close popup win-
dows?
To open a popup, select a text block, "insert
>special link", 3rd tab (independent window or
popup). To close a popup, in the page where
the popup should be closed, use "insert >page
functions >open/close windows", then specify
the name of the popup. The popup is closed on
entering the page. You can open the .aeh files
used as examples (speciallinks.aeh).


I can only get to non-linked pages when I am
in the "edit/preview" mode, by using the page
scroller (the box at the bottom of the screen,
with the page number) or CTRL+-.  Is this
normal?  Will normal keyboard/mouse paging
work when this Web-Page is "published"?
No, you have to place links. The other ways to
manage pages are only active in the editor (this
simplifies the creation / management of pages).


Is there a limit to the length of the URL you
can insert with "Insert >Link", 3rd tab?
Yes, there is an internal limit. You can insert
longer links very simply, with the Long link
plugin (www.visualvision.com/plugin). Or by
using HTML blocks ("Insert >HTML >Within
the page"). Insert two HTML blocks, the first


before the text/image to be linked: <a
href="http://thelongurlhere.com/">, the second
at the end: </a>


What is the maximum number of pages I can
use? Is there a maximum size?
Each EasyWebEditor AEH file can contain at
least 200 pages and 200 images. You can use
an unlimited number of AEH files. There is no
maximum overall size.


The program says "Please delete objects with
Hypertext >Images - files and deletion, or buy
HyperPublish". Is this normal?
Yes, EasyWebEditor stores each image in an
internal album, so even if an image is deleted
from the page, it is still kept in the album,
which has limited available storage.
You can rectify this using any of the following
methods:
- delete unused images using "Hypertext
>Images - files and deletion" (select an unused
image and press the DEL key)
- divide the work into two or three AEH files,
(you can link these AEH files, see below)
- upgrade to HyperPublish at a discounted price
(HyperPublish album has no limits).


Will your program allow me to create an index
at the top of a page, create a paragraph or
graphics several lines down the page, use the
indexed item as a heading for the paragraph
or graphics and link to it, also add a 'return to
top of page' at the end of each paragraph?
You can insert any kind of links but you have to
insert links manually.
You can use "anchors" for links within the
page. The program can create an automatic
linked index with "Insert >Index". To repeat a
block on the top of a page, use the Header
function (Format menu).


TABLES
Does percent % size mean the table will auto-
matically be sized to the content?
It means the table will fit the screen pixel width,
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using a %. When you insert a new table, the
software use 100% as the default. Unless you
have a particular requirement, do not change
this setting. It will fit automatically any brow-
ser window. Read Chapter 10 for more info.


I inserted an image in a table. Why does it
appear in all cells?
Perhaps you inserted the image as the table
“background” . If you want to insert an image as
a single “cell”  background, use the right mouse
button on the cell, “Properties” , second tab,
then click the Sun and Cactus icon.


When I have to write words in 3 columns do I
have to insert a table or can I just use the
space bar?
It is better to use a table. Never use the space
bar as, if you view the page from another PC,
the size of the space might be different and you
will lose the alignment.


How can I create a table with more than a
column within a row?
You can insert a new table with any rows or
columns within a cell of another table.


How can I delete a table?
There are many ways. For example put the
cursor on a cell, press the right mouse button,
then choose "Select table", then press DEL.


How can I copy a table?
Select the table as above, then press
CTRL+INS. Move the cursor to the destination,
then press SHIFT+INS.


I'm having a problem formatting text in a
table. The table text automatically formats it-
self to Times New Roman (my default font is
Arial) and I also can't select the entire table,
column or row to apply the required format-
ting.
The table default style is "[no style in tab]".
Simply change that style with "Format
>Styles".


How do I lock the position of text within a
table, so that it does not reposition when the
browser window is resized?  I know in many
instances locking the text position is not desi-
rable, because the size of monitor used to
view the site will vary. Despite that, I have
certain text that I do not want to reflow,
regardless of what the visitor does with his
browser window.
Simply fix the width of the table column con-
taining the text. Use the right mouse button,
properties, second tab, then choose "fixed" for
the table cell width.


I get inconsistent results when fixing table /
cell widths. Sometimes, when I fix a table cell
containing an image, I can lock the image in
place, but sometimes not.
You can fix both column and table widths,
using the right mouse button when placed over
the column. You can fix each column if you
want to, you have to do this separately for each
column. Usually the best way is to fix all
columns except one. Use the unfixed one for
text that you want to flow. Please note that
some browsers don't actually respect the fixed
column size you have selected (this is strange
but derives from historical HTML behaviour),
but you can force them to respect your sizing
by placing a little and large transparent image
at the top of the column, and fixing the column
width to a small percentage, such as 5%..


IMAGES, AREAS, HOT SPOTS,
THUMBNAILS, BACKGROUNDS,
ICONS
Animated GIFs don't play in the editor!
Move to preview mode (Hypertext >Read
only); they are “ frozen”  in edit mode.


How can I move images and position them
somewhere in the page? I can’ t position an
image as I would like.
The “ fixed”  position for an image is good
when you create a text that will be printed on
paper, but has no sense for a site, where the
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reader can see your work inside an unknown
width window. Your user might use a 600 pixel
or a 1200 pixel width window, and you don’ t
know that. The best thing to do then is to create
a work that will be seen well on any PC, in
other words a work that all readers will like. To
do this, simply use “ invisible”  tables (i.e. tables
without any border) to position images on the
page.


If I want to add a caption near to an image is it
better to use tables or frames?
Better to use a table.


How can I delete an image inside a table?
Select the image and press DEL two times. If
the image is a background, choose “Table
>Properties” . To delete the table, right mouse
button, “select table” , DEL.


Can I write some text over an image, similar to
using layers in a graphics program?
No, you should use PaintShop PRO or a similar
graphics program to achieve this.


Is there a fast way to change the image back-
ground for all pages of a site?
There are two ways. If the background is alre-
ady an image, use “Hypertext >Images - files -
link archive and erase” , select the image, then
press “Replace...” . Otherwise there is a button
in the bottom right of the second tab of
“Hypertext >Current hypertext properties”  dia-
log.


How can I place text beside an image?
Create a simple table with one row and two
columns. Inside the first column, insert the
image. Inside the second one, insert the text.


I am having trouble inserting an image with
transparent background. Sometimes it works
and sometimes not.
It should work for the large majority of GIF
images. However, not all images are suitable to
be automatically converted using the included
transparent-color processor, so you may have to


proceed manually with paint programs such as
Paint Shop PRO or Corel Photo Paint.


Is it possible to add more than one clickable
area (hot spot) on an image?
If you don't test the areas in "read only" mode,
they will work perfectly. You can insert up to
30 areas per image. If you need more, you can
split the image in different sections with a
paint program.


I see the "paste from clipboard" can perform
the automatic conversion of a WMF to a GIF /
JPG format with a lower byte size. As I alre-
ady inserted WMF images, can I convert them
to GIF in some way or must I reinsert them?
Unfortunately, you must reinsert.


I can't insert animated GIFs with "Insert
>Animation"!
Please use "Insert >Image".


Where can I find the included clip art?
In the “ Insert >Images”  dialog, “From disk” ;
click on the icon with the mountain and the
sun.


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


How can I insert pictures that will be enlarged
in a separate window when you click on them?
Should I use the click area / hot spots? What
can I do with a click area?
A click area is useful when you want to assign
different destination links to different sections
of a single image. For example let’s say you
have a picture of yourself. You can assign an
area to the eyes, an area to the mouth, and so
on. A click on the eyes may display a page
where you talk about your wonderful blue eyes
and so on... :o)
If you want to create a gallery with some
thumbnails linked to larger images in a sepa-
rate window, you don’ t need to use hot spots.
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Simply create a page containing a series of
small images, then insert a new page for each
enlargement and assign links to each small
image (right mouse button, “Define special
links” ). Inside the “special link”  dialog you can
specify to use a popup to display the destination
link (the page containing the larger image), and
you can specify a name for the popup.
We have also 1site (that’s like EasyWebEditor,
with more features) that includes an automatic
photo-gallery feature.


Is there a way to place icons of thumbnails on
my page, then click to view a larger image?
Yes, just insert a little image (you can do it with
a paint program) then insert a link (right mouse
button, "Define link") to a page that contains
the larger image. If you use "Define special
link" you can also show the larger image in a
popup.


How can I set a background image or a back-
ground color for a page?
“Format >Page properties” , then click the icon
with the cactus and the sun.
You can also insert tables using an image as the
background (click on a table or on a table cell
with the right mouse button, then properties).


I designed a navigation bar in Paint Shop
PRO, how do I insert that into page and add
links to each button?
Insert >Image then add hot spots (clickable
areas) with the right mouse button, then define
links with right mouse button.


I have an image and some text on one page. I
want the text to line up on the right of the
image, and I suppose using a frame will do it,
but I can't get my image into a frame.
Better to use a simple table, rather than a frame.
Just use "Insert >Table" then use a table with 2
columns, 1 row (if you want to create frames,
simply drag the top or left border of the edit
window).


I imported a picture into my document. Is there


any way to add a border or is that something
only available in the full version?
You can do this with a paint/graphic program.
The normal HTML border facilities are too
limited so they are not included at all.


Is there any way to assign an image as a
border for a page? I have an image that is
about 1 inch wide and I want it wrapped
around the page. Can this be done?
You can create a table with 3 rows x 3 co-
lumns, and use the image as background of the
8 externals cells (right mouse button from
within the cell, then select "Properties"). If you
edit the Style of the paragraph that contains the
table ("Format >Styles"), you can eliminate the
upper and external borders that this solution
often leaves.


STYLES, FONTS, CHARSET
If I change the font height, sometimes this is
lost when I write additional text. Why?
Do not move the cursor after changing the font
size. You may press Return after you change
the number.


Can I save a style?
Yes. Simply write its name in the styles cell,
then press ENTER, and the settings of the
current paragraph will be saved as style. You
can also import styles from another hypertext.
For creating new styles you can also choose
“Format >Styles” . See also the manual for
more info!


How can I recall a style I saved?
Simply click on the styles cell and select the
required style!


How can I change the style of the links within
a table?
Like any style, i.e. by using "Format >Styles".
The default style for tables is [no style in table]


I have created a Web site and used some of
the fonts installed on my computer for the
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page. The problem I have is when other people
install and view it, the fonts are not the same
as the ones I used to create the ebook. Should
I use just fonts that are universal on all compu-
ters?
Yes, Times New Roman, Arial and Courier
New. If the user has MSWindows + Office
usually also Verdana and some others. It is not
possible to distribute fonts due to copyrights. If
you want to use a fancy font for titles, you may
use transparent images - we have a free
"plugin" that permits you to do this automati-
cally (you select a text, you click a button, the
text is instantly transformed into an image by
using the current font). The image will be iden-
tical for all the end users. Please see
www.visualvision.com/plugin/ "text to image"
plugin.


Can I change the charset such as for Russian?
Within Hypertext >Current Hypertext proper-
ties you can change the charset of the site (say
for example windows-1251 for russian).
Do this before the actual typing.


FRAMES
How can I delete some frames I inserted?
You should delete them frame by frame. To
delete a frame you should move its border to the
top or to the left (depending of the kind of the
frame). It may be faster to choose “Format
>Advanced frameset manager” , to load a sim-
plest frame set from a template, then press OK.


How can I remove the frames border?
Choose "Format >Page properties >Frame pro-
perties" (or use the right mouse button). In the
dialog, uncheck the box “show rectangle bor-
der”  and write 0 inside the “border between
frames" box.


I am working with frames and I noticed that
the frames will not allow me to align text/
images to the top right-hand corner. It looks
like the frames have a top margin of about .5".
Can I get rid of this?


Yes, Hypertext >Current hypertext properties,
second tab, then set the “Margin”  parameter to
0. Or you may also define a style where the top
margin of the style is something with a nega-
tive number (-0.01 should be sufficient) and
apply that style to the first paragraph, then you
may insert a table within that paragraph and
experiment within it.


I want to add a page with frames. I want to use
as an existing page as a frame.
Create a new frame set. Within a frame, use
the right-click mouse menu to select which
page will fit the frame. You can also use
"Format >Advanced frame set management".
See the Chapter about frames.


I have a page with too many frames. I went to
"hypertext", then "images - files - hyperlink
archives and erase" and tried to delete the
pages with the frames. When I go back to the
page, the frames are still there. What am I
doing wrong?
You probably deleted another page. When
working in the page with the frames, press the
"no frame" button at the bottom of the page.
That switches the view to "no frame" mode,
(note: it doesn't actually delete the frames, it is
just a display option). This way you will see
which is the master page for the frame set.
Delete it and the frame set will be deleted.
Another way to delete a frameset is to replace
it with another, (Format >Advanced frame set
manager).


I've tried to create frames, but why does the
page reappear on the previous page or the
following one when you copy and paste the
page on the split page with frames?
Please read the complete manual. Each new
frame is in fact a new page, so if you create a
frame-set in page 0, containing 3 frames, if you
go to page 1 you will find the 1st frame created
in page 0, if you go to page 2, the 2nd and so
on. This allows you to use the same frame (e.g.
a menu) in different frame-sets without having
to copy it. To select the page that fits a frame,
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just use the right mouse button within a frame,
then select  "Choose page in frame".


TEMPLATES
The templates seem to be in Italian! Where
could I get English ones?
The templates are not in Italian. It is a dummy
latin-like language that has no meaning. The
text is there purely to fit the page for demonstra-
tion purposes. You can replace it with anything
you like.


INTERNET PUBLISHING - FTP -
UPLOAD
How can I buy a Web space / hosting?
Please see  www.visionhost.info


I found difficulties while completing the fields
needed to publish my Web site.
To publish on the Web you first need to buy a
Web space or find a free one. You will then be
given the parameters you have to insert. See the
tutorial in "?-Help", then "Help", then
"Tutorial", then "Internet FTP publishing tuto-
rial".
If you need some basic info about the publi-
shing of a Web site, see
www.visualvision.com/howtocreateawebsite


How can I just send completed pages to my
Web site?
EWE automatically detects which pages have
been modified since the last time you edited the
file, then marks them with a check mark. If you
don’ t want to publish a particular page, simply
uncheck it.


My ISP has no idea what the FTP server
parameters are...nor does my host...so I don’ t
know how to publish...also it says the www.
parameter is not mandatory...so then where do
you send the finished pages???
Your ISP or host MUST know your FTP server,
user name and password. If he doesn't, please
change your provider. It is like using an electri-


cian that doesn't know what a lamp is :-). You
can tell your host to download the free trial so
they can see where to insert their parameters
and help you. If you have no luck with that
method, drop us an email and we will help
you. Please see the FTP publishing tutorial
first! Every FTP server has a server name: it is
quite obvious you should insert that name in
the field named "server FTP". Every server
requires a user identifier/ username, it is ob-
vious you should insert that in the field named
"user identifier". Every server requires a pas-
sword. Only these 3 parameters are mandatory.
Your providers server may require you to enter
an additional directory such /www or perhaps
/public_html to enter the area that will provide
your web presence: EWE gives you the oppor-
tunity to enter that directory path, so that when
you connect, you automatically enter that direc-
tory. Thismay be inserted in the field named
"Initial remote directory", but this is not man-
datory. If not required you can leave this field
as it is.


I can’ t publish with the AOL mem-
bers.aol.com
The AOL FTP is special, sometimes you can’ t
use the EWE internal FTP with free AOL
accounts. If you want to try, get a paid account
or try another provider such as
www.visionhost.info


I’m getting errors when I try to publish!
Error #500: the FTP server name you used is
wrong or the program can’ t connect to the
server due to a network overload; note that you
should omit the prefix ftp://; other problems
might be caused by Antivirus, Firewalls, Fi-
rewall programs;
Error #530: the username and/or the password
is wrong (or the server inadvertitly reset them);
Error #503, #403, Access Denied or the publi-
shing phase seems OK but the site is not
updated: it is likely the “ Initial remote direc-
tory”  parameter is wrong - it should be set to
the web folder (i.e. /www or /public_html or
/htdocs or something else, please ask to your
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host).
If you are a registered user and you are unable
to publish, send us your parameters and we will
attempt to connect for you. This should help to
track down your problem. Please note that some
“ free”  servers (geocities, freeservers) have disa-
bled the FTP access, and you’ ll receive error
#530. More, see:
www.easywebeditor.com/ftp/


You say you have an FTP "engine" inclu-
ded......what is an engine in this case? I have
an FTP client and a server service that I
already use...but they don’ t know what you
mean by "internal ftp engine".
There is an internal FTP function, i.e. the FTP
resides within the program. You can publish on
the Internet using "Publish >Internet -FTP
>Publish on the Internet". Other programs re-
quire an external FTP program to put the pages
on your site. Our program includes the publi-
shing function (the publishing engine) inter-
nally. To configure the FTP publisher, please
see the tutorial.


I can see my site with Explorer but not with
Netscape. Why?
This can happen if in the "Hypertext > Current
hypertext properties" dialog, under "Export pre-
fix" you use a name that includes spaces or
special chars. Spaces must be avoided if you
don’ t want problems on certain browsers and
operating systems.


If I choose "automatically select modified
items" when publishing, the program doesn't
seem to select them...
This setup only works with subsequent connec-
tions, it will work the next time you choose
"Publish >FTP". If the list on the right is alre-
ady filled, you should press the reload button –
the circular one - to force the program to select
just the modified pages.


After putting a form on my Web page, I tested
it using the browser. After the ‘Submit’  button
was hit, a pop-up box appeared saying: 'This


form is submitted using e-mail. Submitting
this form will reveal your e-mail address...'
etc. What can I do to remove this message?
Usually, when I fill a form in on the Internet, I
never see this message.
To remove this message you need to use a
"formtoemail" script. Ask to your host / Inter-
net provider how to do so. Usually that form is
managed by a "POST" or "GET" script (your
host will tell you the URL of this script, you
should enter it in the form start marker), and
you should insert some form element of the
"hidden" type to specify the real destination
email.


I published a page. Then I have gone online to
my homepage and tried double clicking on a
link but nothing happens. I have to right click
on it then click open.
Once a page is published, just ONE click on a
link on the browser is sufficient. Try to restart
Windows if not.


I have created 2 different .aeh files and have
created links back and forth to the different
files. With EasyWebEditor, is it possible to
publish both of these files to my Web site
without them overlaying each other? I've se-
arched through "help" but can't seem to figure
out how to do it. Each time I "publish" I only
get one file or the other.
Yes, simply change the name of the main file
(the cover). Hypertext, Current hypertext pro-
perties, the cell "Cover file name" (or de-select
the cover file name check box).


Can EasyWebEditor insert my site on the
search engines?
The purpose of EasyWebEditor is to *create*
sites. If you want your site to be listed on
search engines, you must submit its address to
each search engine: enter the search engine
(i.e. www.altavista.com) and search for
"submit your site". There are also programs/
services for doing this automatically, see some
on www.easywebeditor.com
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My search engine company states I have no
META TAGS  appearing on my site. Can you
explain where and how this can be accompli-
shed. Please bear in mind, I only have a basic
knowledge of what META TAGS are used for.
For each page, choose "Insert >HTML >At
page start", then you can write any META tag,
e.g.<meta name="keyword" content="games,
super games, ultra games"> <meta
name="description" content="This page is
about games">
It is not mandatory to have META tags. Most
search engines can index your pages without
them.


Can I "Publish" onto the Internet with the trial
version?
Sure you can. Sure. Have you read the FTP
publishing tutorial? "?-Help >Help >Tutorials"


I have about six pages constructed on a web-
site, and I need to have one of the pages
replace my 'home' or 'page 0' page, and move
the present page 0 to page 1 or 2.
There are two ways:
1) in "Hypertext >Current hypertext properties",
choose the second tab. Then, on the left, you
can choose the "cover" page and the "summary"
page. The "cover" page is the homepage
(default page 0)
2) use the copy and paste and paste the new
home page inside page #0 (you can also use
"Edit >Paste page from...").


I published to the Internet but it seems that not
all pages have been updated.
First verify that your browser cache has been
updated (use SHIFT + Reload button). If this
does not cure the problem, the fastest thing to
do is to force the program to update all of the
Web site. Before pressing "Publish", simply
press the "All" button that's on the bottom left.
The Internet is not perfect, so this may be
needed occasionally.


I found out that it's possible to upload an EWE
file with WS FTP if I save it as html. Could you


tell me the process of FTP'ing with WS FTP?
To get the HTML from EWE simply choose
"Publish >Export pages" then HTML as for-
mat. To choose the destination path for the
export (c: c:\temp or whatever you want) click
on the "Path" tab.
By the way, it is better to use the INTERNAL
FTP function, that has an "optimizer" that re-
duces the transferred byte size (in other words,
with the internal FTP the publishing is faster)


How does the program store Web pages on
the local computer and how does it upload
them? Some Web sites I've visited have the
entire "site" on a single page.  That is, even if
there are links to different subjects, if you
scroll down the page, you can eventually view
all the links. It *appears*  to me that your
program stores individual web site pages on
my local computer as one large file. QUE-
STION: Once I upload my web site, are the
pages stored as one large file with "anchor
links" OR does my Web site have individual
pages? I hope you understand the question
because I really don't know that much about
building a Web site. Until now, I've used
Homestead site builder (which is quite easy to
use), but I want to change.
EasyWebEditor permits you to do both things.
You can use just page zero as one big page,
and put links to anchors (use Insert >Anchor
and Insert>Special links) or you can use diffe-
rent pages. Usually it is better to use several
pages, because using one single long page, is
boring and/or takes a long time to load on slow
modem connections, and the visitors usually
switch to another site.
On the local computer, EWE stores all pages
in a single .AEH file (it is an internal format
that keeps your site compact and easy to ma-
nage). On the Web, EWE converts the site to
one or more HTML pages (depending on how
you use it).


How can I have statistics?
Please see  www.easywebeditor.com, right
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side menu for our statistics service.


What about shopping cart / ecommerce / ac-
cepting credit cards / PayPal on my Website?
There is an internal shopping cart (see the
proper Chapter) and you may use the shopping
cart plugin, www.easywebeditor.com/cart/


HTML - APPLETS - AEH - ASP
How can I modify the HTML of a page?
You can just add code, you can’ t modify the
automatically generated HTML. EasyWebEdi-
tor is designed with an internal optimizer that
works well both with IE, Firefox, Opera and
Netscape. As it is a bit possessive, it doesn’ t
allow external interference. If you want to add
code manually, use "Insert > HTML", or, with
any object selected, use the right mouse button,
"Properties", and the HTML tab.


I want to name the home page as "index.htm",
how do I do that?
Use "Hypertext >Present hypertext properties",
tab "Page settings, background".


I want to supply the HTML file name for a
page. For example "mickey.html" instead of
"nameaeh_000002.htm", how is that done?
Use "Format >Page properties", and the center
left gray box. This will not cancel the automatic
naming, but will add a redirection page.
Working this way optimizes the transfers
through the automatic FTP.


What should I do if I want many Html pages, or
I want to see a preview?
Use the "Publish" menu. You can also publish
directly with FTP.


What can I do with an "AEH"? Can I only see
it with EasyWebEditor?
You can see an "AEH" with almost all Visual
Vision products. An AEH file contains a whole
hypertext, so your work becomes easy to share.
With the "Publish" menu you can convert into
Html or Rtf files anytime you want.


How do I attach Java Applets to a page?
With "Insert >HTML" insert the HTML code
related to the applet. Instead of the class name,
i.e. where you find the clas-
sname="appletname.class" part in the code,
just write classname="", then place the caret
inside the brackets and press the button "Insert
page or file ref", then choose the 3rd tab and
search for the .class file in the HD.


Can I manage ASP pages with EasyWeb-
Editor?
Certainly. You can use "Insert >Html >Within
text" to insert ASP code. You can also take
advantage of custom components ("Tools
>Custom components prototypes") creating cu-
stom components libraries (every component
can have parameters, so you can reuse it with
ease in the text). EWE uses ".htm" or ".html"
as the file extension, but you can change this in
the Options (usually ASP pages are named
".asp"). Or you may ask to your server admini-
strator to enable .htm also for ASP pages.


DOWNLOAD / DOC / ZIP / PDF /
FLASH / INTERNET ACCESSO-
RIES / COUNTERS / FORUM / IM-
PORT FILES
How can I insert a file download on my site?
For example a ZIP?
The best way is to upload the file directly to
your http:// site with an FTP program such as
WS_FTP, then within EWE, select a text
block, use "Insert >Link", 3rd tab, "Add +",
and type the Web address of the file, such as
http://www.myaddress.com/myfilename.zip


How can I insert a directory in the server?
Inside the publishing window, there is a button
similar to the MS Windows new folder button.
If you want to use the directory for downloads
you should take an external FTP program
(such as WS_FTP). It will be configured like
the internal FTP, it has buttons for creating
directories.
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Does EWE have a function that will allow the
Web site visitor to download information from
my Web site?
Is the format of the intended "information" to be
additional ZIP, DOC, PDF files,...? If so, you
can certainly do this with EasyWebEditor. Sim-
ply place the files on your server using an
external FTP program such as WS_FTP for
example, then you can link to these files from
any EWE page using "Insert >Link", 3rd tab,
and inserting the direct link, e.g. http://yourser-
ver.com/yourfilename.doc


I have a .doc file that I don’ t want the browser
to open, I want to start a download when the
site visitor clicks on it.
Follow the same steps described above for the
download. In most cases the best solution is to
"zip" the .doc and make the .zip file available as
a download.


Why does the size of the AEH remain the same
even if I delete some multimedia files?
It is not sufficient to delete a link, a button or a
video with the CANC that deletes the button.
EasyWebEditor archives each thing you use in
an internal archive or “album” . If you delete the
link, the file remains inside the album, to ena-
ble fast reuse. If you want to delete the file,
please choose “Hypertext >Images - files - link
archive and erase” , search the file then delete it
with DEL.


Can I save in PDF format?
Indirectly you can. If you have the Adobe pro-
duct installed, choose "File >Print" then print to
the "Acrobat Distiller". Otherwise you can in-
stall a fake PostScript printer. You find some on
www.soft14.com


Any examples for interacting with Flash?
Use “ Insert >Flash” .
You can see www.easywebeditor.com/faq/ for
additional info.


How can I insert a counter?
A counter is typically a piece of HTML code.


You can insert it with "Insert >HTML". The
program will insert an icon to mark the point
where you insert the HTML. If you want to
change the code, select the icon, use the right
mouse button, "Properties". If you need code
for a counter or for other useful stuff, see
www.visualvision.com/utils.


How can I have statistics?
Please see  www.easywebeditor.com, right
side menu for our statistics service.


I am trying to insert a form for users to be
able to complete and submit. I would like
other users to be able to view what everyone
has submitted, but I do not know how to do
this?
You need a guestbook or a forum tool. These
kind of interactive tools are available from
lots of sources.
You'll find some free tool links in
www.visualvision.com/utils/


How can I insert a chat? A forum?
You will find info in www.visualvision.com/
utils/. Chat, forums, etc. are server side func-
tions. If you do not have direct server access
you should use third party services. These third
parties usually provide all the needed instruc-
tions. Usually you have to insert an HTML
code: HTML codes can be inserted with the
"Insert >HTML" menu.


How can I import files?
To import, use "File >Import" and choose a file
format (RTF; HTML; ASCII), then search for
the files you want to import in the file system
(shown on the left) and drag them to the right.
The program can import multiple files at a time
and automatically divide a single file into pa-
ges. Use CTRL+ CTRL- after the import to see
the pages. The program is designed to be used
for creating Web sites for all browsers; the
import functions sometimes discard the text
format, so it would be better to use the native
program functions once you have learnt them.
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When I import RTF, how does the system split
a single file into multiple pages, how does it
decide when to end a page and start a new
one?
It uses an internal criteria.
You can choose (in the import format menu)
one file/one page or one page/one page. The
latter option ensures that page breaks in the
existing document are maintained in your crea-
ted pages.


I have imported RTF pages, but most of them
do not include the "continue" link on the new
pages.
You are supposed to write the pages INSIDE
the program. If you import the pages from
another program, YOU will need to add the
links. The program can place very powerful
links, not only the sequential links expected for
a sequential piece or book.


After importing, the very first page is blank
and I can not get rid of it.
Simply copy another page inside it. Alternati-
vely, change the settings of the program so that
the cover page and the summary page are not
using the first page (Hypertext >Current Hyper-
text properties), then second tab, then click on
the left on "cover" or "summary" and choose the
required page.


I imported an .rtf document and set up some
links to certain portions of it (hypertext?).  The
links work fine, but in the non-edit, preview
mode, I can only get to the linked pages, not the
ones without links.
This is normal, as the preview mode is designed
to work as if published, and no pages would be
available in a live situation, unless linked.


Can your program import Word Perfect for-
mat (WPF files)?
No, but within Word Perfect you can choose
"Save as..." then save your file in RTF format,
that can be imported by our program.


SHOPPING CARTS, E-
COMMERCE
Can I add a shopping cart to my site?
Yes, there is an internal visual shopping cart
("Insert >Link to shopping cart" - "Hypertext
>Current hypertext properties" for properties).
You can also find a lot of free shopping carts
on the Internet. Insert the provided HTML code
with "Insert >HTML >Within the text".
We have also a free shopping cart plugin,
please see www.easywebeditor.com/cart/ for
more information.


Does the EasyWebEditor have a function to
accept credit cards online?
This is a function provided by various credit
card services. With a direct account you can
insert a form or some code in your page that
will allow you to take orders (this code may be
inserted on your page using Insert >HTML,
and are typically provided by the company you
elect to deal with). Some third party services
that enable you to accept credit cards are:
clickbank, kagi, pageville and a lot more, (you
can use search engines to find others).
See also www.easywebeditor.com/cart/


I am in the process of using the PayPal shop-
ping cart Generator using HTML, and am
making a Buy Now cart for each item I sell.
The Generator states: “ make a copy of the
first box by pressing Ctrl+C and choose copy.
Then it says in your web site files, open the
code for the web page from which wish to
collect payment. Paste the code you just co-
pied into your Web page file wherever you
would like the image to appear...”  Since I was
not using HTML, I'm not sure how to do this,
can you help me?
In EasyWebEditor, place the cursor where you
wish to insert the code in the page. Then, use
"Insert >HTML >Within text". The program
will show a dialog where you can paste the
PayPal code using CTRL-V (or SHIFT-INS).
Then press OK. You will see that EWE will
place a small icon on the page. On future
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occasions, should you wish to edit the code,
simply use the Right mouse button over the
icon, then Properties.


I haven't worked out yet how the shopping cart
lists the number of items chosen by the custo-
mer before they submit their order. It seems to
want to submit each item individually.  If this
software has the facility to create a customer
shopping list before it is submitted, could you
let me know what I need to do to make it work?
Simply place links to the shopping cart ("Insert"
menu) and give a different "id" to each item. As
the customer clicks on an item (text or image
link), it will be added in the shopping cart
window. If the shopping cart window is closed,
all items are deleted.
We have also a free shopping cart plugin, ple-
ase see www.easywebeditor.com/cart/ for more
information.


Would I be able to use the shopping cart in
EasyWebEditor with a merchant provider, me-
aning could I use a merchant provider to han-
dle transactions and still make use of the EWE
shopping cart? If not, how can I make use the
cart?
Merchant providers usually supply their own
codes for implementing their shopping carts:
you can insert these codes in EWE by using
“ Insert >HTML >Within text”  (read the other
FAQ about the PayPal shopping cart). The
internal EWE shopping cart is useful if you
want to have your own independent shopping
cart.
Please see www.easywebeditor.com/cart/ for
more information.


I have a credit card company that processes
orders for me.  I am trying to add new pro-
ducts to my Web site. They say that I should
copy the custom Java script they create, based
on my new product, and just paste it in my Web
page where I want it to display.  But I can't
hide the text or get the order window and
buttons to display. I've tried everything I could


find in the on-line manual, but all I get is a
little box displayed, and you can't do anything
with it. It has nothing but markers for resi-
zing, but it doesn't resize.
You are probably using "Insert >HTML
>Within text". It is the right thing to use, but
you will NOT see anything in the editor win-
dow, just an icon to represent the point where
you inserted the code. You will see the actual
code working only when you publish to the
Web site.


GENERIC QUESTIONS
I can’ t find the answer to my question!
No problem, just write to us! Or take a look at
the user’s forum, most questions already have
an answer there:
www.easywebeditor.com/forum/


I can't delete some objects with DEL.
Use DEL twice.


The XYZ window displays too small for me!
Please resize the window. EasyWebEditor sto-
res and remembers window settings.


How can I see the hypertext on a browser?
Use "Publish >Browser preview"


I'm writing a manual for an application and I
need to include multiple copies of the applica-
tion logo and application name. Is there a
quick way?
Create a new page, insert the name and the
logo of the application.
Then you can use "Edit >Paste page from..." to
insert the logo anywhere you want.


I can't use tabs!
You can use the "reduce indent" and "increase
indent" buttons.


The copy and paste procedure sometimes di-
scards the text format.
This can happen for short text, as EasyWebE-
ditor tries to use intelligent behavior when you
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cut & paste. Sometimes the behavior is not
exactly as you might expect.


Can I insert the same text and/or image group
in multiple pages, like a "C include"?
Yes, simply create a new page and enter the
required text and images. Then, for each page
that will contain the text, use "Insert >Html
>Within text", then use the "insert page in text"
button. A window will display allowing you to
select the page to insert. Note: This is not a fully
visual operation, and works only when Html
publishing. For a fully visual system, see
another FAQ in this page.


How can I make floating windows?
When a user browses your site / hypertext, there
are two ways a window can show:
- when user clicks on a special link ("Insert
>Special link")
- when user enters a page that contains an "open
window" component ("Insert >Page functions
>Open / close windows"
See samples in "? >Examples".


In multi-frame pages Netscape sometimes
hangs.
This is due to a style-sheet bug in some releases
of Netscape 4. To avoid the problem, use
"Format >Reformat" on all paragraphs within
the hanging frame. You may have to define
some additional styles to accomplish this.


Netscape reports "Javascript error,
IperF_open not found in page xxxx.htm".
Edit the page in EasyWebEditor and insert a
special link to a pop-up, even a hidden link, e.g.
a white comma on a white background.


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


I can’ t “ minimize”  the application.
Select “Tools >Program options”  then “Reset
dialogs settings” , then exit from the application.


I have a problem with the program locking up.
It seems to be related to the file I am working
in because I had a few other files I was
working with and I am not having the problem
there. If the file is corrupted in some way is
there anything I can do about saving some of
the pages? Help! I don’ t want to start over!
When a file is corrupted the most practical way
is to open a new file, and copy the pages (the
non-corrupted ones) from the old file, using
"Edit >Paste page from...".
Or you may use the automatic backup (do not
save; use File >Open, then select the format
Backup BAK from the pull down menu on the
bottom)


How can I protect some Internet pages with a
password?
This is a server side thing, your host (or Inter-
net Provider) should be able to provide the
information required.


What is the difference between EasyWebEdi-
tor and HyperPublish?
EasyWebEditor (EWE) is purely for Web de-
sign; HyperPublish (HP) can also create auto-
install CD-ROMs, has more functions, and has
no limit to the maximum number of pages in
each file (www.visualvision.com/checklist/ for
a comparison table)


I have EBooksWriter. What is the difference
with EasyWebEditor?
The EbooksWriter can create self-extracting
ebooks, i.e. it can transform an AEH file to an
EXE file that a user can click and see (without
anything else installed). With EbooksWriter
you can also password protect pages or set of
pages (they will be encoded with a strong 128
bit encryption). You can also disable print or
clipboard copy. The interface is very similar to
EWE, and you can read EWE files.


What is the difference between EasyWebEdi-
tor and 1site?
1site is more powerful than EasyWebEditor
(includes link explorer, macro, TOC, slides...)
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and it has an higher limit to the maximum
number of pages in each file; www.1site.info


The program says "Please delete objects with
Hypertext >Images - files and deletion, or buy
HyperPublish / 1site". Is this normal?
Yes, EasyWebEditor stores each image in an
internal album, so even if an image is deleted
from the page, it is still kept in the album,
which has limited available storage.
You can rectify this using any of the following
methods:
- delete unused images using "Hypertext
>Images - files and deletion" (select an unused
image and press the DEL key)
- divide the work into two or three AEH files,
(you can link these AEH files, see below)
- upgrade to HyperPublish at a discounted price
(HyperPublish album has no limits).


I have an old 200MHz PC, is this sufficient?
Can I manage a high traffic site with this PC
and EasyWebEditor?
Do you mean "host" a site? To manage a Web
site "in house" is quite expensive. You might
want to take a look at the various hosting offers
that can be found on the open market. Apart
from that, your PC is certainly OK for running
EWE: if it can run Windows, it can run EWE.


Do you have a Mac edition?
No. But nowadays PC emulator software are
cheap. And EWE is very fast also when running
within an emulator.


I have an icon for email - I've checked the
tutorial and can't find out how to make this
work!
Very simple: select the image, right mouse
button on it, "define link", 3rd tab, "+ Add"
button, then enter mailto:youraddress@aol.com


I can't get the spell check working!
The application uses the MS spell check en-
gine. Some installations of Office 2000/XP
mess things up. A practical solution to get
things working quickly is to install an old


MSWord release (for example Word 7); or see
the user’s forum (search for spell check).


In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.


The program says “ Access Violation XXXX” ,
then hangs...
You have too many applications opened (” too
many”  may mean 4-5 in Win98/ME...!). Close
some apps or restart the computer.
The error numbers like 00231245E are no use
to us at all.
If this happens and you are able to provide us
with step by step instructions on how to repro-
duce the error, (e.g. open the program, write
"mickey", press "save" and the error ALWAYS
happens) we can correct the problem.


Can I show an external URL in a frame or a
pop-up?
Yes, create an empty page / frame / popup then
use "Insert >HTML >Within text" and insert
this code:
<script language=javascript>
<!--
location.href="http://www.abc.com"
//-->
</script>
The empty page will be replaced with the
external URL (http://www.abc.com). Use pa-
rent.location.href="" in case you want to re-
place a whole frame set.


My popup window works fine in preview, but
does not work at all in browser preview or on
the net. Do you have any ideas as to what is
wrong?
This can happen if you use a window name
that includes spaces or strange characters. Ple-
ase use something like "Mickey" as a window
name (without the quotes). "Mickey Mouse",
"123bcd" or "Mi$%/&" for example, are not
valid identifiers.
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If I switch to “ read only”  (Edit/Preview but-
ton), the slides don’ t appear to work.
You have to use "Hypertext >reload page" to
start the slide sequence. To obtain this at load
time, configure the hypertext as "Read only"
using "Hypertext >Options".


I have noticed that in some of my work, when I
resize the windows (larger or smaller), some
tables or images move and don't retain their
position. Is there a solution to this problem?
You would benefit from practising with the
"invisible" tables, and learn how to use them to
correctly position images and text. You must
remember that the final users screen and win-
dow sizes are unknown. Within Chapter 10 you
will find some useful suggestions on how to
create this kind of positioning.


PURCHASE - REGISTRATION
I created some pages with the trial version,
can I use the project with the registered edi-
tion, without having to redo it all?
Yes, sure.


As I have now purchased EWE, I want to
remove the sentence "VisualVision EasyWe-
bEditor..." that is inserted on the bottom of the
pages.
This is a simple change. When you first use of
the full registered program, and before pres-
sing the big "Publish" button, select "All" in
the bottom left of the internal FTP dialog. This
way the program will refresh all pages (not
only those modified) so the sentence will be
deleted.


MORE QUESTIONS
www.easywebeditor.com/forum/
www.easywebeditor.com






