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Is it true that the CDs will replace the books? I don't know.
Whether or not the printed page will be around forever is
unknown, what I do know for certain is that it has now a
powerful, much cheaper brother.

We wish you success working with CDFrontEnd, and feel
sure you will gain almost as much satisfaction using it, as we
did while designing and writing it.

Ing. Aldo Ghigliano
President, Visual Vision
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CDFrontEnd is a fast and easy-to-
use tool for creating professional

hypermedia autorun CDs.

Thanks to its multimedia capabilities, the
program can create brochures, catalogues,
manuals and, in a more general way, auto-
run any possible content on a CD.

When the end user inserts a CDFront End
CD in their computer, the CD immediately
starts. Nothing is installed on his/her PC
and nothing is required (no Internet Explo-
rer, Opera, Netscape or other browsers). In
other words, the product is completely self
contained and will run off the CD without
problems on any PC. Additionally, it won’ t
be blocked by “ popup killer”  applications
as it uses a private viewer (with powerful
protection features).

No technical knowledge is required to use
CDFrontEnd (more concisely, CDFE), as
CDFE was conceived for everyday utiliza-
tion, much like most of the common word-
processors that you use for printing works

on paper.

You don't have to write code and you don't
need to use external programs. Unlike
some other CD programs, CDFront End is
not a so called “ compiler”  but a feature
rich, standalone environment. It encompas-
ses all you need to get from the page editor
to the autorun CD presentation. You just
have to think about what you want to
write... yes, at the present time, this is still
needed!

Due to its special format and the video
setting adopted, CDFrontEnd (CDFE) of-
fers a very practical way to view informa-
tion on the screen, without having to repea-
tedly zoom on the page, no matter what
size of monitor is used.

There are essentially two major differences
when comparing CDFE with ordinary
tools. Firstly, CDFront End in effect al-
lows you to “ print”  on the reader’s screen
rather than on paper: this means that the
horizontal size of the page is not fixed but
is variable. Secondly, CDFront End mana-
ges hyperlinked pages as a complete set,

Introducing
C D F rontE nd
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used by other Visual Vision products
(www.visualvision.com). If you wish, for
example, to publish your work as Internet
pages, you just need to pass the file to Hy-
perPublish or 1SITE, there is a discount
available for all CDFrontEnd PRO owners.

Every CDFrontEnd page can be protected
with a password. You can also define diffe-
rent passwords for different page sets. Fur-
thermore, you can set different passwords
for each user (the CD remains the same for
everybody, just the match userdata/password
changes). In addition to that, the program
allows you to disable the cut and paste func-
tions and to define an expiry date for the CD.

All CDs have a built-in search engine, with
both keyword and full-text searches. This is
automatic.

Thanks to its hypertext-oriented nature, a
single click is often sufficient to perform an
action on several pages (saving a hypertext;
global searching and substitutions). CDFE
can also read the most common text formats
and can import pictures through the clipbo-
ard.

In conclusion, CDFrontEnd is a powerful
tool for people who want to be free to think
about the content, instead of getting confused
with programming, files or code. It has been
designed around immediacy and speed for
everyday work.

The application requires at least a PC with
MSWindows 95 osr2 (or Windows 98, Me,
NT, 2000, 2003, XP, XP SP2), and at least
a old Pentium I 100MHz, 32Mb of RAM
and 32MB of free Hard Disk space.

We are sure you will appreciate both our
software, and the vast effort behind produ-
cing it. Enjoy!

rather than as stand-alone pages, using an
interface specifically optimized to manage
hypertextual links between pages (words or
pictures you can click on to be taken to other
sections or when calling external docu-
ments).

The simple yet powerful editor interface pro-
vides you with the opportunity to use styles,
tables, hot spots, rollovers, frame sets, slides
and popup windows easily... The automatic
database / CSV import and the automatic
photo gallery / thumbnails creation makes it
easy to create CD catalogues and CD photo
albums.

What’s more, it’ s all visual, WYSIWYG
(What You See Is What You Get), that
means what you see in editing mode is really
what you get when you publish your CD.
CDFrontEnd is also WYSIWYL (What You
See Is What You Link): this means that all
links between pages can be defined directly
on screen and they’ ll be immediately
“ active” , enabling you to follow them from
within the editor, simply by double-clicking.

Furthermore, when you select the destination
page of a link, all the dialogs have a preview
screen, to make selection even simpler. You
see a preview of the selected page, and you
can navigate within that preview, simply by
clicking a link, so you can reach the required
destination page by either name or naviga-
tion. It’ s really much easier to use than it is
to explain!

A click on a link can run any kind of file, and
you can also enclose a so caller “ Viewer”
for any file format. No confirm is asked to
the user when a link runs an external exe file
or any other file.

The editor is optimized to act on a whole
hyperlinked document, which is saved as a
single file in .AEH format, the same format
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1 .  Y our f irs t w ork

Fig.1 will appear, ready for you to type
some text into the page. Enter a line or two
of text about vegetables and include the
word “ potatoes” .

The number “ 0”  shown in the central text-
box at the bottom of the current page,
indicates that we are on page “ 0” .

Now we can select a word, which is done
in the same way as in many other applica-
tions; simply drag your mouse over the
word or double-click it: let’ s select
“ potatoes”  (See Fig.2), and now click the
Link button on your toolbar (the one with
the chain and a page on) as shown
here:

The window in Fig.3 will be shown;
this is one of the most important dialog
windows, because it allows us to define
many link types, by simply choosing one of
the tabs on the top.

But let’ s get on: Choose the “ New page”
tab (the last on the right) and press the
“ OK”  button. CDFrontEnd will define the
link and, at the same time, will take us to a
new page, where we can provide more

Once you have CDFrontEnd instal-
led on your PC, either from a CD or an
Internet distribution release, you will doub-
tless be impatient to make your first page.

The first thing to keep in mind is that
CDFrontEnd operates on a whole hyper-
linked presentation, not on single pages.
This means that multiple pages can be
loaded in memory at the same time. This
set of pages is also called “ hypertext” . At
any time, once they are created, it is possi-
ble to browse pages, create new links,
navigate throughout a file, or carry out a
search. The easiest way to pass from one
page to another is using CTRL+ and
CTRL- keys.

Inser ting links
Linking pages is really very simple: let’ s
make a simple example now, by creating a
hypertext consisting of two pages, each
linked to the other.

Let’s run CDFrontEnd: the window in
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little text now, as shown in Fig.4. At this
point we need to insert a link to the pre-
vious page (page 0), the one about vegeta-
bles.

Now type then select the text “ Back to
previous page” , and click again on the Link
button (chain picture). The window, as
shown in Fig.5, is displayed showing us a
list of all available pages within the hyper-
text (page #0 and page #1 in this case). We
can now directly choose the link destina-
tion on the screen, so let’ s choose

information about potatoes.

If you check
the text-box
at the bot-
tom, you’ ll
see the cur-
rent page
number has
switched to
“ 1” .

Let’s add a

Fig.1 –
CDFrontEnd main

window: to write
something, just

type on your
keyboard…

A hypertextual link
looks like an underlined
word or sentence: with a
click on it you will switch
to a related page (a dou-
ble click when in the
CDFE edit window, ac-
tually).

Fig.2 – Let’s
choose a word
within the text,
"potatoes" for

example
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“ Vegetables” .

Click on the “ OK”  button and CD Fron-
tEnd takes us to the page in Fig.6 (page
#0). Notice here that the link to “ potatoes”
is underlined blue text (by default). If we
double-click on the word “ potatoes” , the
editor will automatically switch to the
“ Potatoes”  page (page #1).

From this page, we can double-click on
“ Back to previous page”  to return again to
page #0, and so on.

As you can see, creating links and naviga-

ting through them with CDFront End is
really very easy, even from within the
editor.

There are several ways provided to move
from page to page: you can type the page
number directly in the page number text-
box; use the up and down arrows beside it;
use the right mouse button over the same
text-box (a list of recently visited pages
will be shown); you can also use the red
arrow buttons at the top left to go to pre-
vious or next visited pages.

Fig.3 – The Link
to... window where

you can define
simple links: just

select the last tab

Fig.4 – Let’s write
something in page

1.
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Using the Hypertext menu at the top, click
“ Hypertext > Read-only”  to switch to a
non-editable preview of the hypertext: This
is handy as you won’ t need to click twice
on links, and table grids will be hidden, but
more on that later.

It’ s now time to save your work: Choose
“ File > Save all”  and the whole presenta-
tion will be saved into a single file with the
.AEH extension. The process is the same
whether 1, 2 or 1000 pages; 1, 2 or 1000
images, in this way CDFront End keeps
your work compact and simplifies the tasks

of making back-ups and exchanging files.

Link to files (e.g. PDF)
It is really very simple to insert a link to a
file (a PDF, a ZIP, PowerPoint, a video or
audio file). Highlight a text block, choose
“ Insert >Link”  from the main menu, and
then choose the 4th tab. Then you will be
able to select the file from your hard disk.

For audio / video you may also use Insert
>Sound / Animation (this way you may
insert the thing within the page, instead of
placing a link).

Fig.5 – The window
where you can

visually choose the
target for your link.

Fig.6 – We’re back
to page 0, and  can
see that the link to

the "potatoes" page
is already active.
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you should create your presentation or your
simple page with a video or a PDF or so
(see the previous chapter); or you can open
a work you previously created.

When the work is ready within the editor,
then choose “ File >Create autorun CD in
temporary folder...”  or press the toolbar
button with the CD icon. You will be
prompted for a temporary folder (that will
contain the draft copy of the CD). Now it is
the time to choose the c:\MyTemp folder
you previously created.

Press OK and the program will show what
in Fig.11. You may choose "Browse..." to
take a look at the folder with the temporary
copy of the CD, the folder will look like
Fig.12.

N o matter if your work is a complex
presentation, or you are just attempting to
create a CD for a single PDF file or video
(see previous page), it is very simple to
setup the autorun CD.

First of all you should create a temporary
folder on your hard disk. You can do this
with the MSWindows File Explorer.
Quickly: double click the “ My Computer”
icon that’s usually on the top left of the
desktop, then double click “ C:\”  (your hard
disk), then use the “ File >New Folder”
menu, it will create a folder “ New folder”
that will be highlighted and editable: name
it MyTemp.

Then you should open CDFrontEnd and

2 .  C re a ting th e
a utorun C D ,  running

a ny  k ind of  f il e

Fig.11 - The
program has just

created the CD
within the

temporary folder
you selected. You

may test the CD
(with some limits...)
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Running files: PDF, video,
music, PowerPoint...
The simplest use for the program is to
autorun a single file, say a PDF file, a
video, or anything else. In other words you
may want to just run a file, and not to show
a presentation to the user. In this case, the
CDFrontEnd presentation might be repla-
ced by just a simple “ cover page”  with two
images or two links such as:

- click here to view / start the Wonderful
file created with ACME

- click here to install the ACME Viewer (if
you don't have it yet).

This last link is important for a professio-
nal CD, as you can’ t suppose that the
user’s PC already contains the Viewer sof-
tware needed by the file you want to auto-

Now you can open Roxio (or Nero, or Win
OnCD, or whatever) and burn the tempo-
rary folder into the root of a CD. Usually
you can do this simply, by creating a new
CD project, and doing drag and drop (see
Fig.13). In the simplest case, the root of the
CD will contain the files:

autorun.ico
autorun.inf
brochure.aeh
CDFE_e.exe
readme.txt

and no folders. Close all programs, insert
the CD in the drive, and enjoy!

GOLD edition: edit gold.gif to change the
logo; edit autorun.ico to change the icon.

Fig.12 - The tmp
directory that you
will burn into the

ROOT directory of
a CD...

with the GOLD
edition you can

change both the
logo and the icon...

Fig.13 - How to
burn with Nero...
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Fig.14 - The
window where you
can insert links to

external files

that is registered in MSWindows for that
file extension.

Link to embedded files
This is the simplest way to run a file.
Embedded (inserted, included) means that
the file is going to be embedded within the
CD FrontEnd document / presentation: this
means that when you will create the CD/
DVD, the original file(s) won’ t have to be
placed on the CD (it is CD FrontEnd that
cares about these files, you have to do
nothing). Embedded links work also in the
editor.

To insert a link to an embedded file, highli-
ght a text block or a picture, and use
“ Insert >Link to embedded file” , then

run. Some files can be seen on any PC
without any additional software, some
other formats need a so called “ viewer”
software. Free viewers are available for
almost all popular formats, such as
MSWord Viewer (viewer for DOC),
Acrobat / Adobe Reader (viewer for PDF),
PowerPoint viewer (viewer for PPS),
MSExcel Viewer, and so on... Should you
need the updated XY Viewer just search
“ XY Viewer download”  on
www.google.com.

As for running the files from the links,
CDFrontEnd provides two ways: you can
insert a link to an embedded (included) file
or a link to an external file.

When the user clicks the link, the program
runs the file by passing it to the program

Fig.15 – Here you
can choose to

show your
presentation in full

screen...
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browse the Hard Drive for the file you want
to link.

Normally, a click on an embedded file link
will prompt a “ Save / Execute”  dialog win-
dow: you can disable this with the checkbox
“ run this file without asking for user confir-
mation” .
Please notice that with this kind of link the
selected file will be permanently inserted
into the internal album, and will increase
your work file size. The menu “ Hypertext
>Images - files - link archive and erase”  is
the only way to remove the file from the
album.

External files
External files are the professional versatile
way to run a file; you should use this way to
run / link big files.

External means that the file is external to the
CD FrontEnd document/presentation: this
means that when you will create the CD/
DVD, the original file(s) will have to be
manually placed on the CD (you must ex-
pressly care about this). External links don’ t
work in the editor - to test them you should
burn a CDRW or use a USB key drive.

To insert a link to an embedded file, highli-
ght a text block or a picture, and use “ Insert
>Link to external file” , then press the “ Add
+”  button, then type something like

run:nice_folder_name\nice_file_name.pdf

Let’s see an example. In the following exam-
ple we want to autorun a PDF file called
mydocument.pdf that you will enclose in a
folder called /data on the CD. Select the
cover image and/or the text block, then
“ Insert >Link to external file” , then “ Add +”
then type:

run:data\mydocument.pdf

Then, assuming the Adobe Acrobat Reader
(the PDF Viewer) setup file is called
ar405eng.exe and you will enclose it in the
same /data folder, repeat the process and
type:

run:data\ar405eng.exe

In Fig.14 you see we added these two links:
mydocument.pdf (the PDF file that we
want to show), and ar405eng.exe (the self
installing Acrobat Reader). If you don’ t
have the Acrobat Reader setup file, you
can download it from www.acrobat.com.
The name might be ar701eng.exe or so-
mething else.

Now, if you want the full screen without
any top menu, check the relevant check box
in “ Hypertext >Current hypertext proper-
ties”  (Fig. 15). Then save the file with
“ File >Save all” .

Then, just choose “ File >Create autorun
CD in temporary folder...”  or press the
toolbar button with the CD icon. You will
be prompted for a temporary folder that
will contain the copy of the CD (e.g.
c:\MyTemp).

Press OK and this temporary folder will be
filled with the proper files .

Then open EasyCD (or Nero, or Wi-
nOnCD) and burn into the root of a CD
both the temporary folder content and a
/data folder with the files mydocument.pdf
and ar405eng.exe. This means the root of
the CD will contain the files:

autorun.ico
autorun.inf
brochure.aeh
CDFE_e.exe
readme.txt
data/mydocument.pdf
data/ar405eng.exe

in other words the files:
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autorun.ico
autorun.inf
brochure.aeh
CDFE_e.exe
readme.txt

and a folder /data containing

mydocument.pdf
ar405eng.exe

Close all programs, insert the CD in the
drive, and enjoy!

Important: if you have Acrobat Writer, you
might find on your Hard Disk the file
AcroRd32.exe. This is NOT the auto in-
stall file for the Acrobat / Adobe Reader
Viewer. This is just the stand alone viewer
and can't work with the example above.
Please see the www.acrobat.com Web site
to download the correct SelfInstalling Se-
tup File (it is supplied with CDFrontEnd
CD edition, by the way).

With this technique you can insert in the
CD any kind and any number of different
files. For example you can run a Power-
Point presentation. The viewer for the
PowerPoint fi les, PPView97.exe fi le is
available in the CDFrontEnd CD. Please
notice that if you have PowerPoint, you
might find on your Hard Disk the file
ppview.exe or ppview32.exe. This is NOT
the auto install viewer file for the Power-
Point Viewer. This is just the stand alone
viewer and can't work with the example
above. You may see the
www.microsoft.com Web site to download
the SelfInstalling Setup File for the Power-
Point Viewer (search for “ PowerPoint
Viewer Download” ).

External files and run:
We have seen that the run: command is a
quick way for running without confirming
any kind of external file. Example:

run:myfolder\mydoc.doc

will run the document mydoc.doc that must
be within the folder myfolder of the CD.
This implies that:

run:mickey.pdf

will run the document mickey.pdf that’s
within the main folder of the CD. The
program does automatically detect the CD
drive name (such as D:, E:, etc.).

IMPORTANT: this feature doesn’ t work in
preview - within the editor.

External files and save:
The save: command works just as the run:
command. Instead of running the external
file, it will prompt a “ Save as...”  dialog.
Example:

save:myfolder\mydoc.doc

will show a “ Save as..”  dialog, that will
save the document mydoc.doc that must be
within the folder myfolder of the CD.

This is useful for creating CDs with file
collections (documents, large photos,
software, music, video: the end user inserts
the CD, searches what he/she needs, and
save it to the hard disk).

IMPORTANT: Please notice that both the
run: and the save: links won’ t work within
the editor and/or in test mode - you should
actually burn a CD (maybe a CDRW) and
you should place the external files correc-
tly, e.g. if you use run:nicfolder\file.abc,
then the file file.abc should actually be
present within the folder nicfolder of the
CD (this means that with Nero, EasyCD,
WinOnCD or whatever, you should burn
on the CD both the CDFrontEnd files and
the external files to which you are linking).
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Running programs and files
with parameters
You can use CDFrontEnd also for autoru-
ning a file passing it to a program. This can
be useful when you have a viewer applica-
tion that wants “ command line”  parame-
ters. Say that your application is called
xyzview.exe and your file is called
mickey.xyz.

As in the previous example, create a tem-
porary folder, say c:\MyTemp. Then run
CDFrontEnd. In the first page, insert this
text (you can replace it with two wonderful
images): “ click here to start the Wonderful
file” .

Select the first text block and use “ Insert
>Link to external file”  (if a picture, use the
right mouse button, “ Define link” , 3rd tab),
“ Add+”  button, and write
run:data\xyzview.exe data\mickey.xyz

You may add other command line parame-
ters as well. Please avoid using folder na-
mes and/or file names with spaces.

File collections
In this chapter we inserted a link to just one
file, but of course you can link any number
of files. This way you can create stunning
presentations, mp3 collections, shareware
files collections, any kind of professional
CD: the program can act like a glue
between different formats.

Reader  screen / show options
As you can see from Fig. 15 you can set
several show options for the CD.

You can show it with a predefined size and
position (but be careful - there are a lot of

different monitors and a lot of different
video resolutions out there), you can show
the CD in full screen and even “ force”  the
full screen (if “ force”  is selected, the CD
window can not be resized). You can hide
the menu, the toolbars, and also the top
bar...

Additionally, for the GOLD edition only:

− you can force the page title to be
shown on the title bar

− at the first run, you can force the
program to ask the end user his/her
name/email; if she/he agrees, this data
can be sent to you through email or
through a script (this way you can
track your end users, create newslet-
ters, etc.);

− within the small dialog that prompts
for name and email, you can show a
“ Ask pass”  button. When the end user
presses this button he/she will auto-
matically prepare an email with the
user data (then the end user may send
the email to you)

Autoinstall
If you want to install the presentaton /
catalogue on the user’s HDD, please get
HyperPublish, www.hyperpublish.com
(just email us for any questions). Usually
you choose “ auto-install”  for catalogues
(where the end user will want to permanen-
tly install the stuff on his/her PC in order to
avoid always having the CD within the
drive), and “ auto-run”  for brochures
(where the end user just wants to quickly
see, without having to install anything on
his PC).
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the “ print current frame”  feature; see Fig,
17).

From within the same window you can
also set an expiry (expiration) date for the
presentation / brochure / catalogue: for
example, you could inhibit reading after
the 11-5-2010.

Then you can define a “ editing password”
to completely prevent unauthorized chan-
ges to the text using CDFE (the CD is
always “ read only” , this is to prevent edi-

P iracy is a real risk for CDs. CDFE
offers you several interesting op-

tions to help you to protect your work.

With the “ Hypertext > Current hypertext
properties”  menu, first tab, you can disable
the printing and/or the clipboard copy (cut
and paste). When printing is globally disa-
bled you can still enable a single page to
be printed (use “ Insert >Special link” , and

3 .  P rote cting a  C D

Fig.16 - With
“Hypertext

>Current hypertext
properties” you set

up copy and print
protection, expiry
(expiration) data,

and a “edit”
password (the CD

is always “read
only”, this is to

prevent editing in
case the end user

owns
CDFrontEnd...)



18

ting in case the end user owns CDFront
End...). Be sure you record this password:
if you lose it you will be unable to edit your
own work - there is no way to recover it.

But now let’s see the sophisticated pas-
sword protection feature that does permit
you to protect your CD with one or more
password that you will supply to your end
users. With “ Hypertext > Password”   the
window in Fig.18 will be shown. The sim-
plest thing is to assign one password for
the entire CD. But you can do more. For
example you can create a CD with ten free
introductory pages and protect the rest of
the document with a password. Or you can

protect different sections of the CD with
different passwords. Or you can force the
program to automatically assign a personal
password (or passwords) for each user.

When you have just created a new presen-
tation, the simplest thing you can do is add
a single password to the whole document.
If you want to do this, just click the “ Add
password”  button, enter the password (e.g.
“ mickey” , see Fig. 18), then the program
will ask you if you want to assign it to all
pages. Say Yes and you are done. All your
users will be able to read the CD by just
entering the password “ mickey” .

The CD prompts for the password the first

Fig.18 – The
password dialog -

we applied a
password to page

2,3 and 4. The
password is the

same for all users,
and is “mickey”...

Fig.17 – With insert
special link you can

place a link such
as “click here to

print the page” (or a
print button)
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page you want to leave unprotected.

Different password(s) for
each user
If you wish to set a different password for
each user (we call this “ reader password” ,
while the unique password or password
seed is the “ author password” ), you just
have to put a check-mark on “ custom pas-
sword for each user” , then save the file
(Save all), then create the CD, and keep
the source file (AEH) you used for crea-
ting the CD in a safe place.

When this option is selected, the CD re-

time you attempt to enter a password pro-
tected page: usually it is wise to not protect
the cover page (select the password
“ mickey”  on the left, then just search for
the cover page on the right list and uncheck
it), this way if the user forgets about the
password, well at least he/she will be able
to know what CD she/he is holding!

If you wish to apply the password
“ mickey”  just to a page set, select the
password in the left box, then check in the
right section every page you want to pro-
tect with this password.

To leave a page unprotected, just click the
“ See pages without pass”  and check every

Fig.19 – If you
check “custom

password for each
user” this window

becomes a “on the
fly” password

calculator.
Example: you

insert “aldo
ghigliano” etc and

the password
calculated is

S\ZTog...

Fig.20 – For the
same CD, the

password for the
user john smith is...
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For the same file, for the end user john
smith  john@smith.com, the password will
be as in Fig.20 (bXaRQs).

You will supply the same CD to John and
to Aldo, each with their own password(s).
The end user knows nothing (and should
not know) about the author password.

The program includes a facility to help you
print/email the password to the end user:
just insert the user data, then press the
button “ >”  on the bottom right. For john
you will have what is in Fig. 21.

Please notice that the author password(s)
has no use when “ custom password for
each user”  is checked - it’ s just a seed used
for calculating the user’s passwords.

For test purpose we do recommend you to
test the CD on a different PC. This way
you will avoid mistakes (your PC will
preset you as user and you should not
change the preset). If the user needs to
“ reset”  (clear) his name/email or the pas-
swords due to a mistake, he/she can use the
right mouse button (User data and Reset
passwords) or the “ ?”  menu.

When a page is password protected, it is
crippled with a strong 128 bit algorithm.
Your passwords are stored in a .EWP file
(don’ t distribute and don’ t delete!!), saved
in the same directory of your AEH file.

mains the same for all users (just like when
there is just one password - it can be mass
replicated), it is the match username /
email and password(s) that changes. You
can print and distribute infinite CDs as the
CD “ knows”  all the passwords.

When you sell a CD to a given user, you
open the CD source file, you use
“ Hypertext >Passwords” , you enter the
user data, and the password(s) is calcula-
ted on-the-fly and can be printed / faxed /
emailed to the user.

Example: say we have the document
abc.aeh, with the author password mickey
associated to all the pages; say this CD is
enabled to personal passwords for each
user (“ custom password for each user”  is
checked); say you are the end user aldo
ghigliano aldo@visualvision.it. The
author will give you the password S\ZTOg
(see Fig.19), this will enable you to see the
CD. In other words, for this CD, the pas-
sword for aldo is S\ZTOg and will always
be asked the first time he enters one of the
protected pages. It will work ONLY if
aldo enters the data aldo ghigliano
aldo@visualvision.it when the CD asks
for them (the end user may also click the
right mouse button and choose the “ User
data”  menu).

Fig.21 – The
automatic

password draft
message facility..
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and/or applied to the text using the
“ Paragraph”  toolbar or from the “ Format”
menu.

The easiest way to understand the advanta-
ges of using styles is to consider this docu-
ment you’ re reading now: every single
page has a title; the title style is the same
for all pages and is different from the text
style (Titles are larger and use a different
font, or typeface).

Saving different styles for titles and nor-
mal text offers these advantages:

− You save time in applying a set of
attributes (if we hadn’ t used the
‘Title’  style for this book, we would
have needed to select each chapter’s
title, applied a font and a size, applied
bold,...);

− You can immediately modify multiple
pages, or even the whole document,
by simply changing one little thing. If
you decide to use green for the titles,
you just need to modify ‘Title’  style,
and it will be applied to all pages
instantly;

N ow we’ve had some practice with
the simplest ways to manage pages and
links, let’ s have a look at the main text
functions and how we can use them.

Text format
Nowadays, all word-processors have stan-
dard buttons to let you apply ‘bold’  and
‘ italic’  characteristics to the text and
CDFE is no different; you can also change
the color, size and character (font). In
addition, CDFront End offers you the abi-
lity to define your own text styles, in much
the same way as MS Word or Word Per-
fect do. Links can have their own proper-
ties (you have to use styles to modify them
- i.e. if you need a particular color for
links, you may edit the properties of the
existing styles or create new styles).

Styles
Text styles can be used to save different
paragraph settings. Styles can be defined

4 .  M a in f unctions
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for example, contains many different styles
including List, Text and Title. Clicking on
any of these items, will reformat the selec-
ted text or paragraph using the selected
style. Another way is to type an existing
style name in the Styles combo and to press
Enter.

If you want to change style settings simply
select a text block and apply modifications;
then click in the styles’  toolbar and press
Enter. A window will be displayed asking
if you wish to make changes to the style,
select “ Modify style by using selected text
as example” . An alternative method is to
use “ Format >Styles...” , then select the
style and apply your changes.

If you simply apply a style to a paragraph,
pre-existing formatting is retained. To
clear all existing formatting, and keep all
paragraphs true to style, use “ Format
>Reformat” .

The “ style”  concept is a relatively recent
thing, originating from word processing
and desktop publishing applications. The
majority of applications distinguish
between style and format:

You can use styles in many different ways.
The easiest way to create a new style is to
apply text attributes to a text block. As an
example, you can select any number of
words, set a size of 15 and apply bold to
the text; then write a name for the new
style in the styles drop down menu on the
toolbar and press Enter. A window will
appear asking you to confirm the new sty-
le’s parameters.

Another way
to create a
new style is
by using
“ F o r m a t
>New style”
directly from
the menu: the
window in
Fig.30 is
di spl ayed,
allowing you

to define all the parameters for your new
style.

To apply a style to a paragraph or a text
block, you must click on the Styles combo
box arrow. The help file (indexCDFE.aeh)

Fig.30 – Here you
can define a new

Style or modify an
existing one; you
can even copy a

Style from another
hypertext using

"Import".

Before starting a new
project it is always a
good idea to spend a few
minutes to set up the
styles you will use. This
will save a lot of time if
you later need to make
modifications.
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− Link to other hypertexts: Fig.31
shows how we can select another hy-
pertext and the page we want to link
to. Select the destination page for the
link visually, as the program provides
us with a preview of the pages, and
enables us to surf through them;

− Link to an Internet address: CDFE
keeps track of all URLs referred to in
the current hypertext. As shown in
Fig.32, we can choose the address to
link to from a list, or we can add a
new one by clicking on the "+" key;

− Link to an embedded file (see Chapter
3 also): we can include a text file or a
ZIP or a PDF or any other file within
a hypertext (.AEH file). We can
browse for a file in the file system
using the window displayed in Fig.33.
Clicking on the link will display the
file. If the selected file has an unk-
nown extension, CDFE will ask for
instructions;

− Link to external files, see Chapter 3;
− Link to a page copied from a tem-

plate: You can link to a new page

− “ Style”  means all properties defined
in the Style applied to a paragraph.

− “ Format”  applies to the same attribu-
tes, but those applied locally with
toolbar buttons or with “ Format
>Font...”

You can have two paragraphs that appear
identical on the screen, but are in fact
different. CDFrontEnd maintains this di-
stinction, as does MS Word and certain
other editors, because this is what users of
styles expect.

Links
Let’s take a look now at some different
link types, in addition to the ones we’ve
seen in Chapter 1. As already stated, crea-
ting a link is as simple as selecting a text
block and clicking the chain tool-button,
but we can also choose “ Insert >Link”
from the menu. In the displayed window,
depending on the tab we select, the fol-
lowing links can be established:

− Link to other pages of the hypertext
(see Chapter 1);

Fig.31 - Here you
can define a link to

a page in another
hypertext. The

simplest ones are
when both
hypertext

documents are in
the same directory.
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Fig.32 – Here  you
can insert a link to

an Email, or
Internet address

(URL) ; this is
accessed using

"Insert >Link".

Fig.33 - This
window allows you
to include any file

within your
hypertext; access it

using "Insert
>Link". See

Chapter 3 for more
information...

Fig.34 - This
window allows you
to create a link to a
new page, created

by copying it from a
template.
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Images
It is possible to insert an image by clicking
the ‘ Insert Image’  tool-button, or by selec-
ting “ Insert >Image/Map”  from the menu.

The window shown in Fig.35 displays,
allowing us to select the source of the
image to include. This can be from disk,
from an existing image in the internal al-
bum or from another hypertext.

To take an image from the internal clipart
collection, you must select “ From disk”
and then click on the “ Clipart”  button (the
icon with the mountain and the sun).

Once an image is inserted you can:

− Assign a link to the image: using the
right mouse button you can “ Define a
link”  the same way as for the text

copied on-the-fly from a template
(Fig.34);

− Link to a new page copied from an
existing one within the current hyper-
text (ebook);

− Link to a new page copied from an
existing one in another hypertext;

− Link to a new empty page: this is the
simplest link that you can add detail
to later;

− Link to images: It is not only possible
to link to images, but also sections of
a picture using hot-spots; These
methods will be dealt with in later
chapters;

Expert users will be able to use additional
special links (Chapter 7).

Fig.35 - You can
insert an image

from the internal
album or from a

disk  using "Insert
>Image".

Fig.36 - Inserting a
clickable zone (hot-

spot) into an
image.
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using the right mouse button or through the
“ Image >Properties”  menu item. Figs.39-
41 show the related windows with all con-
cerned tabs.

You can also apply transparency to your
images and enlarge or reduce them.

It is also possible to use images that
change when the mouse cursor passes over
them. This method uses two different ima-
ges that are shown depending on the cursor
position (see Fig.40). Of course, these
images can link to a new page.

Another useful feature allows you to re-

links shown above. Details of special
links follows later.

− Define one or more clickable zones or
“ hot-spots”  (an image with hot spots
is also called “ image map” ): using the
right mouse button you can select
“ Add area / hot spot” . Hot-spots can
be moved and resized; it‘ s possible to
define a link for each hot-spot using
the right mouse button, the “ image”
menu or the toolbar. Use DEL to
delete a hot spot.

Several properties are available for ima-
ges; you can access the editing window

Fig.37 - It is very
easy to create a

photo album - you
drag and drop a
group of photos

from the hard disk
or from your digital

camera...

Fig.38 -...then you
select the options
(the program can

automatically
create thumbnails
and can link them

to popup
windows...) and

you press
“Create”...
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Fig.39 – Use the
image properties

window  to define
alternative text for

the image, together
with many other

settings.

Fig.40 - It is
possible to choose

an alternative
image to display
when the mouse
cursor is over it.

Fig.41 - This
window allows you

to replace every
occurrence of an

image used in the
whole hypertext in

one hit.

included in the hypertext.

I cons, thumbnails, photo
album
With “ Insert >Image gallery / photo al-

place an image, either on a single page, or
using automatic substitution throughout the
entire hypertext (see Fig.41). In addition,
using the “ Album”  window (“ Hypertext
>Images - files - link archive and erase” ),
you can globally interact with all images
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Fig.43 - This
window allows you
to define and insert

tables.

Fig.44 – Once a
new table is

Inserted, it can be
resized by dragging
the grey rectangles.

Fig.45 - TheTable
properties window.

frame. You may force the program to re-
sample the large image (say your images
are 2400 x 1600 and you need images with
a more reasonable size such as 640 x 400).
If the thumbnails link to popup dialogs (the
popup contains the large image) you can
set up the popup properties, including a
background image or color.

bum”  (Fig.37 and 38) you can automati-
cally create a photo album / image gallery
quickly, by selecting a group of images
(maybe from a digital camera). Say you
select 10 images, then the program will
automatically create 10 thumbnails and
will l ink them to either a simple page
(image + title), a popup window, or a given
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add or delete rows and columns, change the
background color of a cell, etc…).

Placing your cursor over a table cell and
using your right mouse button gives yet
another modification option. Choose
“ Properties”  and the window in Fig.45 will
be displayed, allowing you to define the
properties for your table, such as border’s
width or the background. From here you
can also assign a fixed size for your table
or a percentage relative to the main win-
dow.

Using the tab in Fig.46 you can act on a
cell’ s background, on a row or on a co-
lumn. It’ s interesting to note that each cell
can have a colored background, an image
or can be transparent.

What’s more, tables can be “ nested” , that
means you can build a table inside a cell of
another table, and so on.

You can select a whole table using the right
mouse button and “ Select table” .

To copy a whole table, simply select it and
press CTRL+INS; then move to your requi-
red destination and press SHIFT+INS, it
really is that easy.

This automatic feature is available only
within the Gold edition (in any case it is
not so difficult to manually create thumb-
nails with a graphic program... then you
can link them to popup dialogs with
“ Special links” , see Chapter 7).

Tables
Tables are not merely a way to put num-
bers and letters into columns. In video
publishing, tables with transparent borders
are the best way to position objects on the
screen. Other programs designed for the
paper allow “ absolute”  positioning on the
screen, but this feature has to be avoided
or viewing pages becomes strongly depen-
dent on the user’s PC video resolution.
Users viewing your CD with a lower/hi-
gher screen resolution would not see the
CD as you had intended.

Using “ Insert >Table”  will display the
window shown in Fig.43, where you can
choose from several predefined table
layouts.

You can modify these tables if required,
using the “ Tables”  menu or by using the
tool-buttons on the toolbar (e.g. you can

Fig.46 - Properties
of the selected cell

and the column it
belongs to.
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A  common method to make an hy-
perlinked document more appealing and
usable is to split the screen into different
sections, or frames.

CDFE offers you many tools to simplify
the creation and modification of frames. It
also enables you to copy your frame
layouts to different pages.

Creating frames
Creating frames with CDFE is really very
easy: all you need to do is to drag and
release one of the notched bars that are on
the screen sides.

As you will notice, in most of its windows,
CDFE treats pages that contain frames as a
single page. In particular, the master page
of the frame-set will always be referred/
displayed. The master page is the page
shown when the frames button is relea-
sed.

You can use this button to switch between

“ Frames”  and “ No frames”  mode. This
button has no effect on the page’s struc-
ture, it’ s just a display option for the editor.
As said, the master frame is the only one
shown in the preview windows, so it is
important.

Let’s make a simple example. Start by
creating a new hypertext with “ File >New
hypertext” , and split the page (#0) into two
sections by dragging the notched bar on the
left (see Fig.50). If you do not see the
notched bar on the left, click the ‘Show
frames’  button. You will notice that pres-
sing and releasing this button shows the
master page, the one on the right.

Now we want to build a structure where
“ page A”  and “ page B”  can be selected
from a list displayed in the left window e.g.
a simple menu. The selected page is di-
splayed in the right window, without the
left frame being affected or changed in any
way.

To demonstrate this, we’ re going to create
a new page with “ File >Add new page” ,
then drag out a frame using the bar, as we

5 .  F ra m e s  a nd
f ra m e  s e ts
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by the two frame set.

Please note that by changing the value of
the “ Size”  box, we can set the same size
for both “ Page A”  and “ Page B”  left
frame, for example 25%.

Links
All we have to do now is to insert links.

did before (Fig.51). Now click in the left
frame, then using your right mouse button,
click and select “ Choose page in
frame…” ; the window in Fig.52 will
open. In the box “ Page in frame”  we will
select “ Choose existing one” : the window
will change as in Fig.53, allowing us to
insert the “ Index”  page into the frame. In
this way, the “ Index”  page will be shared

Fig.50 - We’ve just
created two frames
by simply dragging
the left bar across

to the right, and are
currently entering

text in the right
frame.

Fig.51 - Recreating
the same frames

layout in a new
page of the
hypertext…

Fig.52 - Let’s fill the
left frame with the

same page as used
in the previous

frame-set…
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links, as described in Chapter 7.

Copying layout of existing
frames
Now we’ re going to see a simple way to
copy and edit frame layouts. The following
method is available using “ Format
>Advanced frameset manager” . This will
open the window in Fig.56 and is called
from Page B.

The page layout is shown on the right.
Clicking on a frame, the preview of the
page contained in the frame itself will be
displayed at the bottom of the dialog, hel-
ping us when choosing the page to display
in the frame. On the left side the program
shows all the parameters of the selected
frame (name and properties).

The tab “ Copy from other page”  is useful

Selecting the text-block “ page B”  and
choosing “ Insert >Link”  will display the
window in Fig.5, allowing us to select
"Page B" as the destination. Now do the
same for “ Page A” .

When finished, it should look like Fig.55.
Clicking on “ Page A”  or “ Page B”  in the
left frame should display the corresponding
page on the right.

Several ways are given to build a set of
frames like the one just demonstrated. In
the example just created, the page changing
is achieved by replacing both frames; but
since the frame on the left is the same, only
the one on the right appears to change to
the user.

In fact, it would be possible to only change
the right frame, keeping the one on the left
unchanged. This requires us to use special

Fig.53 - It’s
possible to insert

any page of the
hypertext into the

frame…

Fig.54 - Let’s
complete the page
by writing "page B"
in the frame on the
right. Now we just
need to set up the

links.
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case, the only non-master frame is the
“ Index”  one). Pressing “ OK”  will lead us
to Fig.60, where the right frame is the
master page of “ Page C” .

As you will notice, this is a very quick and
easy way to create side menus and, also to
reproduce frames.

It is possible to position the master frame
on the left or at the bottom, rather than on
the right, using the “ Advanced frameset
manager”  window.

You can save the current frame layout as a
template (button “ Save”  in Fig.56), or al-
ternatively, you can use a previously saved
template as the current page, using the
“ Load from template”  tab (Fig.61). From

for replacing the current page layout (we
could have a frame-set or simply a single
page) with the layout of another page of
the hypertext.

As an example, let’ s try to create page
“ C” , identical to page “ A”  and “ B” . First
let’ s create a new empty page with “ File
>Add new page”  (or by using the shortcut
button on the lower toolbar). Then let’ s
choose “ Format >Advanced frameset ma-
nager”  from within the new page; this will
open the window in Fig.57. Here we select
the tab “ Copy from other page”  and choose
“ Page A”  (Fig.58). At this point we need
to click on “ Copy also non master frames”
to copy the full layout of page “ A”  (in this

Fig.55 - Our first
frame-set: clicking

in the left menu will
display our

selected page in
the right frame.

Fig.56 – A view
from the Advanced
frame management

window, showing
properties of the

current page: here
you can also

specify frame
borders, disable

scrolling, etc...
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turn to the editor and you will see the
layout copied.

Floating frames
You can insert a frame as shown in Fig.62

this tab simply choose the template you
want to use and click on “ Copy layout” . A
preview will be displayed, as shown in
Fig.56. All that’s needed now is to confirm
your choice with the “ OK”  button, to re-

Fig.57 - The
Advanced frame

management
window when

called from an
empty page.

Fig.58 – This
demonstrates the
"Copy from other

page" tab being
used within the

Frame-set
properties window,

to select an
existing page in the

hypertext

Fig.60 - We’ve
copied the same

layout of pages A
and B into an

empty page; now
we can write in the

page (the master
section on the

right)…
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Fig.61 - You can
save time by

copying layouts
from the

templates, or
save new

templates to
save time in the

future.

Fig.62 - A page
containing a

floating frame...

using "Insert >Floating frame". A dialog
window will display as shown in Fig.63
and you have the option to include any
hypertext page within the frame.

Fig.63 - The dialog
window for

independent
frames. You can

also call it by
clicking on a frame

with the right
mouse button, and

selecting
"Properties".
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T he simplest links available in CD-
FrontEnd are the “ normal links” . As seen
in Chapter 1 you can insert them by selec-
ting a text block and using “ Insert >Link” .
If you need something more elaborate and
powerful, you have to use “ Insert >Special
link” . Note that special links work only
with the editor in read only mode
(“ Hypertext >Read only” ), or within the
selfextracting ebook.

We suggest that you don’ t attempt using
special links until you are familiar with
the normal ones.

There are many available options. Firstly,
you can link to another page:

− with a click, a window will show
− a new browser window will show
− the destination page replaces the cal-

ling frame
− the destination page will show in

another frame or window

− the destination page will show as a
popup window

− the destination page is opened at a
fixed row, marked by an anchor (see
below)

Additionally, you can set up the following
behaviors:

− a click on the link will close a win-
dow

− link to a different position on  the
same page, using anchors

− a click on the link will show the
search by keyword window (click to
show the search window: this works
only in the editor/reader)

All these actions are “ visual” , i.e. you do
not have to do anything difficult or write
any code. We will also see how to open
windows automatically, as the user enters
a page.

Anchors
The simplest of the special links are the

6 .  T h e  “ s p e cia l ”  l ink s
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links to an “ Anchor”  within the same
page. Anchors act like a bookmark and
allow jumping to sections within a given
page. This kind of link is useful when you
have a very long page.

To insert an anchor, move the cursor to
the link destination and use “ Insert
>Anchor”  from the main menu (or
SHIFT+F5). An anchor icon appears. Se-
lecting it with your right mouse button
allows you to edit its properties.

Now select the text block or the image
you want to link to your anchor, and use
“ Insert >Special link”  (on an image, use
your right mouse button and click “ Define
special link” ). Click on OK in the window
that will be displayed. You will then see a
dialog where you can select the destina-
tion Anchor. Click on the anchor (a num-
ber is assigned to each anchor and will be
displayed in the box at the bottom right),
and then click OK. You can test the result
in “ read only”  mode (“ Hypertext >Read
only” ).

If you later need to modify the link desti-
nation, place the cursor on the link, use
the right mouse button and select “ Link

properties” . In the dialog window di-
splayed, select “ Visual edit...”  (Fig. 103)
or “ Link target page...” .

You can also link to an anchor inserted on
another page. Select a text block, use
“ Insert >Special link”  and select the se-
cond tab (Fig.104). In the “ Target page
shows:”  area, choose “ in current window”
and click OK. You will then select both a
destination page and an anchor (see
Fig.105).

Showing windows
From the special link dialog, choosing the
third tab allows you to show the destina-
tion page within a separate window. You
must define a name for the new window
(see Fig.106), this name can be used later
to change the window content for exam-
ple.

If two links use the same name for a
window (e.g. “ Goofy” ), and you click first
on the link #1, then on the link #2, you
will not show two different windows, so it
is imperative that each window has a uni-
que name. That is, unless you really want
to show the same window from two diffe-

Fig.100 – Showing
an anchor within a

page, these are not
visible out of edit

mode.
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Fig.101 - The
special link window

Fig.102 - Here you
can select the

destination anchor

Fig.103 - Properties
of the link just

inserted...
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rent links.

The separate window can be shown as an
ordinary window, or as a popup window.
The difference is that a popup closes whe-
never a user clicks on it, or clicks on
another window. If the destination page is
a frame-set, you can choose to show the
whole frame-set or just the “ master”  page
(see Chapter 6 to learn about the master
page).

Choosing the second tab (see Fig.104)
and selecting “ opening a new browser
window” , will show the destination page
in another instance of the browser (this is
different from a normal “ window” , as it

will include the navigation bar).

With the 5th tab you can close any win-
dow, by name.

Links inside/to frame sets
Now we will see some useful links that
work within frame-sets.

Suppose that we have the layout as shown
in Fig.107: We want a link from a word or
text block in the right window, that repla-
ces the content of the same window while
leaving the left window unchanged. To
obtain this, we simply choose “ in current
window, replaces caller page”  in the tab

Fig.104 - More link
types

Fig.105 - Let’s
choose a

destination page for
the link, and an

anchor. The link
dialog allows many
different link types.
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shown in Fig.104: when we click OK, the
program asks for the destination page
which can, as usual, be chosen visually.

Another possible choice is more difficult to
explain than to use: The tab shown in
Fig.108 which allows you to visually
choose the frame where the destination
page will be shown. Please note that you
can also manually insert the destination
frame name (frames can be named using
“ Format >Advanced frameset manage-
ment” ). This is useful for linking to
“ floating frames”  (see Chapter 6) or to link
to a separate window, or a frame within a
separate window. Any window with the
specified name will have its content repla-
ced by the destination page when the user
clicks this type of link.

Using the last tab, it is possible to activate
some special features: you can for example
display the "Search" window which is very
useful. Additionally you may place a link
that will allow to print the current page or
a different frame (so you can place a
“ Print”  button or a “ Click here to print the
page”  text).

All these links work with text blocks, sin-

gle words, images and hot spots (Fig.36).

Showing windows without a
click
Using “ Insert >Page functions >Open/
Close windows”  you can open or close a
window as soon as the user enters the
specified page. A “ functional block”  will
be inserted in the page, and will be activa-
ted when the page is shown.

The “ functional block”  properties may be
modified using the right mouse button, (see
Fig.109). Here you can define the window
attributes, or supply the name of the win-
dow to be closed.

The online guide contains live examples
that can be opened in the editor (the file
specialLinksCDFE.aeh - you may find it
with the MSWindows Start >Find feature).
There are lots of tricks to enable full use of
these resources.

Trick: to show two windows with a click,
use “ Insert >Special”  link to place a link to
popup. Inside the popup, use “ Insert >Page
functions >Open/Close windows”  to show
the second window (use a different name
for the window!).

Fig.106 - More
available link types

and properties...
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Fig.107 -  A simple
frame set, used as

an example

Fig.108 - You can
visually select the

link destination
frame, and the

linked page

Fig.109 - Show /
close windows
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F orms allow the users of your CD to
send you data by the Internet, if they have
an Internet connection. The data are
usually sent to a program called a script,
or CGI function, that runs on the WWW-
server computer, or by email.

Forms are available in CDFrontEnd
GOLD.

Your host may include in your hosting
account a pre-installed set of form script
programs: there are many Web sites
where you can find programs such as
these for free, or for a nominal fee. You
can also set up the form so that the data is
sent to an e-mail address (this is the most
common way if you don’ t have direct
access to the server).

A form typically consists in one or more
edit boxes and buttons. Each edit box has
its own identifier e.g. “ Name”  or
“ Address” . When you click the form but-
ton, usually “ Submit” , the edit box identi-

fiers and their contents are passed to the
CGI program or sent to an e-mail address.
The form start marker’ s properties deter-
mine what happens when the form is sub-
mitted.

Inser ting forms
Using “ Insert >Form >Form element”  we
can insert any kind of form element. Fir-
stly, you will be asked  for a “ form start
marker”  (Fig.71). The form start marker
is mandatory and specifies the action
taken by the browser when the user pres-
ses a form “ Submit”  button. If you are
unsure of where to position the marker,
simply press OK. You have the option to
change the form start marker properties at
any time, using the right mouse button and
“ Properties” .

In the next dialog (Fig.72), you could
select the first tab for example, and insert
your email address if you decide to have
the input data sent by email.

Then with the next window (Fig.73), you

7 .  T h e  f orm s
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Fig.70 – An
example page

containing a simple
form

Fig.71

Fig.72 – A Form
start marker

contains
information such as

where to send the
form content, once
a submit button is

clicked

can insert edit boxes, memo, lists and
other elements useful when creating a
form. It is very important to assign a
different identifier for each element, apart
from the “ radio buttons” . “ Radio-buttons”
are used in groups offering your user a
choice, and only one item may be selected.
The identifier must be the same for all
buttons within a  group, while the “ button
name”  identifies the actual button.

Fig.70 shows a simple form, with a text
cell and a button. To insert a button, use
“ Insert >Forms >Button” . There are two
kinds of button, submit and reset. The
reset button simply resets all form fields to
their original state. The submit button
starts the action specified in the form start
marker. The button can be a “ classic”
button or an image. To use an image as a
button, simply click on “ select image”
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Fig.73 – This
window displays all

of the available
form elements

Fig.74 - A slightly
more complex

form...

Fig.75 – An
alternative form

start marker
demonstrating how

page jumps are
used with forms...
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Fig.76 - Here we
select a page to
show when the
user clicks the
submit button

(you can select any image from the internal
album).

You can insert more than one form within
the same page. No “ form end”  marker is
required. If you include two forms on the
same page, the form start marker of the
second form will also act as the “ form end”
marker for the first form. Each “ Send”
button will be active only for the form that

contains it.

Fig.74 shows an interesting example: we
define a form that will toggle a page
change. Firstly we must ensure that the
form start marker is defined as in Fig.75.
Then, for each included button, we have to
define the destination page, as in Fig.76,
using the “ Advanced”  tab of the button
properties window.

Fig.77 –
Demonstrating

Image buttons in
use.
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T he following multimedia objects are
directly supported:

− pages with background music
− pages with buttons to start music
− pages with avi video; mpeg; mov
− pages with Flash™ (Gold edition

only)
You can then insert links to any kind of
external file, see Chapter 3.

Sounds and video
Use “ Insert >Animation - sound”  to insert
an animation or a sound. Interesting isn’ t
it? You will see the dialog shown in
Fig.80. To choose the audio or video file,
click “ choose file” . Don’ t we make it easy
for you? The window shown in Fig.81 will
be displayed. For audio, you can use any
wav or mid file, together with any format
supported by your MSWindows install. If
you have already used an audio file on
another page of your hypertext, you can
easily select it using the second tab
(Fig.82).

For video files, the process is very similar.
With “ action kind”  you can choose if you
want a loop action (e.g. background sound,
or repeated animation) or to show a
“ console” , a set of buttons that the user
will use to start the sound or video.

The “ loops”  box indicates how many loops
are allowed, if “ loop”  is selected as the
action. For example if you choose “ 1”  you
can insert an action that will be executed
when entering the page.

Flash
Use “ Insert >Flash”  to insert a Macrome-
dia Flash™ (or Swish) animation. You
will be asked for the .SWF file name, then
the Flash file will be inserted with a de-
fault size of 50%. With the right mouse
button (Properties) you can edit the size
and (if needed) the HTML code related to
the Flash. You can use invisible tables to
position the Flash rectangle.

Please notice that this function is available
in the Gold edition only. If Flash is not
present, it will be installed.

8 .  M ul tim e dia  a nd
a dditiona l  f unctions
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Fig.80 – Insert
animation and

sounds using this
window

Fig.81 - Here you
can insert a file

(sound or
animation) that will

be embedded in the
hypertext

Headers and footers
Each page can have a header and / or a
footer. There is no special edit area for
headers and footers, these are managed
separately. In short, you can use any page
as a header or a footer for any other page.
If you want a global header for the entire
presentation:

− Create a page and insert all the things
you want in your header (a logo, a
sentence, etc.).

− Select “ Hypertext >Current hyper-
text properties” , click the second tab

(Fig.94), and the “ browse...”  button
near “ header” . In the window that
will be displayed, choose the page
that you have just created

With “ Format >Current page properties”
you can define a private header for any
page (Fig.95) or choose None. Footers are
handled in the same way.

Slides
Using “ Insert >Page functions >Slides”
you can instruct the program to replace the
current page with a different one, after N
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Fig.82 - CDFE
mantains an

internal album with
all sounds and

animations used in
the hypertext

seconds. The window shown is the one in
Fig.96. This is the function used in “ ? -
Help >Show demo” .

With “ Hypertext >Slides”  you can use the
more comprehensive window shown in
Fig.97, where you can set up a whole slide
sequence: pages (slides) may be selected
from the whole hypertext, and you can
simply change the sequence using “ drag &
drop” .

Keywords
The program permits you to create a list of
keywords for the whole presentation / bro-
chure / manual /catalog, and you can as-
sign some of these to each page.

While the full text search function is auto-
matic, the keyword list and the keywords

related to each page should be set up ma-
nually. You can setup a global keyword
list with “ Hypertext >Keywords” . In the
window shown, select the “ Add global
key”  button (the yellow key with the green
+). Then use the left button to add a given
global key to the selected page. You can
add up to 20 keywords to each page.

Any presentation comes with a built-in
keyword search and full-text search en-
gine. You can prompt users to press
“ Search”  to start a search, or you can even
place a link or an image/button that shows
the search window when clicked: to do
this, use “ Insert >Special link”  and select
the last tab. The search does not work on
external files.

Fig.94 - Global
header and footer

for the document...
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Predefined page order , table
of contents
CDFE allows you to create a tree structure
for organizing your document. You can do
that by using "Hypertext> Pages order".
Such a structure can be utilized by the final
user to get a sequential print of the presen-
tation / catalog / manual.

By choosing "Insert > Index" the program
will automatically create a hypertextual
index containing all links to the document's
pages: you can choose whether to order
pages alphabetically or by page number, or
even by following the tree-structure’s pre-
defined order.

Fig.95 - Header
and footer for a

page (Page
properties dialog)

Fig.96 - The
simplest way to

switch a page to
another one

(shown) after N
seconds...

Fig.97 - Using this
dialog we can

easily set up a
page or slide
sequence...
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postal mail, or its content can be sent to
your email address (if the user is connec-
ted).

To define the shopping cart properties use
“ Hypertext >Current hypertext proper-
ties” , then the Cart tab (Fig. 201). To add
a shopping cart link, select a text block and
use “ Insert >Link to shopping cart” , or

C DFrontEnd includes a visual shop-
ping cart facility for creating your CD
Catalog (Gold edition only). A click on a
text block or on a image can be used to add
a product in the shopping cart. The shop-
ping cart is shown in a popup window: the
window can be printed and sent by fax or

Fig.200 - Use
“Insert >Link to

shopping cart” to
allow the user to
add a product in

the shopping cart...

9 .  S h op p ing ca rt
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select an image and use “ Image >Define
special link...”  (then last tab). Each link
contains the product price, currency, de-
scription and the product code.

The shopping cart properties window is
shown in Fig.201: you can define an email
address (the cart content will be sent to
that email) or the path of a CGI script, a

fax number, a remark for users, and you
can choose the colors for the shopping cart
rows.

You can also define some custom fields for
the cart / order form.

If the user closes the cart window or uses
the “ Reset”  button the cart content is dele-
ted.

Fig.201 - the
shopping cart

properties dialog...

Fig.202 - We
inserted two

products in the
cart... (to view the

cart, Insert >Link to
shopping cart, then
click on the link, or

double click if in
the editor)
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rate thumbnails, as well as shopping cart
buttons / links.

The function is accessible from the main
menu, “ File >Import from database /
CSV” .

There are dozens of different database
brands out there (Oracle, DB2, Microsoft
Access, MySQL, Interbase, Paradox, In-
formix, Fulcrum, DBase, SQL server, Fox-

CDFrontEnd includes a visual data-
base import facility for creating

your CD Catalog (Gold edition only).

This feature permits you to create a catalo-
gue quickly, by importing data from a data-
base or from Excel. You can use images
and the program can automatically gene-

Fig.203 - The first
tab for the

database import /
automatic

catalogue creation;
here you can set

up the input file
format (fields,

delimiters...)

1 0 .  D a ta b a s e  /  C S V
im p ort
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Pro, Firebird, and much more...). We wan-
ted to provide a generic tool, so we chose
to rely on CSV format (comma separated
values), as any database (and also other
programs such as Excel) can export to a
CSV file. This permits you to use any
database.

Please see your database User’s Manual in
order to learn how to export to a CSV text
file - you may also use the CDFrontEnd
user’s forum to exchange information with
other users.

A simple example
The fastest way to learn how the import
works (and the meaning for the different
sub-tabs) is to use a sample file supplied
with the program, a file that works with the
default settings.

Please just press the “ Load CSV file”
button on the first tab and choose the file
catalog_example_cat_and_subcat_ex1.tx
t. As you may see this is a text file: you can
open it with the MSWindows NotePad and
you can use it as a sample of what you
should obtain from your database.

The file relies on some images that are
contained within the same folder (you may
also choose another folder for images with
the “ Options”  tab, Fig. 207).

If you touch nothing, and you press the
“ Create”  button on the bottom left, the
program will ask you to choose a Template
(from the Template tab). A template is
simply a one-page AEH file saved within a
particular folder. You can create infinite
new templates - the layout of your catalo-
gue is completely customizable. Within the
template you may use some keywords, that
will be replaced with live data. For exam-
ple, $$title$$ will be replaced with the
product title, $$image$$ with the product
image. You find these special words listed
on the first tab (Fig. 203).

Just press the Create button to see how it
works. It will extract the data from the
CSV file, create several pages, and then
put you on the index page. You may see
the other pages with CTRL+ and CTRL-.

In the example provided, the products are
audio CDs, the subcategories are music
artists, the categories Rock, Country, etc.

Fig.204 -
Subcategories tab;

if subcategories are
present, you may

list the products
with thumbnails

and you can apply
a header and a

footer to the subcat
pages...
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You will see that when you press “ Create”
it creates a main index, category pages,
subcategory pages, and product pages.
You may experience some variations by
using the various subtabs.

Very quick and nice, isn’ t it?

Usually you press the “ Load CSV file”  in
order to see your CSV file within the white
text box. Then you try to match it with the
gray text box, by configuring the Separa-
tor, the Delimiter, the fields on the right.

With the “ Test parsing”  button you can
then perform a test on the input file. The
program will attempt to read the first line
of the file and to parse the various identi-
fiers, generating a report that you may use
for refining the settings or the CSV file,
before the actual import.

Categor ies and subcategor ies
Your own file may have either categories +
subcategories, subcategories only, or pro-

Fig.206 - Product
templates tab;

each product page
will be copied from

the selected
template; the
keywords are

replaced with the
database / CSV

data...

Fig.205 - the tab
related to Products

settings. The
product pages are

copied from the
template in Fig

206; here you can
set up the image

properties, the add
to cart links (if

needed), header
and footer...
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ducts only - just check / uncheck the op-
tions on the right of the first tab.

If the input file contains subcategories (in
the example, the products are audio CDs,
the subcategories are music artists, the
categories Rock, Country, etc.), the second
tab (Fig. 204) contains the properties for
the automatically generated subcategory
pages.

If “ include thumbnails”  is checked, the
subcategory pages will contain the product
listed with thumbnails. If not, a simple text
list. The subcategories pages may have a
header and a footer: as usual for CDFron-
tEnd the header (or footer) is another page
of the hypertext, so if you don’ t have a
header yet, you should exit from the CSV
import dialog, create a new page, label it
as “ subcat header” , fill in it with the hea-
der stuff (logo, statements, etc.) then return
to the CSV import dialog.

Product pages and templates
The third tab (Fig. 205) contains the set-
tings for the automatically generated pro-
duct pages (in the example, audio CDs

images and descriptions). Click on the
image in order to see the other tabs, and for
more information.

The product pages are copied from the
template selected within the template tab
(Fig 206). A template is simply a “ single
page”  AEH file saved within a particular
folder. Within the text you can insert spe-
cial symbols such as $$title$$ that will be
replaced with the database fields (these
symbols are listed on the bottom left of the
first tab).

Each product page can contain one main
image (possibly in multiple copies). Within
the template, the image is defined with
$$image$$ (this text is replaced with the
actual image). The actual image may be
inserted: as is, scaled to a given width,
scaled and linked to a popup window that
will show the large image. If the main
image is scaled, and linked to a popup (that
contains the larger image), you can decide
the popup properties: it can have a back-
ground color or image; its size can be fixed
or automatically related to the image size
(plus a X and Y offset).

Fig.207 - Options
tab; you can

choose a style for
Heads and Text

(subcategories and
categories); the

images path; load
and save settings...
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If the template contains the $$buytext$$
symbol, this will be replaced with a link to
the internal cart (with data extracted from
CSV) or a link to a cart URL (you choose
if internal or cartURL on the bottom right).
If the template contains the $$buyimage$$
symbol, this will be replaced with an
image linked as $$buytext$$.

Last but not least, just like subcategories
you can have a header and a footer for the
product pages.

Within the options tab (Fig. 207) you can
set some additional options. One is the
folder that contains the images (by default,
this field is empty, and the folder is the
same folder that contains the CSV file -
you can load the CSV with the button on
the top left of the first tab). Another one is
the style for Heads and texts, for catego-

ries’  and subcategories’  pages. You can
choose from the existing styles (see Chap-
ter 5 for creating new styles). Then you
can say if the long description is normal
text (line breaks - CR LF are not allowed)
or HTML (only basic tags are allowed,
such as <font> <b> <i> etc. ).

The option “ decode double delimiter”  me-
ans that if the fields within a CSV record
are delimited with (say) “ , a real “  is coded
with a double instance, e.g. “ field1” ,” field
2 with some words here “ ” real quotation
marks” “  and some other words” , ” field
3” ;

With the buttons on the bottom left, you
can Load and Save the settings of the
powerful CSV dialog.
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B esides the powerful features offered
by CDFE to create “ well built”  pages, we
would like to provide some useful sugge-
stions about creating and paging presenta-
tions / catalogs / manuals, although this is
really not the aim of this manual.

Creating a good work is not merely depen-
dent on the richness of graphics or special
effects, nor an on-paper paging experience.
Even if the usual communication and
marketing rules are adopted, as for com-
mercial publications, the electronic world
is a media apart from all traditional ones.

In this chapter we give some tips for
making a professional and useful docu-
ment, even without super-graphics and ex-
pensive software

Displaying information on the
screen
Displaying information on the screen is
very different from presenting it on paper.

In traditional publishing, the page-maker
just needs to choose the page's size and can
then begin adding text and pictures.

Using the same methods for on-screen pa-
ging may well result in ineffective di-
splays, since the dimensions are dependent
on the video resolution set by the user, not
by the author of the page. Typical screen
resolutions can vary between 640x480 and
1600x1280 pixels on different monitors,
going from 10 inch  to 21 inch screens. So,
how can we cater for everyone’s require-
ments?

There are different solutions. By conside-
ring the fact that a minimal resolution of
640x480 or 800x600 is available to
everyone, we could set such values as
typical during the design of pages. Ac-
tually, this is the choice adopted for many
professional works on CD. Nevertheless,
this solution may be considered very limi-
ted by the user, who would like to take
advantage of a more powerful video card,
leaving our work appearing to be of a low
quality.

1 1 .  G ra p h ics  a nd
p a ging p a ge s
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Fig. 134 - A correct
page when shown in

different windows

Another simple solution may consist of
preparing the work as if it were a book or
paper magazine. For example, we can de-
fine the A4 or US Letter format for all
pages, and then provide the user with a
reader that has zoom capabilities for use
on a small monitor. If we do this, pages
will have a fixed size and the content will
be the same for all video resolutions.

This is the method adopted for a lot of
works provided with Adobe Acrobat Rea-

der. In our personal opinion, this method is
not ideal for users who have small moni-
tors or with monitors working at a low
video resolution.

Everything's relative
CDFE adopts a third method based on
automatic justification. Using this method
the displayed content has no absolute posi-
tion value, but is dependent on the width of
the current window. Firstly, text fits accor-
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ding to the window’s width: this means
that if you narrow the window, the length
of each text line will change accordingly,
as shown in the example in Fig.134.

To be effective, when using this strategy, it
is essential to position all objects on the
page using percentage or relative values,
rather than absolute values. Looking at
Fig. 134 and Fig.135 we can make a com-
parison using the two methods: unfortuna-
tely, with absolute positioning, the user’s
screen must have the same video resolution
and the same window size you used, in
order to get the correct display. To quote a
statistic, this scenario may apply for only
10-15% of users; this suggests that the
highest percentage of users would see a
more or less, reasonably laid out page. All
things considered, it would be better to
accept the in-percentage tables philosophy,
since it is evident that it has a reason of
being.

Invisible tables
How can we insert in-percentage tables
making them fit for all resolutions? Well,
it’ s very easy indeed, since they are the
default used by CDFE.

Let’s make an example now, by recreating
what is shown in Fig.135, but this time
changing the absolute references which
make the page video resolution dependent.

The example shown in Fig. 135 is a page
we found somewhere on the Internet. We
“ rob”  the images and the text for our
example. Firstly let’ s save the three images
or let’ s create them. Then let’ s run CDFE
and define the page’s background as white
using “ Format > Page properties” . If you
wish, you can also insert an image as the
background. Now we have to put the three

images saved previously (“ Insert >
Image” ) and an invisible table (“ Insert
>Table” ) with two columns to put text in.
We can define the percentage for the two
columns simply by right-clicking within
the two cells shown on screen (second tab,
as shown in Fig.44). The result should look
the example in Fig.139. At this point we
can insert the text, and the page should
then look like Fig.140: enlarging or nar-
rowing the window should not affect the
page quality.

Please notice that you can insert a table
within another table, so you can create
more sophisticated structures, if needed.
Again, we suggest you to try and try again,
as this is the best way to learn how to use
the advanced features offered by CDFE.

Backgrounds
One of the greatest differences between
video and paper publications is the use of
backgrounds.

Printing backgrounds on a paper-made pu-
blication is very expensive and sometimes
may affect the readability and spoil the
overall appearance. This same treatment,
when applied to CD pages, may well result
in a visual enhancement.

In Fig. 141, 143 and 148, we can see some
examples that demonstrate the use of back-
grounds.

We can assign a background to a table’s
cell through the usual window shown in
Fig.44. It is however important not to over
use this feature. In general, we discourage
the use of backgrounds that have too much
contrast, saturated colors or too much de-
tail, because these can affect text readabi-
lity and take focus away from the subject
matter. If you really wish to use them, we
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Fig. 135 - A page
with fixed tabes seen

at different screen
resolutions.

It is a Web page...
this is an old

example and we are
too lazy to redo it!

suggest that you put a colored table where
you want to insert a text block (see Fig.
143, where we have used nested tables).

Clickable maps, hot spots and
browsing bars
An interesting way to link different pages
is to create special images that contain
some intelligent areas, which, when
clicked, will generate the loading of the
linked page. In Fig.154 we show a sophi-

sticated example, but we could simplify
this by making a bare horizontal bar.

We can insert a clickable zone (hot spot)
by positioning the cursor over the chosen
area and right-clicking with the mouse
(“ Add area / hot spot” ). A small rectangle
appears with four white corners. We can
then move the rectangle and resize it by
dragging the white corners in order to
define the intelligent (clickable) zone. By
right-clicking on the newly created hot
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Fig. 139 - Let’s insert
the images and let’s

create a table with
two coloumns,

without borders...

Fig. 140 - ...then let’s
write (you will see the

dotted lines just in
the editor; they aren’t

shown in the
published CD).

Fig. 141 - Page with
a repeated square

background

spot, we could go on to define a link.

It is important to take into consideration
that some users may not be able to take
advantage of the graphic links. To provide
them with the opportunity of browsing our
pages, it would be advisable to replicate
the links elsewhere on the page in a simple
text format, even if only in small sized
characters at the foot of the page.

Accompanying the program, you are provi-
ded with many different examples of
button-bars and clickable maps. Using the
same bars throughout the same presenta-
tion / manual /catalogue will improve uni-

formity and will contribute to the overall
style of your work.

Taking all of these points into considera-
tion, we should say that designing button
bars or maps is not as easy as it could at
first seem. If you are not experienced with
graphics software, it may take some time
before you obtain a satisfying result. For
an easy software for creating buttons, see
our Web site. Nevertheless don’ t give up,
but try to get some help from an experien-
ced friend or from a specialized video-
graphics publication
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Fig. 143 - If you
apply a coloured

background to the
table the text is more

readable

Fig. 148 - Lens
effect. You can do

this with two different
backgrounds, similar

but with different
color tone.

Frames
Frames are a very useful feature, espe-
cially while designing complex CDs. Fra-
mes allow us to split pages into more
sections. A very common implementation
consists of using an index or box contai-
ning a selection-list on the left side of each
page. Using frames so that we don’ t have
to physically repeat the same menu for
every page; and at the same time, make
browsing much easier.

Some authors discourage the use of fra-
mes. Actually, the practice of discourage-
ment should not be applied to the correct
use of frames, but rather for those making
bad use of them.

It is interesting to note that by choosing ‘0’
as the value for the borders of a frame, the
borders will be invisible to your readers,
and you can also hide any scroll-bars.
Using these features, you can easily create

some interesting effects for your CDFE
works.

Please refer to chapters 6 and 7 for more
details concerning the use of frames and
related special links.

Don't exaggerate!
With a little practice and your powers of
observation, you will soon get excellent
results with the several opportunities offe-
red by invisible tables, frames, back-
grounds and clickable maps.

To further enhance your work, some
graphics software is almost a necessity.
Use it to develop effects such as texture,
lens, aliasing and fading and also to create
your own buttons, image maps, split-line
and backgrounds.

Having said all that, only one more rule
requires attention. In order to create really
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Fig. 154 - A nice
image with hot

spots (www.
fantascienza.

com).

efficient and optimized pages: “ don’ t
exaggerate!” . With so much power in your
hands it's very difficult to set a limit, but to
keep your readers interest, it’ s necessary to
create light, quick and efficient pages, so
don’ t overdo the effects.

With this same aim in mind, we suggest
that you use the same background for all
pages, that you don’ t use more than two

different fonts (one for the text blocks and
one for titles) and no more than 3 font
sizes. Following these recommendations,
we are sure you will cope with creating
attractive and well-made pages. Nothing
else is needed.

Have fun with CDFE!
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F or any question, email the support staff:
cdfrontend@visualvision.com

For Immediate response to frequent que-
stions, read below!

− tutorials, basic questions
− link and pages, hypertext functions
− tables
− images, hot spots, areas, backgrounds,

icons, thumbnails
− styles and fonts (CSS)
− frames
− templates
− HTML - Applets - AEH - ASP
− download / .DOC / .ZIP / .PDF / Flash

/ Import files
− CD protection and publishing; autorun,

autoplay; database;
− generic questions
− purchase

TUTORIALS, BASIC
Are there any tutorials for main features?
Yes, use F1, then click “ tutorials” .

Can CDFrontEnd manage frames? And what
about the mouseover? The popup windows?
Does it protect my work? Does it make the
coffee...?
The answer is always yes (well... not for the
coffee, but we’re working on it...!). To learn
more, read all this manual and take a look to the
online manual (F1).

I have used another editor before, and I can’ t
understand how to manage HTML files with
CDFrontEnd...
CDFrontEnd is a standalone tool, not a
"compiler", you don’ t need to deal with the
HTML. If needed, you can import old HTML
pages with “File >Import” .

Is CDFrontEnd HTML compatible?
Our program has its own internal standard that’s
independent of HTML. It will display on any PC
as it doesn’ t need any Explorer or Netscape
installed. If you get HyperPublish
(www.hyperpublish.com) you can save your
CDFrontEnd’s works in HTML.

I am very interested in your compiler. What
program would you suggest that I write my
document in so that I can take advantage of the

1 2 .  F re q ue nt q ue s tions
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features but is not too complex?
CDFrontEnd is an all-in-one tool! It encloses a
powerful multi-page editor and can create the
CD with just a click. No external programs are
needed!!!

I saved the CD as in Chapter 2. When I inserted
the CD, it only displayed the cover page. There
is no way of getting to another page. How do I
do this?
You must place links to let the user browse the
other pages. The ways to browse pages provided
INSIDE the Writer are for authors only. The
reader can just follow the links YOU place. If
you don't place links, they will not see any other
page other than the cover.

I have a manuscript all ready. I want to know
how to get it into the program in order to
continue and see how your program creates the
CD. What are my first steps?
If your work is in another text format, use "File
>Import" then choose the format. If not, just start
the program and type on the keyboard. CTRL+
for adding new pages. CDFrontEnd has its own
editor, you don't need external programs. See
also the Tutorials, "?-Help" "Help" then
"Tutorials".

Can two pages be viewed at once, just like a
book?
Yes, you can use a table with two columns or
you can create frames and then place links. It's
very simple. Please remember that the page
number in the bottom box is just a facility for
you, the author, and you can show the reader a
completely different page number (just type it at
the bottom of the page). The page number di-
splayed in the bottom box has nothing to do
with your book's page number.

I imported HTML pages, but nothing is showing
up!!
Use CTRL+ & CTRL- to move between pages.

I want to create a Web site.
See www.hyperpublish.com or www.1site.info

LINK AND PAGES, HYPERTEXT
FUNCTIONS
I don’ t understand the way CDFrontEnd saves
pages.
All CD pages are saved in a whole “AEH”  file.
With “File >Save all”  or with the toolbar button,
you save all presentation / hypertext pages with
a single click.

...in the tutorial it says:...then, let’s press the
link button in the toolbar (sheet and chain, or
> "Insert >Link" from the main menu)... but
there is no button labeled "link" in the tool-
bar...and which toolbar?
Select a text block, then choose from the main
menu “ Insert”  then “Link”  if you aren't able to
find the button with the image of the sheet and
the chain. If you are on an image, use the right
mouse button, and choose “Define link” .

How can I set the size of a page?
You can’ t set the size of the page, as you can’ t
know what monitor and what window will be
used by the people that will see your site. The
safe way is to always use % tables (it is the
default in CDFE) and not to assume that the
pages have a fixed size.

I want to change the page numbering as I want
to insert a page between page 1 and 2, but I
can’ t.
Yes, you can’ t. If you really need to do that, you
can insert say a page #3, copy the #2 to #3 with
“Edit >Paste page from...” , then delete all the
text within page #2. Agreed this is not quite
what you are looking for, but the automatic
numbering is very useful to optimize the publi-
shing speed. Please remember that the end user
will not see the CDFrontEnd page numbers, only
the page titles, so it really makes no difference. If
you were to label page 24 as "Page 1" and page
45 as "Page 2" this would have no effect on your
readers, as the CDFE page number is just a
facility to allow you to switch pages without
having to remember the proper page names.
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Can I change the number of page #0?
This is not possible. If you want to set another
page as home page, simply choose “Hypertext
>Current hypertext properties” , and click on the
left, on “cover” . Any page can be used as cover,
not just the #0. The #0 is just the default.

How can I fix a page width to 535 pixels, in
order to obtain the ideal setting when printed to
paper?
You can fix this width for a table. Use the right
mouse button on a table cell, and click
“Properties” . However, it is better to use %
tables, so your work will display well on all
monitors, from 10 to 19” .

How can I place a link inside the same page?
The links within the same page are called
“Anchors” . You need first to place the
“Anchors” . In order to do this, move the cursor
to the link destination and use “ Insert >Anchor”
from the main menu (or SHIFT+F5). You will
see an anchor icon. If you select it with the right
mouse button you can edit its properties. A
number is assigned to each anchor.
Now select the text block or the image you want
to link, and use “ Insert >Special link”  (on an
image, right mouse button, “ Define special
link” ). Click on OK in the window that will be
shown. Then you will see a dialog where you can
select the destination Anchor. Click on the an-
chor, then click OK. You can test the result in
“ read only”  mode (Hypertext >Read only).

How can I link to an anchor placed in a diffe-
rent page?
Select the text block you want to link, then
“ Insert >Special link” . In the dialog that will be
shown, do not choose the first tab but one of the
others (e.g. second tab “Normal” ), then OK, and
select the destination page. Within the preview
of that page you can click on the destination
Anchor (the number will be copied in the box
that’s on the right at the bottom of the window).

I've not been able to find out if I can have
different colors for links in the same frame...

You should define different text styles. Each text
style can have its own color/style for the links.
Use "Format >Styles", then the last tab ("link").
You can also set up the style of the link
(underlined, bold, or so).

Where can I find information about pages con-
tained in a document / CD / presentation? How
can I manage pages?
Creation: "Insert >New page", "Insert >Link",
"Insert >Special link".
Deletions, management: "Hypertext >Images /
files /link archive and erase".
Access: "Hypertext >Go to page", the bottom
center page number box, right mouse button on
this box.

When I'm editing an * .aeh file, how can I delete
a page (in my case page 0 as it is empty)?
Page 0 can't be deleted. For other pages, use
"Hypertext >Images /files /link archive and
erase". You can also cut & paste another page to
fill the page 0.

I don't understand how to insert a link.
Select a text block, then press the button with a
page and chain. In the window displayed, you
can link to an existing page in the hypertext, or to
a newer one - more options are also available.
If for example you choose "new page", then press
OK, CDFrontEnd will create the new page for
you, and will show the page in the editor. If you
link to an existing page, you can choose it from
an active preview - active means that you can
navigate through it like in a browser. When you
press OK, the link is made and CDFE shows the
destination page in the editor. See also the tuto-
rial and Chapter 1.

How can I link an external Html page, for
example an Html page that already exists on my
Web site?
Select a block, chain button, choose "Internet",
click the “Add”  button and write in the left box
the address (e.g. "http://mysite.com/ my-
page.htm"), then press "OK".
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How can I manage the pages different from the
main one? Just with links?
In the bottom center there is a box with the
current page number. Click on it with the right
mouse button, you will have a list of the most
recent visited pages. You can also use
“Hypertext >Images - files - link archive and
erase” , “Hypertext >Go to page...” , “File >All
pages...” .

How can I copy a page within another in same
hypertext (with Html I can do it with "save as",
then "open". Is there another way in CDFron-
tEnd)?
"Insert >New page", then "New page by copying
existing one"; or "New page by copying from
another hypertext", ...
You can also use "Edit >Paste page from...".

How can I manage headers and footers?
If you use "? >Help" and search for the keyword
"header" or "footer" (Search >Keyword search)
you'll get the answer.
In short, you can use any page as header or footer
for any other page, i.e. if you want a global
header for the whole site:
- create a page and insert within it all things you
want in your header (a logo, a sentence, etc.).
- choose "Hypertext >Current hypertext proper-
ties", second tab, and press the "browse..." but-
ton near “header” . In the window that will be
shown, choose the page you just created.
With “Format >Current page properties”  you can
define a private header (or no header) for any
page.

Do you have some step by step guidelines on
how to create, open, and close popup windows?
To open a popup, select a text block, "insert
>special link", 3rd tab (independent window or
popup). To close a popup, in the page where the
popup should be closed, use "insert >page func-
tions >open/close windows", then specify the
name of the popup. The popup is closed on
entering the page. You can open the .aeh files
used as examples (speciallinks.aeh).

I can only get to non-linked pages when I am in
the "edit/preview" mode, by using the page
scroller (the box at the bottom of the screen,
with the page number) or CTRL+-.  Is this
normal?  Will normal keyboard/mouse paging
work when this CD is "published"?
No, you have to place links. The other ways to
manage pages are only active in the editor (this
simplifies the creation / management of pages).

Is there a limit to the length of the URL you can
insert with "Insert >Link", 3rd tab?
Yes, there is an internal limit.

Will your program allow me to create an index
at the top of a page, create a paragraph or
graphics several lines down the page, use the
indexed item as a heading for the paragraph or
graphics and link to it, also add a 'return to top
of page' at the end of each paragraph?
You can insert any kind of links but you have to
insert links manually.
You can use "anchors" for links within the page.
The program can create an automatic linked
index with "Insert >Index". To repeat a block on
the top of a page, use the Header function
(Format menu).

TABLES
Does percent % size mean the table will auto-
matically be sized to the content?
It means the table will fit the screen pixel width,
using a %. When you insert a new table, the
software use 100% as the default. Unless you
have a particular requirement, do not change this
setting. It will fit automatically any browser
window.

I inserted an image in a table. Why does it
appear in all cells?
Perhaps you inserted the image as the table
“background” . If you want to insert an image as
a single “cell”  background, use the right mouse
button on the cell, “Properties” , second tab, then
click the Sun and Cactus icon.
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When I have to write words in 3 columns do I
have to insert a table or can I just use the space
bar?
It is better to use a table. Never use the space bar
as, if you view the page from another PC, the
size of the space might be different and you will
lose the alignment.

How can I create a table with more than a
column within a row?
You can insert a new table with any rows or
columns within a cell of another table.

How can I delete/copy a table?
Delete: There are many ways. For example put
the cursor on a cell, press the right mouse button,
then choose "Select table", then press DEL.
Copy: Select the table as above, then press
CTRL+INS. Move the cursor to the destination,
then press SHIFT+INS.
I'm having a problem formatting text in a table.
The table text automatically formats itself to
Times New Roman (my default font is Arial) and
I also can't select the entire table, column or
row to apply the required formatting.
The table default style is "[no style in tab]".
Simply change that style with "Format >Styles".

How do I lock the position of text within a ta-
ble, so that it does not reposition when the
browser window is resized?  I know in many in-
stances locking the text position is not desira-
ble, because the size of monitor used to view
the site will vary. Despite that, I have certain
text that I do not want to reflow, regardless of
what the visitor does with his browser window.
Simply fix the width of the table column contai-
ning the text. Use the right mouse button, pro-
perties, second tab, then choose "fixed" for the
table cell width. Or for the whole table.

IMAGES, AREAS, HOT SPOTS,
THUMBNAILS, BACKGROUNDS,
ICONS
Animated GIFs don't play in the editor!
Move to preview mode (Hypertext >Read only).

How can I move images and position them
somewhere in the page? I can’ t position an
image as I would like.
The “ fixed”  position for an image is good when
you create a text that will be printed on paper,
but has no sense for a CD, where the reader can
see your work inside an unknown width win-
dow. Your user might use a 600 pixel or a 1200
pixel width window, and you don’ t know that.
The best thing to do then is to create a work that
will be seen well on any PC, in other words a
work that all readers will like. To do this, simply
use “ invisible”  tables (i.e. tables without any
border) to position images on the page.

If I want to add a caption near to an image is it
better to use tables or frames?
Better to use a table.

How can I delete an image inside a table?
Select the image and press DEL two times. If the
image is a background, choose “Table
>Properties” . To delete the table, right mouse
button, “select table” , DEL.

Can I write some text over an image, similar to
using layers in a graphics program?
No, you should use PaintShop PRO or a similar
graphics program to achieve this.

Is there a fast way to change the image back-
ground for all pages of a site?
There are two ways. If the background is already
an image, use “Hypertext >Images - files - link
archive and erase” , select the image, then press
“Replace...” . Otherwise there is a button in the
bottom right of the second tab of “Hypertext
>Current hypertext properties”  dialog.

How can I place text beside an image?
Create a simple table with one row and two
columns. Inside the first column, insert the
image. Inside the second one, insert the text.

I am having trouble inserting an image with
transparent background. Sometimes it works
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and sometimes not.
It should work for the large majority of GIF
images. However, not all images are suitable to
be automatically converted using the included
transparent-color processor, so you may have to
proceed manually with paint programs such as
Paint Shop PRO or Corel Photo Paint.

I see the "paste from clipboard" can perform
the automatic conversion of a WMF to a GIF /
JPG format with a lower byte size. As I already
inserted WMF images, can I convert them to
GIF in some way or must I reinsert them?
Unfortunately, you must reinsert.

I can't insert animated GIFs with "Insert
>Animation"!
Please use "Insert >Image".

Where can I find the included clip art?
In the “ Insert >Images”  dialog, “From disk” ;
click on the icon with the mountain and the sun.

In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.

How can I insert pictures that will be enlarged
in a separate window when you click on them?
Should I use the click area / hot spots? What
can I do with a click area?
A click area is useful when you want to assign
different destination links to different sections of
a single image. For example let’s say you have a
picture of yourself. You can assign an area to the
eyes, an area to the mouth, and so on. A click on
the eyes may display a page where you talk about
your wonderful blue eyes and so on... :o)
If you want to create a gallery with some thumb-
nails linked to larger images in a separate win-
dow, you don’ t need to use hot spots. Simply
use “ Insert >Image gallery / photo album”  (Gold
edition). Or create a page containing a series of
small images, then insert a new page for each
enlargement and assign links to each small
image (right mouse button, “ Define special

links” ). Inside the “special link”  dialog you can
specify to use a popup to display the destination
link (the page containing the larger image), and
you can specify a name for the popup.

Is there a way to place icons of thumbnails on
my page, then click to view a larger image?
Yes, use “ Insert >Image gallery / photo album”
(Gold edition). Or just insert a little image (you
can do it with a paint program) then insert a link
(right mouse button, "Define link") to a page that
contains the larger image. If you use "Define
special link" you can also show the larger image
in a popup.

How can I set a background image or a back-
ground color for a page?
“Format >Page properties” , then click the icon
with the cactus and the sun.
You can also insert tables using an image as the
background (click on a table or on a table cell
with the right mouse button, then properties).

I designed a navigation bar in Paint Shop PRO,
how do I insert that into a page and add links to
each button?
“ Insert >Image”  then add hot spots (clickable
areas) with the right mouse button, then define
links with right mouse button.

I have an image and some text on one page. I
want the text to line up on the right of the image,
and I suppose using a frame will do it, but I can’ t
get my image into a frame.
Better to use a simple table, rather than a frame.
Just use “ Insert >Table”  then use a table with 2
columns, 1 row (if you want to create frames,
simply drag the top or left border of the edit
window).

I imported a picture into my document. Is there
any way to add a border?
You can do this with a paint program.

Is there any way to assign an image as a border
for a page? I have an image that is about 1 inch
wide and I want it wrapped around the page.
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Can this be done?
You can create a table with 3 rows x 3 columns,
and use the image as background of the 8 exter-
nals cells (right mouse button from within the
cell, then select "Properties"). If you edit the Style
of the paragraph that contains the table ("Format
>Styles"), you can eliminate the upper and exter-
nal borders that this solution often leaves.

STYLES AND FONTS
If I change the font height, sometimes this is lost
when I write additional text. Why?
Do not move the cursor after changing the font
style.

Can I save a style?
Yes. Simply write its name in the styles cell, then
press ENTER, and the settings of the current
paragraph will be saved as style. You can also
import styles from another hypertext. For creating
new styles you can also choose “Format >Styles” .
See also the proper chapter for more info!

How can I recall a style I saved?
Simply click on the styles cell and select the
required style!

How can I change the style of the links within a
table?
Like any style, i.e. by using "Format >Styles".
The default style for tables is [no style in table]

I have created a CD  and used some of the fonts
installed on my computer for the page. The
problem I have is when other people install and
view it, the fonts are not the same as the ones I
used to create the CD. Should I use just fonts
that are universal on all computers?
Yes, Times New Roman, Arial and Courier New.
If the user has MSWindows + Office usually also
Verdana and some others. It is not possible to
distribute fonts due to copyrights. If you want to
use a fancy font for titles, you may use transpa-
rent images - we have a free "plugin" that permits
you to do this automatically (you select a text, you
click a button, the text is instantly transformed

into an image by using the current font). The
image will be identical for all the end users.
Please see www.visualvision.com/plugin/ "text
to image" plugin.

FRAMES
How can I delete some frames I inserted?
You should delete them frame by frame. To
delete a frame you should move its border to the
top or to the left (depending of the kind of the
frame). It may be faster to choose “ Format
>Advanced frameset manager” , to load a sim-
plest frame set from a template, then press OK.

How can I remove the frames border?
Choose "Format >Page properties >Frame pro-
perties" (or use the right mouse button). In the
dialog, uncheck the box “show rectangle border”
and write 0 inside the “border between frames"
box.

I am working with frames and I noticed that the
frames will not allow me to align text/images to
the top right-hand corner. It looks like the fra-
mes have a top margin of about .5". Can I get
rid of this?
Yes, define a style where the top margin of the
style is something with a negative number (-0.01
should be sufficient) and apply that style to the
first paragraph, then you may insert a table
within that paragraph and experiment within it.

I want to add a page with frames. I want to use
as an existing page as a frame.
Create a new frame set. Within a frame, use the
right-click mouse menu to select which page
will fit the frame. You can also use "Format
>Advanced frame set management". See the
chapter about frames.

I have a page with too many frames. I went to
"hypertext", then "images - files - hyperlink
archives and erase" and tried to delete the
pages with the frames. When I go back to the
page, the frames are still there. What am I
doing wrong?
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You probably deleted another page. When
working in the page with the frames, press the
"no frame" button at the bottom of the page. That
switches the view to "no frame" mode, (note: it
doesn't actually delete the frames, it is just a
display option). This way you will see which is
the master page for the frame set. Delete it and
the frame set will be deleted. Another way to
delete a frameset is to replace it with another,
(Format >Advanced frame set manager).

I've tried to create frames, but why does the
page reappear on the previous page or the fol-
lowing one when you copy and paste the page
on the split page with frames?
Please read the complete manual. Each new
frame is in fact a new page, so if you create a
frame-set in page 0, containing 3 frames, if you
go to page 1 you will find the 1st frame created
in page 0, if you go to page 2, the 2nd and so on.
This allows you to use the same frame (e.g. a
menu) in different frame-sets without having to
copy it. To select the page that fits a frame, just
use the right mouse button within a frame, then
select  "Choose page in frame".

TEMPLATES
The templates seem to be in Italian! Where could
I get English ones?
The templates are not in Italian. It is a dummy
latin-like language that has no meaning. The text
is there purely to fit the page for demonstration
purposes. You can replace it with anything you
like.

CD, AUTORUN, AUTOPLAY, DATA-
BASE
Must I pay any royalties on the CDs that I  will
create with CDFrontEnd?
No.

Just recently I have created a small CD. I'm
using the full screen setting and would like to
have a link on each page for closing the CD, but
I can’ t locate the information about how to do

this. Should I reset the CD to be viewed in a
window rather than full screen to be able to
have closing controls? Can I insert a link such
as “ click here to exit” ?
Write the sentence, select the text block, “ Insert
>Special l ink” , select the close window tab,
check the “main page”  checkbox.
Close is also available using the right mouse
button.

I created the CD and when I insert it I see a
blank page!
Please use “Hypertext >Current hypertext pro-
perties” , second tab, then click the “Cover page”
button on the bottom left, and choose a non-
empty page as cover page.

When I save my CD , and put it on another
computer, all I get is an empty, gray page and
cannot see or read the other pages.
This is because the default "cover" and
"summary" is page 0. If your page 0 is empty,
nothing is shown. If you want the user to see
other pages, you must properly set the Cover and
Summary pages, and you MUST place links. All
the internal methods that CDFront End provides
for browsing pages are available only to the
author. The reader must click on links to switch
pages, so YOU decide what can be read by
whom, and in what order.

Can a person print the entire CD at once with
one click or do they need to print each page one
at a time?
Yes they can use File >Print all. It prints the CD
in the order you defined with "Hypertext
>Predefined page order TOC".

How do I keep the file size to a minimum?
The thing that increases the file size is the num-
ber and type of the images included. Use a
graphics program such as Paint Shop PRO in
order to compress the images: for photos, the
best format is .JPG. For line art, cartoons, etc,
the best one is .GIF.

What can I do with an "AEH"? Can I only see it
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with CDFrontEnd?
You can see it with the free EBooksReader
(www.ebookswriter.com). If the AEH is not pro-
tected, you can see an "AEH" with almost all
Visual Vision products.

In case I want to distribute .AEH files, can I
distribute the free EBooksReader from my Web
site?
Yes, sure.

Can a user edit the CD?
Any user will see the CD in a read-only environ-
ment. The end user/reader is not supposed to have
the CDFrontEnd editor: you can however setup
an editing password and so disable editing even
in such cases ("Hypertext >Current hypertext pro-
perites").

Does CDFE support DB files when on CD?
No, CDFE does not support database (DB) files
on CD. But you can import (see below).

Can I import from a database? Oracle, Access,
DB2, DBase, Paradox, FoxPro, Excel, Informix,
Fulcrum, MySQL, SQL server, Interbase, Fire-
bird, Fox Pro?
Yes, save the data as CSV (comma separated va-
lues) + images, then use “File >Import from da-
tabase / CSV” .

Can I collect end user’s email / data?
Yes, see Chapter 3 (Gold edition).

PROTECTIONS: PASSWORDS,
COPY, PRINT, EXPIRY
Can I protect my pages with a password? Can I
leave some pages without a password?
Yes, sure.

Can I protect my CD with passwords? Can the
clipboard copy be disabled? Can printing be
disabled? Can I set an expiry date? Can I force
the CD to be shown "full screen"?
Yes.

Is the protection strong?
Yes, it is a 128 bit strong encryption.

My target is big business with lots of employees
and I don’ t know how to protect my CD from
sharing. Now lets assume that in one office
there are 10 employees and that 5 of them want
to buy my book. How do I make sure that if I
give the password to one of them he or she will
not share the password with the others?
The passwords for the CDs created with CD-
FrontEnd can be personalized for each user
without any effort. The first time someone reads
your CD, they will be prompted to enter a name
and email address. In CDFrontEnd there is a
dialog where you can insert that user name and
email address, and you will get a personalized
password that you can send to the user. The
password will work for this user only. This
feature can be enabled or disabled, it's your
choice.

I’ve tried the sample with different passwords
for different users but the user password doe-
sn’ t work, and also the author password,
“ mickey” , doesn’ t work!
When using personal passwords, the author pas-
sword works within CDFrontEnd only. It doe-
sn’ t work in CDs. To obtain the proper user
password, you must insert a user name and
email address in the “ Hypertext >Password”
dialog.

I am struggling to get to grips with the pas-
sword. I am happy assigning an author pa-
sword, but the reader password is beyond me.
Your examples do not explain what happens.
What does the reader have to do to get the
password and how does it relate to the pas-
sword window and boxes.
You can set a fixed password for all readers, or a
password that changes for each reader. Each
page can have a different password. The online
help gives you an example. In the example the
writer has added to the hypertext the password
"mickey". That password is known by the writer
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only, and will be changed to a different password
for any reader. You should not to give the pas-
sword "mickey" to the reader. For the reader
called "aldo ghigliano", that password is
"S\ZTOg". If you change the reader name you
will have another password. It is your responsibi-
lity to give the correct password to each reader.
To disable that feature, uncheck the box "custom
password for each user". If this box is unchecked,
when you save the CD, the password "mickey"
will be valid and identical for any reader.
The password "mickey" is assigned to the pages
that are in the list on the right and are checked. In
a new hypertext, to add a new password press the
"Add +" button, then enter the password. To
assign that password to one or more pages, check
the box in the list on the right.
The reader will use the menu “?”  then “Data”  to
insert his/her data.

Is there a way to only let the users print certain
pages?
At present no. If you want, you can disable
printing totally using: ("Hypertext >Current hy-
pertext properties").

I was reading about all the security features that
your program offers, but I did not see anything
on how you prevent individuals from making
mass copies and distributing it. For example, if a
customer purchases a CD from my site created
with your software, there is nothing technically
that prevents the individual from making multi-
ple copies. Do you have a solution?
Yes, he can makes multiple copies, but provided
you protected the CD with an individual pas-
sword, the password must match his name and
email address.
For example, you sell the CD to Mark Smith
msmith@ge.com. If he copies the CD, he would
have to give away his name and email address, so
it will publicly broadcast that he is a thief.

AEH - DOC - ZIP - PDF - FLASH -
JAVA - ASP
How can I insert an external file? For example a

ZIP, a PDF, etc.?
There are two basic ways, see Chapter 3 for more
information.

What can I do with an "AEH"? Can I see it only
with CDFrontEnd?
You can see an "AEH" with different VisualVi-
sion products and also with the free EBooksRea-
der (www.ebookswriter.com) which works on
the same principle as Acrobat Reader. An AEH
file contains a whole CD, so your work becomes
easy to share.

Can I insert Java Applets, JavaScripts, Flash
within a page? Can I use ASP?
No. The CD contains a custom browser that
doesn't support these things. The positive side of
the story is that each CDFrontEnd CD doesn't
need preinstalled software in order to be read.

Why does the size of the AEH remain the same
even if I delete some multimedia files ?
It is not sufficient to delete a link, a button or a
video with the CANC that deletes the button.
CDFrontEnd archives each thing you use in an
internal archive or “album” . If you delete the
link, the file remains inside the album, to enable
fast reuse. If you want to delete the file, please
choose “Hypertext >Images - files - link archive
and erase” , search the file then delete it with
DEL.

Can I save in PDF format?
Indirectly you can. If you have the Adobe pro-
duct installed, choose "File >Print" then print to
the "Acrobat Distiller". Otherwise you can in-
stall a fake PostScript printer (an Apple LaserJet
for example), print to FILE: (instead of LPT1),
save the file as filename.ps then use the free
Ghostscript (you can find it on simtel.net) to
convert from PS to PDF. A correct Ghostscript
command on the DOS prompt is gswin32c -q -d
-dPDFSETTINGS=/printer -
dCompatibil ityLevel=1.3 -dNOPAUSE -
dBATCH -sDEVICE=pdfwrite -
sOutputFile=c:\nomeoutputfile.pdf nomefile.ps).
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How can I import files?
To import, use "File >Import" and choose a file
format (RTF; HTML; ASCII), then search for the
files you want to import in the file system (shown
on the left) and drag them to the right. The
program can import multiple files at a time and
automatically divide a single file into pages. Use
CTRL+ CTRL- after the import to see the pages.
The import functions sometimes discard the text
format, so it would be better to use the native
program functions once you have learnt them.

When I import RTF, how does the system split a
single file into multiple pages, how does it decide
when to end a page and start a new one?
It uses an internal criteria.
You can choose (in the import format menu) one
file/one page or one page/one page. The latter
option ensures that page breaks in the existing
document are maintained in your created pages.

I have imported RTF pages, but most of them do
not include the "continue" link on the new pages.
You are supposed to write the pages INSIDE the
program. If you import the pages from another
program, YOU will need to add the links. The
program can place very powerful links, not only
the sequential links expected for a sequential
piece or book.

After importing, the very first page is blank and
I can not get rid of it.
Simply copy another page inside it. Alternatively,
change the settings of the program so that the
cover page and the summary page are not using
the first page (Hypertext >Current Hypertext pro-
perties), then second tab, then click on the left on
"cover" or "summary" and choose the required
page.

I imported an .rtf document and set up some
links to certain portions of it (hypertext?).  The
links work fine, but in the non-edit, preview
mode, I can only get to the linked pages, not the
ones without links.
This is normal, as the preview mode is designed
to work as if published, and no pages would be

available in a live situation, unless linked.

We have user manuals which were created
using another program. If we choose to use
your software, will we be able to maintain/edit/
revise the old manuals in it, or will they have to
be recreated?
If your other program is able to save in RTF,
HTML or ASCII formats, or at least allows
copying to the clipboard, you will be able to
import the data to our software (possibly some
reformatting will be required).

Can your program import Word Perfect format
(WPF files)?
No, but within Word Perfect you can choose
"Save as..." then save your file in RTF format,
that can be imported by our program.

GENERIC QUESTIONS
I can’ t find the answer to my question!
No problem, just write to us! We respond to all!

I can’ t delete some objects with DEL.
Use DEL twice.

The XYZ window displays too small for me!
Please resize the window. CDFrontEnd stores
and remembers window settings.

I’m writing a manual for an application and I
need to include multiple copies of the applica-
tion logo and application name. Is there a quick
way?
Create a new page, insert the name and the logo
of the application.
Then you can use "Edit >Paste page from..." to
insert the logo anywhere you want. You can also
use Headers and Footers, see Chapter 8.

I can’ t use tabs!
You can use the "reduce indent" and "increase
indent" buttons.

The copy and paste procedure sometimes di-
scards the text format.
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This can happen for short text, as CDFrontEnd
tries to use intelligent behavior when you cut
& paste. Sometimes the behavior is not exactly as
you might expect.

How can I make floating windows?
When a user browses your CD / hypertext, there
are two ways a window can show:
- when user clicks on a special link ("Insert
>Special link")
- when user enters a page that contains an "open
window" component ("Insert >Page functions
>Open / close windows"
See samples in "? >Examples".

In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.

I can’ t “ minimize”  the application.
Select “Tools >Program options”  then “Reset
dialogs settings” , then exit from the application.

I have a problem with the program locking up. It
seems to be related to the file I am working in
because I had a few other files I was working
with and I am not having the problem there. If
the fi le is corrupted in some way is there
anything I can do about saving some of the
pages? Help! I don’ t want to start over!
When a file is corrupted the most practical way is
to open a new file, and copy the pages (the
non-corrupted ones) from the old file, using "Edit
>Paste page from...".

I have CDFrontEnd. What is the difference with
iPer Hyper Publish PRO (HP)?
HyperPublish can create Web sites and autorun
CDROM (but with a different behavior: when  a
CD created with HP is inserted in the drive, it
shows a professional setup that can install your
work or part of your work on the user’s Hard
Disk). CDFrontEnd can read HP files, HP can
read non-protected CDFE files.

Do you have a Mac edition?

No.

I have an icon for email - I've checked the
tutorial and can't find out how to make this
work!
Very simple: select the image, right mouse but-
ton on it, "define link", 3rd tab, "+ Add" button,
then enter mailto:youraddress@aol.com

Can I insert forms in CDFrontEnd?
No with the PRO, yes with the GOLD; you can
link to a page that contains a form in your Web
site. If the user wants to send the form, he must
be connected, so this solution will be OK for all
cases.

I can't get the spell check working!
The application uses the MS spell check engine.
Some installations of Office 2000/XP mess
things up. Please see the Web Forum on
www.cdfrontend.com for a patch.

In a hypertext with lots of images, it seems as
though there are problems with previews.
Use “Tools >Program options”  to increase the
image cache settings.

The program says “ Access Violation XXXX” ,
then hangs...
You have too many applications opened (” too
mamy”  may mean 4-5 in Win98/ME...!). Close
some apps or restart the computer.
The error numbers like 00231245E are no use to
us at all. If this happens and you are able to
provide us with step by step instructions on how
to reproduce the error, (e.g. open the program,
write "mickey", press "save" and the error
ALWAYS happens) we can correct the problem.
Often it is not a problem with the program, but a
problem of limited handles within MSWindows.

If I switch to “ read only”  (Edit/Preview button),
the slides don’ t appear to work.
You have to use "Hypertext >reload page" to
start the slide sequence. To obtain this at load
time, configure the hypertext as "Read only"
using "Hypertext >Options".
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I have noticed that in some of my work, when I
resize the windows (larger or smaller), some
tables or images move and don't retain their
position. Is there a solution to this problem?
You would benefit from practising with the
"invisible" tables, and learn how to use them to
correctly position images and text. You must
remember that the final users screen and window
sizes are unknown. In the previous chapter you
find some useful suggestions on how to create
this kind of positioning.

What is the difference between CDFrontEnd
PRO and CDFrontEnd GOLD?
The GOLD edition has these additional functions:
forms, shopping cart, custom splash screen (just
edit gold.gif file or insert gold.jpg). And better
support, of course.

I don't see much mention of video on CD with
your product.  My needs are simple - I want to
create an autoplay CD that opens an interface
page that allows a viewer to select from several
short MPEG videos or a couple of documents.
It seems like this is no problem with your pro-
duct, correct?
Correct. You might want to provide a free MPEG
reader application on the CD in case the user's
PC has MSWindows misconfigured but this is
not a must as usually 99,9% MSWin PCs can
read MPEG.

Is there a way to setup a printing order for the
pages, so when the user wants to print, there is
a predefined order?
Just use Hypertext >Predefined order - TOC to
setup an order. You can define chapters and
subchapters, or just sequential pages.
Then with File >Print you can choose to print the
pages by using the predefined order.

I get "Share error... "
This means the same file is opened in another
instance of the program (go to the task bar and
close the other instance); or out of disk space; or
the AEH file is marked as "read only" in the
MSWindows file manager.

When making a CD, how can you add a link to
exit the program?
Just select a text block, "Insert >Special link",
then select the "Close window" tab, check the
"main window" checkbox.

PURCHASE - REGISTRATION
I created some pages with the LITE version, can
I use the project with the registered edition,
without having to redo it all?
Yes, sure.
www.cdfrontend.com


